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Abstract

Fluorescence-based imaging techniques, in combination with developments in light microscopy, have revolutionized how cell biologists conduct
live cell imaging studies. Methods for detecting RNAs have expanded greatly since seminal studies linked site-specific mRNA localization to
gene expression regulation. Dynamic mRNA processes can now be visualized via approaches that detect mRNAs, coupled with microscopy
set-ups that are fast enough to capture the dynamic range of molecular behavior. The molecular beacon technology is a hybridization-based
approach capable of direct detection of endogenous transcripts in living cells. Molecular beacons are hairpin-shaped, internally quenched, single-
nucleotide discriminating nucleic acid probes, which fluoresce only upon hybridization to a unique target sequence. When coupled with advanced
fluorescence microscopy and high-resolution imaging, they enable one to perform spatial and temporal tracking of intracellular movement of
mRNAs. Although this technology is the only method capable of detecting endogenous transcripts, cell biologists have not yet fully embraced
this technology due to difficulties in designing such probes for live cell imaging. A new software application, PinMol, allows for enhanced and
rapid design of probes best suited to efficiently hybridize to mRNA target regions within a living cell. In addition, high-resolution, real-time image
acquisition and current, open source image analysis software allow for a refined data output, leading to a finer evaluation of the complexity
underlying the dynamic processes involved in the mRNA's life cycle.

Here we present a comprehensive protocol for designing and delivering molecular beacons into Drosophila melanogaster egg chambers. Direct
and highly specific detection and visualization of endogenous maternal mRNAs is performed via spinning disc confocal microscopy. Imaging data
is processed and analyzed using object detection and tracking in Icy software to obtain details about the dynamic movement of mRNAs, which
are transported and localized to specialized regions within the oocyte.

Introduction

Cell biology studies that visualize dynamic events with spatial and temporal resolution have been made possible by the development of
fluorescence-based live cell imaging techniques. Presently, in vivo mRNA visualization is achieved via technologies that are based on RNA
aptamer-protein interactions, RNA aptamer-induced fluorescence of organic dyes and nucleic acid probe annealing1,2,3. They all offer high
specificity, sensitivity and signal-to-background ratio. However, RNA aptamer-centered approaches require extensive genetic manipulation,
where a transgene is engineered to express an RNA with artificial structural motifs that are required for protein or organic dye binding. For
example, the MS2/MCP system requires the co-expression of a transgene expressing an RNA construct containing multiple tandem repeats of
the binding sequence for the bacteriophage MS2 coat protein (MCP), and another transgene encoding a fluorescent protein fused to MCP4,5.
The addition of such secondary structural motifs to the RNA, along with a bulky fluorescently tagged protein, has raised concerns that native
RNA processes may be affected6. A technology that addresses this concern and offers additional unique advantages is the nucleic acid-based
approach, molecular beacons (MBs). MBs allow for the multiplex detection of endogenous mRNAs, discrimination of single nucleotide variations,
and fast kinetics of hybridization with target mRNA7,8. MBs are oligonucleotide probes that remain in a quenched hairpin fold prior to undergoing
a fluorogenic conformational change once they hybridize to their targets (Figure 1C)9. Several groups have had success in using MBs to detect
both non-coding RNAs (microRNAs and lncRNAs)10,11,12,13, RNA retroviruses14 and dynamic DNA-protein interactions15. They have been
successfully employed for imaging in various organisms and tissues, such as zebrafish embryos16, neurons13, tumor tissue17, differentiating
cardiomyocytes18, and Salmonella19.

Here we describe the design, delivery and detection approach for endogenous mRNAs in living D. melanogaster egg chambers coupled with
a microscopy set-up that is fast enough to capture the dynamic range of active molecular transport. The D. melanogaster egg chamber has
served as an ideal multicellular model system for a wide range of developmental studies, from early germline stem cell division and maternal
gene expression to the generation of segmental body plan20,21. Egg chambers are easily isolated, large and translucent, and able to withstand
hours of ex vivo analysis, making them highly amenable to imaging experiments. Much work has focused on the asymmetric localization of
maternal transcripts to discrete subcellular regions prior to being actively translated. In particular, oskar mRNA localization and its subsequent
translation at the oocyte's posterior pole must occur in a tightly regulated manner to avoid a lethal bicaudal embryo phenotype22. oskar mRNA is
transcribed in the 15 germline cells, called nurse cells, and actively transported through cytoplasmic bridges, called ring canals, into the oocyte,
the germline cell that becomes the mature egg and is ultimately fertilized (Figure 1A). The considerable amount of information already available
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regarding the dynamic recruitment and exchange of protein factors to and from oskar mRNP, along with its long-range intracellular travel, make
oskar a preferred candidate to study the many processes of the mRNA life cycle. MBs have been instrumental in revealing details about the
process of mRNA localization and deciphering the regulation and function of protein factors that control mRNA transport during Drosophila
oogenesis. In particular, by microinjecting MBs into nurse cells and performing live cell imaging experiments, the tracking of endogenous mRNAs
is possible8,23.

The roadmap presented here offers the steps of a complete process, from carrying out a live cell imaging experiment using MBs, acquiring
imaging data, to performing data analysis to track endogenous mRNA in its native cellular environment. The steps can be modified and further
optimized to meet the needs of researchers working with other tissues/cell types within their own lab setting.

Protocol

1. Design of MBs for Live Cell Imaging

1. Fold the target RNA sequence to predict the mRNA target’s secondary structure using the “RNA form” from the mfold server (http://
unafold.rna.albany.edu/?q=mfold/RNA-Folding-Form).

1. Paste/upload the target sequence in FASTA format, select 5 or 10% sub-optimality (structures with a free energy of folding within 5
or 10% of the MFE value, respectively), and adjust the maximum number of computed foldings accordingly (e.g. larger for 10% sub-
optimality).
 

Note: Inclusion of sub-optimal secondary structures when designing MBs allows for the identification of regions within the target mRNA
that may be more flexible or more rigid than as predicted for the minimum free energy (MFE) structure alone, which improves the
overall design of MBs suited for live cell imaging.

2. Select an “immediate job” for mRNA targets of 800 nucleotides (nt), or a “batch job” for mRNA lengths between 801 and 8,000 nt. Save
the “ss-count” file as simple text file.

2. Use the “ss-count” file obtained in step 1.1 as input for the PinMol program (https://bratulab.wordpress.com/software/) with the
desired parameters, to design several MBs for the mRNA target (see tutorials describing usage of PinMol program24 at https://
bratulab.wordpress.com/tutorial-pinmol-mac/).

1. Determine the specificity of selected MBs by performing BLAST analysis: use “blastn” with the appropriate database (e.g. for oskar
mRNA-specific MBs use the “refseq-rna” database and the Drosophila melanogaster organism).

2. Identify any tissue-specific expression of mRNA target (e.g. for oskar mRNA Flybase> High-Throughput Expression Data> FlyAtlas
Anatomy Microarray or modENCODE Anatomy RNA-Seq; http://flybase.org/reports/FBgn0003015) and compare with any positive
BLAST hits. Eliminate probes that show > 50% cross-homology with other mRNAs that are also expressed in the tissue/cell of interest.

3. Select the fluorophore and quencher pair appropriate for the microscopy set-up available to perform live cell imaging (e.g. Cy5/BHQ2)25.

2. MB synthesis, purification and characterization

1. Use in-house synthesis and purification as previously described7, or services from commercial providers, to synthesize and purify one to five
MBs (see above note), using the following labeling scheme: [5’(Fluorophore)-(C3 or C6 linker)-(2’-O-methyl MB sequence)-(Quencher)3’].
Purify MBs using reverse-phase HPLC, in house or using the services of the commercial provider.
 

Note: The phosphoramidites used for automated probe synthesis must have the 2’-O-methyl ribonucleotide modification. One can also use
chimeras of alternating locked-nucleic acid (LNA) and 2’-O-methyl modifications to increase the stability of a hybrid between a shorter MB
and its target mRNA26.

2. Synthesize DNA oligonucleotides that match the sequence of the targeted RNA region and thus are complementary to the probe region of
MBs, for use in in vitro characterization (see steps 2.3 to 2.5; above note). Maximize hybridization of the MB with the DNA-oligonucleotide
target mimic, by including on each end of the DNA target four additional nucleotides, as found in the target mRNA sequence.
 

Note: A more rigorous characterization of the MB’s efficiency to detect the targeted sequence can be performed using in vitro synthesized
RNA targets instead of complementary DNA oligonucleotides8.

3. Perform thermal denaturation of the MB alone, measure its melting temperature (Tm), and confirm that the MB assumes the desired hairpin
shape at physiological temperature. We have observed Tm values between 60 and 90 °C.

4. Perform thermal denaturation of the MB in the presence of the DNA oligonucleotide target and measure the MB:DNA target hybrid’s Tm, as
previously described7. A Tm between 55 and 60 °C is desired for the MB:DNA hybrid.

5. Perform in vitro hybridization reactions with the corresponding DNA oligonucleotide target, and determine the efficiency of MB:DNA hybrid
formation at physiological temperature, as previously described7. Fast hybridization kinetics with the DNA target mimic is desired, however
MBs that do not show high hybridization efficiency with DNA targets may have a better performance with the target mRNA in vitro and/or in
vivo.

3. Dissection and Preparation of Individual Egg Chambers for Microinjection

1. Feed newly hatched, mated females for 2-3 days with fresh yeast paste.
2. Anesthetize flies on a CO2 pad and, using fine tweezers (Dumont #5), transfer 1-2 females into a drop of Halocarbon oil 700 on a glass cover

slip.
3. Using a pair of tweezers, orient the fly with the dorsal side up under a stereomicroscope. Dissect the female abdomen by making a small

incision at the posterior end and gently squeeze the pair of ovaries into the oil.
4. Explant the ovaries onto an oil drop on a new coverslip. Gently hold one ovary with one tweezer while pinching off the youngest stages of

the ovariole with the other tweezer. oskar mRNA is actively localized at and after mid-oogenesis (stages > 7), and younger egg chambers
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( stages < 7) are more difficult to inject and do not survive as long. Slowly drag on the cover slip (with a downward movement) until individual
ovarioles or egg chambers are isolated and aligned vertically. Further separate single egg chambers by displacing the unwanted stages from
the ovariole egg chain.
 

Note: Ensure that individually teased egg chambers do not float in the oil, and that they adhere to the cover slip. This is important for both
successful microinjection and image acquisition.

4. Microinjection of MBs into the Nurse Cells of Egg Chambers

1. Prepare the MB solution, using one molecular beacon (e.g. osk2216Cy5), or a mix of two MBs that target different mRNAs and which are
labeled with spectrally distinct fluorophores (e.g. osk2216Cy5 and drongo1111Cy3). Use a concentration of 200-300 ng/µL each MB in
HybBuffer (50 mM Tris-HCl - pH 7.5, 1.5 mM MgCl2 and 100 mM NaCl). For a cocktail of four MBs labeled with the same fluorophore that are
targeting the same mRNA at 200 ng/µL each in HybBuffer (e.g. osk82, osk1236, osk2216). Spin down the MB solution immediately prior to
loading the needle for microinjection.

2. Select the objective. A 40X oil objective is recommended for finding an appropriate egg chamber and for performing microinjection.
3. Mount the coverslip with dissected egg chamber onto the microscope stage. Bring up the objective in the focus position and identify an egg

chamber at a mid-to-late developmental stage, that is properly oriented for microinjection (i.e., with the AàP axis perpendicular to the needle
tip to allow for easy injection within a nurse cell proximal to the oocyte).

4. Load a needle (commercial or prepared in house27) with ~1 µL MB solution (see step 4.1) and connect it to the microinjector. For
microinjections in D. melanogaster egg chambers, orient the needle (see Table of Materials) at an angle < 45° to the microscope stage (e.g.
30°) to avoid puncturing several nurse cells.

5. Set-up the injector with injection pressure of 500-1,000 hPa and compensation pressure of 100-250 hPa (see Table of Materials).
6. Slowly move the stage to bring in the field of view an area of the oil drop void of egg chambers.
7. Using the micromanipulator joystick, gently lower the needle into the oil drop and bring its tip into focus towards the periphery of the field of

view.
8. Perform a ‘clean’ function to remove the air from the tip of needle and to ensure that there is flow from the needle.
9. Bring the needle to the home position and focus on the egg chamber to be microinjected, then bring the needle back into focus and position it

near the edge of the egg chamber.
10. Perform a fine adjustment of the objective’s Z-position such that the membrane separating the follicle cells from nurse cells is in focus.
11. Insert the needle into a nurse cell and perform injection for 2-5 s.
12. Gently remove the needle and retract it to the home position.
13. Change the objective to the desired magnification for image acquisition (60-63X or 100X), focus on the egg chamber, and begin acquisition.

5. Acquisition of Data Using a Spinning Disc Confocal Microscope Setup

Note: See Table of Materials for our specific setup.

1. Set up acquisition protocol to record an XYZCt stack of 8-16-bit images (XYZ = volume, C = channel, t = time).
2. Select laser lines for the desired channels (e.g. 641 nm laser for Cy5 and 491 nm for GFP) and acquire the channels sequentially: first the

fluorescence signal in each channel and then change the Z position, to allow for proper colocalization analysis.
3. Select the Z step (e.g. 0.3 µm), and the top and bottom Z limits (e.g. -2 µm to 2 µm).
4. Input the acquisition time and sampling rate (e.g. every 15-30 s for up to 1 h).
5. Initiate acquisition.

6. Processing, Data Analysis to Obtain Tracking and Colocalization Information, and
Preparation of Video Files

1. Image Processing
1. Download, unpack, and open Icy, an open community platform for bioimage informatics (http://icy.bioimageanalysis.org/)
2. Open the XYZCt stack acquired in step 5: Image/Sequence >File>Open.
3. Convert stack to ImageJ: ImageJ> Tools> Convert to IJ, have Detached Mode ON.
4. Make a substack (a selection of a range of Z steps and time points to be further analyzed): ImageJ>Image>Stacks>Tools>Make

Substack…; select the desired channels, Z-steps and time points.
5. Save substack as TIFF file: ImageJ>File>Save As>Tiff…; use this file for subsequent steps.
6. Split channels: ImageJ>Image>Color>Split Channels.
7. Subtract background either using a background stack: ImageJ>Process>Image Calculator…, or using the Rolling ball option:

ImageJ>Process>Subtract Background…, select the Rolling ball radius. Preview the image for the radius selected before selecting
“Accept”.
 

Note: Background signal will mainly arise from improper quenching of the flurorophore. The signal:background ratio (S:B) is often
used as an indicator for an MB’s “brightness”, and it is measured from in vitro hybridization experiments of the MB and DNA target
oligonucleotide. For example, MBs osk1236 and osk2216 have an S:B of ~81 and ~120, respectively.

8. Adjust the brightness and contrast for each channel: ImageJ>Image>Adjust>Brightness/Contrast, select Apply.
9. Save each channel as a separate TIFF file: ImageJ>File>Save As>Tiff....
10. Merge the two channels: ImageJ>Image>Color>Merge Channels…; select the channels. Save the new stack as a new TIFF file (see

step 6.1.8).

2. Spot Detection and Tracking
1. Convert back to Icy: ImageJ>Tools>Convert to Icy.
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2. A scale bar is automatically overlaid onto the stack upon conversion to Icy, if the scale bar plugin is installed [Search using
Plugins>Setup>Online plugin]. If needed, edit the scale bar via Inspector window (right side of screen)>Layer tab>Name>Scale bar.

3. Deselect/inactivate the ‘eye’ icon for Scale bar from the Layer tab>Name to remove the scale bar from the original stack. It can be
reactivated on the final stack.

4. Save the newly processed stack by taking a screenshot using the “camera” icon from the Image Window’s menu bar, “Take a
screenshot of current view” and File>Save as>Tiff….

5. Determine spot sensitivity, if spot sensitivity parameters have already been determined move onto step 6.2.7.
6. Detect spots: select the window with the image or stack to be analyzed, Detection&Tracking>Detection>Spot Detector, and fill in the

Settings parameters:
1. For Input, select “currentSequenceInputDetection” (default).
2. For Pre Processing, select “Channel 0” (default), or desired channel by cross-referencing the number in the Inspector

window>Sequence tab.
3. For Detector, select “Detect bright spot over dark background;” use “Force use of 2D Wavelets for 3D” only if there are not

enough Z-slices in the stacks to perform the analysis. Select “Scale(s)” and “Sensitivity” for each scale (add more scales
for larger spots). The Scale and Sensitivity (the larger the number the more sensitive is the detection, a maximum of 140 is
suggested by Icy) are trial and error variables, that must be visually checked afterwards and decided upon.

4. For Region of Interest, use “ROIfromSequence” (default).
5. For Filtering, use “NoFiltering” (default), or select “SizeFiltering” to define the “Range of accepted objects (in pixels)”.
6. Output: select XLS or XML output setting (select XML format when using 2007 MS Excel or earlier and there are > 65,000 spots).

If the spot detector results are used for the tracking analysis, also select “Export to SwimmingPool”.
7. Repeat detection of spots using various scale/sensitivity values until all or most of the spots are detected. Record all of the final

parameters.
8. For colocalization analysis, repeat spot detection for the other channel.

7. To track spots, select Detection&Tracking>Tracking>Spot Tracking>Run the Spot Detector with parameters from step 6.2.6., or use
“Select detection results here” pull-down menu to select an existing dataset (for this, keep Spot Detector window open from step 6.2.5).
Press the “Estimate parameters” button and select the desired target motion in the Parameters estimation pop-up window (e.g. “is both
diffusive and directed”). Press the “Run tracking” button.

8. Repeat spot detection and tracking for other channels when tracking spots of multichannel stacks, following steps 6.2.6 and 6.2.7,
beginning with the stack generated from step 6.2.7.

9. To visualize tracks, select Detection&Tracking>Tracking>Track Manager – this window opens automatically upon completion of a
tracking run. For “Color Track Processor,” select “Enable” and choose the desired representation of color for the tracks. Relevant track
processors can be accessed via the “add Track Processor…” pull-down menu (e.g. select “Track Processor Time Clip,” enable the
“Track Clipper” window, and choose the desired number of detections to be displayed before and after the current time point.)

10. Save tracks information as an XML track file: Detection&Tracking>Tracking>Track Manager>File>Save as….
11. Save results by taking a screenshot using the “camera” icon from the Image Window’s menu bar, “Take a screenshot of current view”.

Screenshots can be taken with the detected spots and/or the tracks simply by activating/deactivating the corresponding eye icon(s)
found in Inspector window>Layer tab>Name>Overlay wrapper.

12. Install the TimeStamp Overlay plugin: Plugins>Setup>Online plugin>TimeStamp Overlay>Install.
13. Add timestamp: Plugins>TimeStamp Overlay (New). Follow instructions on the pop-up window (lower right corner of screen) for

directions on placing and formatting the time stamp. The time interval can be added/changed in the Inspector window>Sequence
tab>Sequence Properties>Edit.

14. Save results by taking another screenshot. Save image as 1) Tiff format, and 2) as AVI format; for AVI format first convert to RGB
rendering (Image/Sequence>Rendering>RGB image).

15. Rotate image to desired orientation: Inspector window>Sequence tab>Canvas>Rotation.
16. Save rotated image by “Take a screenshot of the current view”. Ensure the “eye” icon for the scale bar is deselected, as it will also

rotate with the image.
17. Choose and crop ROI: select Region Of Interest>2D ROI>Choose ROI shape and then create/draw ROI on the image; Image/

Sequence>Plane (XY)>Fast crop.

3. Colocalization analysis
1. Prepare a colocalization protocol; several examples are provided on the Icy website (http://icy.bioimageanalysis.org/protocol/List) (see

Supplemental Materials).
2. Load colocalization protocol: Tools>Scripting>Protocols>Load, and adjust parameters in the interacting blocks (e.g. in the “Wavelet

Spot Detecting” block use parameters determined in step 6.2.6.).
3. Measure the size of a particle in pixels, determine the colocalization distance and input it into “Colocalizer” block as “Max distance.”

 

Note: The size of the particle in pixels depends on the detection system. To measure size, zoom into a single particle and manually
count the pixels that span the width of the signal across. Average the measurements from at least three particles. The maximum
distance to be set for colocalization is the size of the particle in pixels (this represents the maximum sum of the radius of two particles
touching).

4. If desired, select one or more ROIs for colocalization analysis: Region Of Interest>2D ROI>Choose ROI shape>Draw ROI on image.
5. Crop ROI(s): Image/Sequence>Plane (XY)>Fast crop.
6. Perform colocalization: Protocols editor window>Chosen protocol tab>Run. The final block in Protocols editor window will contain

overall colocalization percentage based on spot detection, while information at each time point can be found in the Inspector window>
Output tab.

7. Track colocalized and single particles by following step 6.2.7 (Track spots).
8. Save as described in step 6.2.16.
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Representative Results

Using PinMol, several MBs can be designed for one mRNA target (Figure 1B-C). After synthesis and purification, the selected MBs are
characterized and compared using in vitro analysis.

 

Figure 1: Technique and tissue description for live cell imaging of endogenous mRNAs. (A) Depiction of a mid-stage Drosophila egg
chamber used for microinjection. The microinjection needle (green) delivers a cocktail of molecular beacons specific for oskar mRNA. A quick
injection into a nurse cell enables detection of mRNAs in transit to the oocyte, as well as visualization of already localized mRNA at the posterior
cortex. (B) PinMol software output of molecular beacon ranking for targeting oskar mRNA (C) Secondary structure region within oskar mRNA
targeted by a molecular beacon. (C') Sequence and folding of oskar-specific molecular beacon, osk2216. Please click here to view a larger
version of this figure.

After optimum performance of MBs is confirmed via in vitro characterization, the probes are used for live visualization of endogenous target
mRNA(s). It is possible to visualize the patterns of oskar mRNA transport and localization at various stages of oogenesis, and in particular at
and after mid-oogenesis (7-10) (Figure 2A-B). Due to their small size, it is difficult to inject egg chambers at very early stages (1-4). When
individually injected in the same stage egg chambers, oskar-specific MBs present the same patterns of localization (Figure 2, osk1236 vs
osk2216).
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Figure 2: Time sequence of oskar mRNA in wild type egg chamber at t = 0, 10, and 30 min time points, after initiation of acquisition.
Nurse cell injections of two oskar-specific molecular beacons (osk1236 and osk2216) in (A) stage 6-7 egg chambers and (B) stage 9 egg
chambers. Scale bar, 20 µm. Please click here to view a larger version of this figure.

Different mRNA targets can be co-visualized by using spectrally distinct fluorescently labeled MBs (Figure 3). The MB solution can be
microinjected into a nurse cell (Figure 3A) or into the oocyte (Figure 3B). MBs injected into a nurse cell's cytoplasm will freely diffuse into
the other nurse cells as well as into the oocyte, and thus are able to find their target and generate fluorescence signal at other sites than the
microinjection site. For example, when performing microinjections in a nurse cell of a late oogenesis stage (9-10) egg chamber, most of the
fluorescence signal visualized within the oocyte is generated by the already localized oskar mRNA, and less by actively transported transcripts,
which are more prevalent in earlier stages (7-8). Note that classical MBs will give rise to non-specific signal within the nuclei, therefore limiting
the analysis to the cytoplasmic regions of the egg chamber. Additional modifications, such as NeutrAvidin or gold nanoparticles, have been
employed to reduce or eliminate this non-specific signal28,29. In spite of this nuclear non-specific signal, the specificity of MBs for in vivo detection
of oskar mRNA has been established using a FRET approach8, and MB co-injection with in vitro transcribed oskar mRNA labeled with a
fluorophore spectrally distinct from the MB's label23.
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Figure 3: Co-visualization of two mRNA species in live egg chambers. Co-injections of oskar- and drongo-specific molecular beacons in the
(A) nurse cell and (B) oocyte of stage 8-9 egg chambers. oskar (red) and drongo (green) mRNAs colocalize at the posterior end of the oocyte
(asterix), and drongo also shows dorso-anterior accumulation (arrowhead). Scale bar, 20 µm. Please click here to view a larger version of this
figure.

For mRNA targets that show low expression levels, the fluorescence signal per mRNA molecule is increased by injecting a cocktail solution
containing at least two MBs, each binding to different target regions (Figures 4 and 5).

 

Figure 4: Visualization of oskar mRNA with both MBs and MS2-GFP system. Microinjections of a MB cocktail solution (MB) in an egg
chamber expressing osk-MS2::MCP-GFP30 (GFP). After the microinjection of a nurse cell, images were acquired every 30 s for 20 min. Two
regions of interest were selected, one ROI in a nurse cell and one in the oocyte. Different sensitivity was used for each ROI to detect the spots.
ROI nurse cell: Scale 2, Sensitivity 100 for GFP and MB. ROI oocyte: Scale 2, Sensitivity 50 for GFP and 110 for MB. Colocalization distance
is 4 pixels for both ROIs. The whole egg chamber and the zoom in on the nurse cell are shown at the 12-min time point, and the zoom in on
the oocyte is shown at the 14-min time point. MB spots (red circles) and GFP spots (green circles) identify oskar mRNA particles detected by
each approach, and the colocalized particles (yellow) indicate where MB and GFP spots are at most 4 pixels apart. XY-projections of 14 Z optical
slices at 0.3 µm steps. Acquired as 16-bit data with an 63X objective (oil, NA = 1.4), XY = 0.24 µm, exposure time 500 ms, at 5.23 and 5.39 mW
laser power for the 641 nm and 491 nm laser, respectively. Scale bar, 10 µm. Please click here to view a larger version of this figure.
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Figure 5: Tracking analysis in the oocyte, after nurse cell microinjection with oskar mRNA-specific MBs. MB particles were detected at
Scale 2 with Sensitivity 110, and 8 time points are shown before/after the current time frame. MB spots (red circles) are tracked in the volume
of the oocyte; tracks represent detection information from 8 time points before/after the shown 12-min time point. Each color represents an
individual track. XY-projections of 14 Z optical slices at 0.3 µm steps. Scale bar, 10 µm. Please click here to view a larger version of this figure.

When comparing trafficking of oskar mRNA as detected with MBs vs MS2/MCP, the fluorescence signal generated by oskar-specific MBs
faithfully documents on the transport and localization of transgenic oskar mRNA labeled with 10 GFP molecules via the MS2/MCP system
(Figure 4). In oskar-MS2/MCP-GFP transgenic egg chambers at mid oogenesis, acquisition data analysis showed extensive colocalization
between fluorescent signals of genetically engineered oskar-MS2 mRNA detected using MBs and GFP-tagging. At 12 and 14 min post-injection,
57% (7 MB-objects and 13 GFP-objects, with 4 colocalized objects) and 93% (30 MB-objects and 51 GFP-objects, with 28 colocalized objects) of
detected MB particles colocalized with GFP particles in the nurse cells and oocyte, respectively. Our analysis yields 31% and 55% colocalization
percentages of oskar-MS2 mRNA with oskar mRNA detected with MBs within the cytoplasm of a nurse cell and the oocyte, respectively.
Moreover, 5D-stacks can be further analyzed to determine oskar mRNA trajectories for long-distance transport in both the nurse cell and oocyte
cytoplasm (Figure 5).

Discussion

Live visualization of endogenous mRNA trafficking in Drosophila egg chambers relies on the use of specific, efficient, and nuclease-resistant
MBs, which can now be easily designed with PinMol software. MBs are specific probes designed to detect unique sequences within a target
mRNA (preferably regions free of secondary structure), making possible highly resolved detection of a transcript. The only limitation when
adopting this technique/protocol for other tissues/cell types is the efficiency of MB delivery for the specimen of interest. While other approaches
require genetic manipulation of the tissue to express an aptamer and an RNA-binding protein tagged with a fluorescent protein to visualize
one target mRNA (e.g. MS2/MCP system), multiplexing is possible for, at most, two transcripts. MB technology stands alone for detecting
endogenous mRNAs in living cells, and it is the only technique permitting the co-visualization of more than two mRNA species.

MBs can be labeled with a wide range of fluorescent moieties and are stable within the cellular environment when synthesized from modified
nucleotides such as 2'-O-methylribonucleotides or locked-nucleic acids26,31. These backbone modifications also increase MBs' affinity for their
target. Several MBs can be easily designed for target mRNAs of average length. However, some limitations may be encountered for short and/
or highly structured targets. This can be overcome by adopting our tiny molecular beacons, for which the probe region is approximately half of
the length of a classical MB probe31. Depending on the specimen type, MBs are delivered into cells via electroporation, linking to cell-penetrating
peptides, lipofection, or microinjection23,32,33,34. An MB's performance efficiency in live cell imaging experiments leans on the capability of the
probe sequence to hybridize to the corresponding complementary sequence within the mRNA target, which is determined by the target structure.
The predicted MFE RNA secondary structure obtained using in vitro measured thermodynamics parameters is valuable in assessing target
accessibility, but ultimately it is the in vivo target structure and the target interaction with other cellular factors that will determine the MB's
suitability for live cell imaging. Genome-wide analysis of RNA secondary structure suggests that many RNAs are less structured in vivo than
in vitro35. Although the efficiency of in vivo target detection using MBs is mainly dependent on the accessibility of the binding site, optimizing
certain MB features will ensure an enhanced visualization of the mRNA target. Specifically, a careful selection of the following parameters
should be performed: 1) the probe length can vary between 18 and 26, such that the probe's nucleotide composition is between 31 and 55%
GC pairs in the target:MB hybrid, 2) the 5 bp stem sequence should be G/C rich, to maintain the hairpin shape in absence of mRNA target and
to provide mismatch discrimination, 3) a modified backbone should be used for protection against nucleases of both MB and target:MB hybrid,
4) the fluorophore/quencher pair can offer an additional modest stability to the MB's stem, and 5) the fluorophore should be stable during long
imaging time intervals. In addition, classical MBs usually generate a nuclear non-specific signal34, which in our case only moderately impacts
data processing and analysis. However, for mRNA trafficking visualization at cellular level, this non-specific signal may become problematic.
Several groups have proposed modifications or tags, such as tRNA, peptides and nanoparticles, which prevent the delivery of MBs into the
nucleus and thus eliminate this possible non-specific signal33,36.

The biggest drawback of this approach has been the manual design of MBs for live cell imaging. To address this, we have written a Python-
based program (PinMol) that readily identifies accessible target sites within an mRNA by considering suboptimal secondary structures in addition
to the MFE, as well as designs hairpin probes, which are best suited for detection of mRNAs in live cells24. PinMol uses structural information
from secondary structures of the target RNA predicted via energy minimization approaches, and by including information from suboptimal
structures, the flexibility or rigidity of specific targeted regions is assessed when designing MBs. It takes into account the accessibility of the
targeted regions,as well as the inter- and intramolecular interactions of each selected probe. Additionally, highly regulated stretches of RNA
(e.g. binding sites for microRNAs or RNA-binding proteins) should not be considered as target sites when selecting probes, as these regions
may result in inefficient binding of the MBs. The user can evaluate and eliminate probes targeting these sites, or restrict the target region used
by PinMol to design probes so it does not include such sites. The relative capability of PinMol was demonstrated by comparing the ranking of
PinMol designed MBs with the experimental results of manually designed MBs24. Pinmol selected and designed MBs for similar target regions
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as well as identified new accessible sites on the mRNA. This is essential for the detection of low copy number transcripts where the fluorescent
signal must be increased above background. By scaling up the MB numbers which effectively hybridize to several accessible sites on a target
mRNA, signal amplification can be achieved. Therefore, this program facilitates a fast approach to design multiple MBs per target mRNA, and to
simultaneously visualize numerous mRNAs in a live cell.

In order to achieve high quality 5D (XYZCt) acquisition data of transported mRNAs within the egg chamber, proper dissection of individual
egg chambers and effective microinjection into nurse cells are critical. For studies during early stages of development, microinjection can be
detrimental to the viability of the egg chamber and thus the length of a live cell imaging experiment is shortened (< 20 min). An increased
success rate of the microinjection experiments can be ensured by using commercially available ultrafine needles. In addition, a quick set-up of
the acquisition settings is important so that the early, post-injection time points can be captured. The quality of the spot detection and tracking
data will only be as good as the quality of the images acquired.

Upon image acquisition, it is essential that subsequent analysis steps are also completed carefully and precisely. Although post-acquisition
processing and analysis offer their own set of difficulties, they can be streamlined by choosing the appropriate software for one's particular
experiment or sample. Current existing programs include Volocity (PerkinElmer), Imaris (Bitplane), ImageJ/Fiji and Icy37. Of the three, Icy offers
several benefits, as it is an open community platform that allows for, both, processing (via ImageJ) and analysis of imaging data. Here we
describe the steps necessary for efficient processing and analysis of RNA imaging data using Icy. Our results are representative of data obtained
by co-visualizing two mRNA species in a whole egg chamber and by tracking an mRNA via the MB technology and the MS2/MCP system.

The post-acquisition processing with Icy software provides user flexibility in the image processing (e.g. brightness, contrast) and analysis (e.g.
the thresholds/cut-offs settings for sensitivity of detection of the fluorescent particles as spots). Icy also enables the control relevant parameters
within each block of the Protocols Editor run (e.g. determine the colocalization distance and use it as "Max distance" into the "Colocalizer"
block). Icy software is updated at launch, and has reliable online support to troubleshoot any problems. The described protocol was designed
for detecting oskar mRNA and the representative results were obtained using parameters optimized for the kind of mRNA particle to be detected
and tracked. For example, oskar mRNA is an abundant transcript that is predominantly transported during mid stages of oogenesis, utilizing the
microtubule network and dynamically associating with various protein factors throughout development of the oocyte. We previously reported that
oskar mRNP undergoes extensive remodeling during transport from the nurse cells into the oocyte23. In addition, using MBs we characterized
the temporal and spatial characteristics of endogenous oskar mRNA trafficking, and found that hundreds of oskar transcript copies can be
incorporated to form large oskar mRNPs.

Post-acquisition analysis for colocalization and tracking can also be performed by using other software such as Imaris, ImageJ/Fiji and Volocity.
Icy was selected for its capability to threshold and annotate fluorescent particles with high sensitivity and tracking capabilities. Here, we
describe object-based colocalization, but colocalization, albeit without tracking, can also be quantified by determining the overlap and degree of
colocalization using PCC(Costes) analysis using Icy and ImageJ plugins (Colocalization studio, JACoP)38,39.

In the future, an optimized, long-term imaging protocol is desired to ensure extended egg chamber survival. This would provide longer acquisition
in order to analyze data pertaining to long-range mRNA trafficking studies.
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