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Abstract

An increasing number of studies are utilizing the rodent mammary gland as an endpoint for assessing the developmental toxicity of a
chemical exposure. The effects these exposures have on mammary gland development are typically evaluated using either basic dimensional
measurements or by scoring morphological characteristics. However, the broad range of methods for interpreting developmental changes
could lead to inconsistent translations across laboratories. A common method of assessment is needed so that proper interpretations can be
formed from data being compared across studies. The present study describes the application of the Sholl analysis method to quantify mammary
gland branching characteristics. The Sholl method was originally developed for use in quantifying neuronal dendritic patterns. By using ImageJ,
an open-source image analysis software package, and a plugin developed for this analysis, the mammary gland branching density and the
complexity of a mammary gland from a peripubertal female rat were determined. The methods described here will enable the use of the Sholl
analysis as an effective tool for quantifying an important characteristic of mammary gland development.

Video Link

The video component of this article can be found at https://www.jove.com/video/55789/

Introduction

Mammary gland branching is a characteristic that is commonly assessed as an indicator of gland development, but it is difficult to objectively
quantify. In 1953, Sholl1 described a method for measuring neuronal dendritic arborization in the visual and motor cortices of the cat, and a
plugin for this technique was developed by Ferriera et al2. Because both neurons and mammary glands exhibit a similar tree-like structure, the
plugin was employed to quantify mammary epithelial branching densities in 2D images of the peripubertal rat mammary gland. The peripubertal
stage was chosen for analysis because weaning is a life stage that is often assessed in academic laboratories and test guideline studies. The
Sholl analysis is a plugin distributed with FIJI, which is the open-source image processing package ImageJ, with additional plugins included.
The plugin creates a series of concentric rings encircling a predefined center (typically the soma of a neuron or the origin of the primary duct of
a mammary gland) and extending out to the distal-most portion of the object (the enclosing radius). It then counts the number of intersections
(N) that occur on each of the rings. The plugin also returns a Sholl regression coefficient (k), which is a measurement of the rate of decay of
epithelial branching.

Using ImageJ, a skeletonized image of a mammary gland whole-mount is created and the mammary epithelial area (MEA) is measured.
The image is analyzed using the Sholl analysis plugin, and values for N and k, among other values not utilized here, are returned. Mammary
epithelial branching density is determined by calculating N/MEA. The extent to which branching continues in the outer regions of the glandular
epithelium is the branching complexity and is an indicator of uniform distal epithelial growth. As k is a measure of the distal decrease in epithelial
branching, it is an effective measure of the branching complexity and a reliable indicator of mammary development.

This protocol describes a computer-assisted method for creating skeletonized images of mammary gland whole-mounts and quantitatively
evaluating mammary branching characteristics in peripubertal male and female rats. This method is relatively rapid and does not require the
use of specialized microscopy equipment. Development and validation of this method are described in Stanko et al. (2015)3. This report also
describes preparation of rat mammary gland whole=mounts. Similar mammary whole-mount procedures have been described in de Assis et al.
(2010)4 and Plante et al. (2011)5.

Protocol

All animal use and procedures for this study were approved by the NIEHS Laboratory Animal Care and Use Committee and conducted in an
Association for Assessment and Accreditation of Laboratory Animal Care-accredited facility.
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1. Excise Mammary Glands

1. Pre-label all slides using a xylene-proof method (pencil works best). Cover them with mounting solution at the end to preserve the label.
2. Euthanize the animal by an Institutional Animal Care and Use Committee-approved method.
3. After euthanasia, place the animal on its back on a dissecting board (Figure 1). Stretch and pin down all four limbs, with the rear limbs

forming an inverted V (holding pins or small-gauge needles work well).
4. Spray the abdomen liberally with 70% ethanol to keep hair out of the mammary sample.
5. Using forceps, pull up the abdominal skin at the midline and make a small incision with dissecting scissors, being careful not to

puncture the peritoneum.
1. Beginning at the incision, cut the skin up to the neck region and then distally to the front limb. Cut down to the inguinal region and then

distally to the first joint of the rear limb on the same side; this incision usually separates mammary glands 5 and 6. Avoid cutting the
peritoneum.

2. Pull back the skin with the attached mammary fat pad using forceps, gently separating it from the peritoneum using the blunt end of
dissecting scissors. Separate as far dorsally as possible to fully expose the 4th and 5th inguinal mammary glands on the underside of
the skin; pin the skin to the dissecting board (Figure 2).

3. Gently grasp the mammary tissue of the 5th gland with the rounded side of curved forceps and slowly trim the gland away from the skin,
being careful not to nick the gland or the skin.

4. Continue to trim, moving dorsally until the 4th and 5th glands have been completely lifted from the skin. Ensure that the nipple region is
removed with the rest of the gland, as this serves as the starting point for the Sholl analysis. Cut the mammary tissue away from the
body where it is attached at gland 4.

6. Once the gland is removed from the animal, spread it evenly on an electrostatically charged, 25 mm x 75 mm x 1 mm microscopy slide, with
the side that was adjacent to the skin facing down.
 

NOTE: For glands from older or lactating animals, a 51 x 75 x 1 mm slide may be required.
7. While wearing gloves, gently squeeze out any air bubbles. Cover the gland with a plastic paraffin film and another microscope slide and

compress the gland to adhere it to the slide.
 

NOTE: A 50 mL conical tube filled with water serves as a suitable weight. The amount of time required to adhere to the slide depends on the
thickness of the gland. Thin, postnatal day (PND) 4 glands should be compressed for a minimum of 30 min, while thicker, adult glands may
require as much as 2-5 h.

2. Prepare Mammary Whole-Mounts

1. Prepare the carmine alum solution at least 24 h in advance, as it requires boiling and refrigeration.
1. Dissolve 1 g of carmine alum and 2.5 g of aluminum potassium sulfate (AlK(SO4)2·12H2O) in 500 mL of distilled water and boil for 20

min in a 1-L flask. Bring the final volume to 500 mL using distilled water.
2. Filter the solution through filter paper under a vacuum and refrigerate for storage.

 

NOTE: Carmine alum solution can be reused but should be discarded when the color begins to fade.

2. Prior to fixation, peel the paraffin film off the gland, being careful not to pull the gland off the slide. Place the slide(s) in a glass slide-staining
jar and immerse in fixative (100% ethanol, chloroform, and glacial acetic acid in a 6:3:1 ratio) for 12-48 h, depending on the thickness of the
glands.

3. Pour off the fixative and soak the glands in 70% ethanol for 15 min. Gradually rehydrate the glands by pouring out 1/3 of the ethanol solution
and replacing it with distilled water. Soak for 5 min. Repeat this process three times.

4. After the final rinse, pour off all the ethanol/water solution and replace it with 100% distilled water. Soak the glands for 5 min.
5. Pour off the distilled water and immerse the glands in the carmine alum solution. Stain the glands for 12-24 h, depending on the thickness.

 

NOTE: The glands cannot be over-stained, but the staining time for multiple batches should be the same, so that the staining intensity is the
same.

6. Pour off the carmine alum solution and rinse the glands in 100% distilled water for 30 s. Gradually dehydrate the glands by soaking them in
70% ethanol for 15 min, 95% ethanol for 15 min, and 100% ethanol for 20 min.

7. Clear the glands of fat by soaking them in xylene for 12-72 h, depending on the thickness.
 

NOTE: The glands should be translucent (clear). If any opaque (whitish) areas remain, continue soaking in xylene until translucent. If lactating
or otherwise very thick glands are being stained and cleared, the xylene may need to be replaced once to fully clear the glands.

8. Mount the slides with a xylene-based mounting medium by pipetting enough medium to just cover the gland. Add a coverslip, ensuring that
no air bubbles form.

9. Allow the slides to dry. As the mounting medium dries, it will contract under the coverslip, and it may be necessary to add additional mounting
medium. Once no additional medium is required, allow the slides to dry completely; this may take 2-3 weeks.

10. Once the slides are completely dry, any residual mounting medium can be removed with a cotton swab and a small amount of xylene. Be
careful not to use too much xylene, as this can dissolve the mounting medium and loosen the coverslip. If this happens and air bubbles
collect under the coverslip, the coverslip should be removed in xylene and the mounting process should be repeated.

3. Prepare Whole-mount Images for Analysis

1. Capture images of whole-mounts (Figure 3) using a macroscope or dissecting microscope and a digital camera with the appropriate
software.
 

NOTE: While any magnification that captures the entire glandular epithelium can be selected, it is imperative to capture all whole-mount
images that will be compared to each other at the same magnification.

2. Download ImageJ software (or FIJI software)6.
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3. Open the mammary whole-mount image in ImageJ by clicking "File" → "Open." Select the Freehand tool and trace around the
glandular epithelium. Select "Edit" → "Clear Outside."

1. Remove the lymph nodes by tracing around the node and using the Freehand tool and "Edit" → "Cut."

4. Separate the color channels by selecting "Image" → "Color" → "Split Channels." Select the channel with the best contrast, typically the blue
channel.
 

NOTE: An RGB image consists of a stack of the red, green, and blue components of that image. This action separates these components
into three 8-bit grayscale images.

5. Subtract the background by selecting "Process" → "Subtract Background." Choose the desired parameters and then click "Preview" to
preview the changes.
 

NOTE: "Subtract Background" removes smooth, continuous backgrounds. Additionally, "Process" → "Filters" → "Unsharp Mask" can be used
to create contrast.

6. Choose one of the following methods for automatically removing noise: despeckle or remove outliers.
 

NOTE: ImageJ offers a third method for automatic noise removal: remove NaNs. However, the remove NaNs command is not applicable
since it uses 32-bit images, and the current method uses 8-bit images.

1. Remove noise using the despeckle command by selecting "Process" → "Noise" → "Despeckle."
 

NOTE: This is equivalent to adding a median filter, which replaces each pixel with the median value in its 3 × 3 neighborhood.
2. Remove noise using the remove outliers command by selecting "Process" → "Noise" → "Remove Outliers."

 

NOTE: This process replaces a pixel with the median of the pixels in the immediate surroundings if it deviates from the median by more
than a certain value (the threshold).

7. Remove any remaining noise manually (Figure 4).
1. Open a copy of the original image and use this as a guide for what is and what is not noise. Click the double-red-arrow button at the far

right of the toolbar. Select the Drawing Tools; the Drawing Tool buttons will now appear in the toolbar.
2. Click the Eraser tool. Adjust the eraser diameter by right-clicking the Eraser tool button. Hold the left mouse button to erase noise.

 

NOTE: Only one session of erasing can be undone. Once the left mouse button is released and clicked again, the previous erase
cannot be undone.

8. Adjust the threshold by selecting "Image" → "Adjust" → "Threshold." Move the sliders to adjust the minimum (upper slider) and
maximum (lower slider) threshold values until an adequate depiction of the gland is achieved.
 

NOTE: Setting the threshold value segments grayscale images into features of interest and background.
1. Click Apply. If necessary, remove additional noise at this point by following steps 3.6.1 and 3.6.2.

9. Reconstruct the portions of the glandular epithelium that were removed by thresholding and noise removal (Figure 5).
1. Conduct image reconstruction carefully and on a minimal basis to maintain the integrity of the original image. Refer to the original

image for a reference as to what is and what is not epithelium.
2. Click the Spray Can tool (on the toolbar with the Drawing Tools). Adjust the spray diameter and rate by right-clicking on the Spray Can

tool button. Carefully fill in missing sections of gland by clicking or holding down on the left mouse button.

10. Create a skeletonized image of the gland for conducting the Sholl Analysis. Ensure that the thresholded image is binary by
selecting "Process" → "Binary" → "Make Binary."

1. If the image is white on a black background, select "Process" → "Binary" → "Options" and uncheck "Black Background." Skeletonize
the image by selecting "Process" → "Binary" → "Skeletonize."
 

NOTE: This repeatedly removes pixels from the edges of the binary image until it is reduced to a single-pixel-wide shape.
2. Dilate the image one time by selecting "Process" → "Binary" → "Dilate."

 

NOTE: This fills in gaps created by thresholding and skeletonizing by adding pixels to the edges of the binary image.

11. Save the image by selecting "File" → "Save As." Select an image type (typically jpeg), enter the filename, and click "OK."
12. Check the accuracy of the skeletonized image by overlaying the skeletonized image onto the original image (Figure 6).

1. Create an overlay by opening both the original image and the skeletonized image. Select "Image" → "Overlay" → "Add Image." In the
"Add Image" dialog box, select the skeleton image from the "Image to Add" dropdown menu and set the opacity at 30%.

2. Save the image of the skeleton image overlaid onto the original by selecting "File" → "Save As." Select an image type, enter the file
name, and click "OK."

4. Conduct the Sholl Analysis

1. Open a skeleton image and make the image binary by selecting "Process" → "Binary" → "Make Binary."
1. Prior to setting the magnification scale, measure the number of pixels/mm using a micrometer for the magnification at which the images

were captured.
2. Set the measured magnification scale by selecting "Analyze" → "Set Scale." Enter the number of pixels/mm. Set the "Known Distance"

and the "Pixel Aspect Ratio," both to 1. Enter "mm" for the "Unit of Length" and check "Global" (maintains the same scale for each
image).

2. Determine the ending radius (enclosing radius) for the Sholl analysis by drawing a line from the start of the primary duct (center of
analysis) to the most distal point of the glandular epithelium (Figure 7).

1. Use the line drawing tool in the toolbar to draw a line between the points of interest. Press the "M" key to take a measurement and note
that a results window will open.
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NOTE: The value in the "Length" column is the length of the line in mm. This value will be automatically entered as the Ending Radius
when setting the Sholl parameters. The Sholl plugin will use the starting point of the line as the center of the centric rings.

3. Running the Sholl Analysis.
1. Run the analysis by selecting "Plugins" "Advanced Sholl Analysis;" a parameter window will appear.
2. Set the Starting Radius in "I. Definition of Shells" to 0.00 mm; the length of the line measured in step 4.2 will automatically be entered

as the "Ending Radius."
3. Set the "Radius Step Size" to 0.1 mm.

 

NOTE: The radius step size determines the number of rings (effectively the number of iterations); a smaller step size will increase the
number of rings, while a larger step size will decrease the number of rings. The radius cannot be set too small, although an excessively
small radius will result in an unnecessarily large number of rings. However, it can be set too large, which will create fewer rings and
subsequently underestimate the true number of intersections. Refer to Stanko et al. (2015) for further information on determining the
step size.

4. Set the "# Samples" to 1 and the "Integration" to "Mean" in "II. Multiple Samples per Radius."
5. Set the "Enclosing radius cutoff" to 1 and check "infer from starting radius" for the "# Primary branches" in "III. Descriptors and Curve

Fitting."
 

NOTE: "Fit profile and compute descriptors" and "Show fitting details" can be checked as desired.
6. Check "Linear" and select "Best fitting degree" in "Profiles Without Normalization;" check "Most informative." Select "Area for

Normalized Profiles" in "IV. Sholl Methods."
7. Check "Create Intersections Mask" in "V. Output options" to create a heat map of the intersections (optional).
8. Click "Cf. Segmentation" to generate a preview window of the image with rings to confirm the area of analysis.

4. Click "OK" to run the analysis.

5. Measuring the MEA

1. Measure the MEA by tracing the shortest distance around the epithelial tree (Figure 8).
1. In ImageJ with the skeleton image of the gland open, click the Polygon tool. Click on a point on the perimeter of the epithelial tree to

begin the polygon, move around the perimeter of the gland, and click to add a line segment.
2. When the entire epithelial area has been circumvented, double-click to close the polygon. Press the "M" key to open a results window;

the value in the "Area" column is the MEA.

2. In cases where the glandular epithelium has extended beyond the lymph node, subtract the lymph node area (LNA) from the MEA
when calculating the branching density.

1. Measure the LNA by tracing the lymph node in the same manner as the epithelial tree and pressing "M."
 

NOTE: The LNA must be subtracted from the MEA in these cases because the lymph node prevents the analysis from counting
intersections within the LNA. When the epithelium has not reached the lymph node, the LNA is zero.

6. Reporting Data

1. Report values for the enclosing radius, MEA, N, k, and branching density.
 

NOTE: The enclosing radius is determined in step 4.2 and the MEA is determined in step 5.1.
1. Run the analysis to generate a Sholl results window.

 

NOTE: The reported N is the value for the sum inters. The reported k is the value for the Sholl regression coefficient (semi-log). The
Sholl analysis will return a value for k over any measured region of the glandular epithelium. To obtain an accurate value for k over the
full epithelium, the ductal ends must be present.

2. Modify the Sholl analysis for the mammary gland by using the output value for N to calculate the branching density (the fundamental
endpoint of this method). Calculate the branching density using the formula N/(MEA-LNA) and report the value as N/mm2.

Representative Results

The values for the measured enclosed radius, MEA, N, k, and calculated branching density for the mammary gland analyzed in this protocol
are reported in Table 1. The Sholl analysis generates linear and semi-log plots of the number of intersections at each radius (Figure 9) and, if
selected, a heat map of the intersections (Figure 10). Less-developed glands exhibit fewer intersections within the same MEA and therefore
have a lower branching density. A well-developed gland will continue to branch uniformly throughout the entire glandular epithelium, particularly
in the distal regions. The extent to which branching continues in these regions can be described as branching complexity and decreases in
complexity are conveyed as a rate of decay (or Sholl regression coefficient, k). The rate of decay reflects the change in distal epithelial branching
and is measured as the slope of the line of the number of intersections plotted against the enclosing radius (i.e., the longitudinal growth of the
epithelium). Thus, the Sholl regression coefficient is calculated by taking the slope of the line of the plot of log(N/S) versus the radial distance
(r), where log(N/S) = -k r + m, with N being the number of intersections for each ring of radius r and area S (πr2), and m being the intercept.
Because the slope -k describes the decay of the intersections, a value of -k = 0 would indicate zero decay and uniform branching from the center
of analysis to the edge of the epithelium. In sparsely developed glands, branching decay is increased; there are fewer intersections in the distal
region of the epithelial tree; and the slope, k, is increased. Therefore, values of k approaching 0 are indicative of greater distal branching (i.e.,
branching complexity) and a well-developed mammary gland.
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Figure 1: Ventral View. Image of the ventral portion of an adult female Sprague Dawley rat, illustrating how to secure the rat on the dissecting
surface and the location of the 12 mammary glands, with the nipples circled. * The nipples of glands 6 and 7 are not visible. Please click here to
view a larger version of this figure.
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Figure 2: Female Rat Mammary Gland. Illustration of exposed mammary glands 4 (MG4) and 5 (MG5), with the skin pinned to the dissecting
surface above MG4 and just below MG5. The glands should be removed from the skin beginning with MG5 and continuing up and dorsally until
MG5 and 4 are completely removed. The nipple is in the distal area of gland 4, and care should be exercised to collect this area. The lymph node
is indicated for reference. Please click here to view a larger version of this figure.

https://www.jove.com
https://www.jove.com
https://www.jove.com
http://ecsource.jove.com/files/ftp_upload/55789/55789fig2large.jpg


Journal of Visualized Experiments www.jove.com

Copyright © 2017  Journal of Visualized Experiments July 2017 |  125  | e55789 | Page 7 of 12

 

Figure 3: Mammary Gland Whole-mount. A whole-mount image of a mammary gland collected from a postnatal day 25 female Sprague
Dawley rat. Scale bar =1 mm. Please click here to view a larger version of this figure.

 

Figure 4: Removal of Noise. The blue color channel of a mammary whole-mount image, with the background subtracted. (A) demonstrates
examples with noise. The arrows indicate noise created by blood vessels, and the more heavily shaded region surrounding the ductal ends is an
example of noise created by subtracting the background. (B) illustrates the image after the noise has been removed. Please click here to view a
larger version of this figure.

 

Figure 5: Image Reconstruction. Reconstruction of the erased portions of the thresholded image. (A) The red arrows indicate regions where
portions of the image were lost due to thresholding. Image reconstruction should be performed at these regions. (B) Mammary image after
reconstructing the deleted regions. Image reconstruction should be conducted carefully and on a minimal basis so as to maintain the integrity of
the original image Please click here to view a larger version of this figure.
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Figure 6: Overlay of a Skeletonized Image. Overlay image showing a skeletonized image overlaid onto the original whole-mount image. This
image demonstrates that the skeletonized gland reflects the branching of the actual gland with a high degree of accuracy. Please click here to
view a larger version of this figure.

 

Figure 7: Enclosing Radius. Skeletonized image of a mammary whole-mount showing where the enclosing radius is measured (yellow). The
line should begin at the base of the epithelial tree (center of analysis) and extend to the most distal point of the epithelium. Please click here to
view a larger version of this figure.

https://www.jove.com
https://www.jove.com
https://www.jove.com
http://ecsource.jove.com/files/ftp_upload/55789/55789fig6large.jpg
http://ecsource.jove.com/files/ftp_upload/55789/55789fig6large.jpg
http://ecsource.jove.com/files/ftp_upload/55789/55789fig7large.jpg
http://ecsource.jove.com/files/ftp_upload/55789/55789fig7large.jpg


Journal of Visualized Experiments www.jove.com

Copyright © 2017  Journal of Visualized Experiments July 2017 |  125  | e55789 | Page 9 of 12

 

Figure 8: Mammary Epithelial Area. Skeletonized image showing a polygon traced around the epithelial tree to determine the MEA. Please
click here to view a larger version of this figure.

 

Figure 9: Sholl Plot Output. Sholl output of linear (A) and semi-log (B) plots of the number of intersections at each radial increment. The red dot
in panel (A) is the abscissa of the centroid (geometric center). In panel (B), the blue line is the linear regression over the full range of data, while
the red line is the linear regression over the 10th-90th percentile. Please click here to view a larger version of this figure.
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Figure 10: Intersections Mask. When the "Create Intersections Mask" option is selected (step 4.3.7), the analysis will output a heat map of the
number of intersections across the enclosing radius of the image. This heat map reflects the density of branching intersections throughout the
epithelium (red = hot = high density; blue = cold = low density). The entire epithelium would be the same color in a heat map of an image where k
= 0. Please click here to view a larger version of this figure.

Enclosing Radius (mm) MEA (mm2) N k Branching Density (N/
mm2)

7.4 71.7 2381 0.73 33.2

Table 1: Sholl Analysis Parameters. The values are the reported data for the Sholl analysis. The Enclosing Radius (step 4.2) and MEA (step
5.1) are measured values, N and k are Sholl analysis results and are returned in the Sholl analysis results window (step 6.1.), and Branching
Density is calculated using the formula N/(MEA-LNA) (step 6.1.2).

Discussion

From birth until puberty, mammary gland growth is allometric. After puberty, the mammary gland develops through extensive ductal branching
and elongation, which continue until the mammary epithelium occupies the entire fat pad. Branching characteristics are an important aspect of
mammary gland development, and the ability to objectively quantify these characteristics can be highly useful for assessing normal mammary
development and for identifying abnormal development following early life exposures to mammary toxicants.

Scoring morphological characteristics, quantifying basic dimensional measurements, and counting mammary structures are typical methods for
evaluating mammary gland development. However, these methods are not especially sensitive due to the considerable variation in the size and
shape of rodent mammary glands and developmental interpretation may be difficult for an inexperienced evaluator. Furthermore, the potential for
bias exists in studies that are not blinded properly. The Sholl analysis method provides an efficient protocol for accurately quantifying mammary
epithelial branching density and branching complexity, discrete morphological characteristics of mammary gland development, which can easily
be compared across studies and laboratories.

There are critical steps within several sections of this protocol. The first and most important relates to the condition of the mammary gland
whole-mount. The accuracy of this method relies upon a mammary gland that is collected wholly intact, mounted with no defects, properly fixed
and stained, and demonstrates no oxidation of the gland or significant discoloration of the mounting medium. If the gland is torn or folded, an
accurate measure of the branching density cannot be obtained. If the ductal ends are not present, the value for k will not be representative of the
entire gland. Thresholding will be difficult in glands that have not been fully fixed due to a lack of staining contrast in the ductal epithelium. And
finally, if oxidation or discoloration is present, these blemishes could prevent the analysis from measuring intersections in the affected area.

When suitable whole-mounts have been prepared, the next critical step is capturing the images at the same magnification. It is common practice
to capture digital images at the highest resolution possible. However, for the Sholl analysis, it is more important that all images be captured
at the same magnification. As described in Stanko et al. (2015)3, a caveat was discovered where images of smaller glands captured at high
magnification exhibited greater branching densities than images of larger glands captured at a lower magnification, even though they visually
appeared to be less developed. We hypothesized that the higher magnification resulted in greater detail, which carried over into the skeletonized
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image and resulted in a higher N, which over-represented the branching density of the smaller glands. This issue is alleviated by capturing all
images at the same magnification.

While the basis of an accurate analysis lies within the whole-mount, the greatest potential for user-influenced changes in intersection data lie
within the steps for noise removal. All images contain noise, to some extent, due to staining intensity, non-relevant physiological entities (e.g.,
blood vessels), and artifacts of thresholding. Each image must be addressed independently due to variations in the amount of noise between
images. Care must be taken not to remove too little or too much noise, as this can skew the number of intersections and, consequently, the
branching density. However, the extent to which noise affects the interpretation has not been examined. The user should decide how meticulous
to be with noise removal and should also exercise consistency to maintain the integrity of the images. It is highly recommended that the user be
blinded to treatment when conducting noise removal, as this will minimize the potential for bias. Noise removal is described in detail the ImageJ
User's Guide7. In this procedure, noise is removed primarily from the background-subtracted image. Additionally, the thresholding process itself
may remove segments of the gland. Portions of the gland where only a few pixels have been removed will be reconstructed automatically when
the skeletonized image is dilated. However, expansive gaps may require manual reconstruction. The user should decide whether and to what
extent to reconstruct these segments, again maintaining the integrity of the original images.

Although this is not critical, it is important to maintain software updates, as ImageJ software is updated frequently. The methods described
here are based on version 1.48v. FIJI and the Sholl analysis plugin are also updated regularly, and the protocol described here is based on
v3.4.1. Changes made in later versions of both ImageJ and the Sholl Analysis plugin can affect these methods. ImageJ automatically checks
for updates, but updates for FIJI should be conducted regularly, and changes between the current versions and those utilized here should be
addressed as needed. All parameters are defined in subheadings on the Sholl Analysis webpage6. Parameter settings within this procedure are
based on images captured from mammary gland whole-mounts created in our laboratory and are not absolute. Whole-mount preparation varies
from lab to lab, and these parameters may be adjusted accordingly to optimize images and output.

The mammary gland whole-mount utilized in this study was from a female Sprague Dawley rat at PND 25, and the method was applied
appropriately and without limitations. In rats, the mammary epithelial density increases with age to a point where it prevents thresholding the
image with high enough resolution to generate an accurate skeletonized image of the gland. Therefore, we currently do not recommend using
this method on glands from rats older than PND40. Although the strain of rat has been indicated here, it is irrelevant, as the authors are not
currently aware of any strain-specific mammary traits that would prevent the use of this method. Furthermore, while the method described
within was conducted using a female rat, it could also be applied to the mammary glands of male rats. This application has also been effectively
used with whole-mounts of mice (Deirdre Tucker, personal communication) and should be suitable for mice of any age, as mammary glands
in mice do not grow as dense as those in rats. However, there are two limitations with using this application in mice: 1) there may be too few
branching intersections in younger mice to detect significant differences and 2) this method cannot be applied to male mice, as they do not
exhibit mammary epithelium. Regardless, this automated method is faster, unbiased, and much less labor-intensive than counting branching
intersections manually.

It is possible that investigators may wish to utilize the mammary gland for other experimental techniques, such as excising abnormal structures
or for immunohistochemistry (IHC). Although Tucker et al. (2016) have described a method for preparing a hematoxylin-eosin-stained section
from a mouse mammary gland whole-mount,8 we typically consider creating a whole-mount to be a terminal process and do not know of
methods for using a whole-mounted mammary gland for additional sensitive assays, such as IHC or TUNEL assays. Where sensitive assays
using mammary gland tissue are required in conjunction with whole-mounts, it is recommended to use the contralateral mammary glands.

The mammary gland continues to be the focal point in an increasing number of studies, yet differences across laboratories exist in both whole-
mount preparation9,10,11,12 and developmental assessments13,14,15. The modification of the Sholl analysis described here provides a standardized
method for the objective quantification of branching density, an important characteristic of mammary gland development, in the rodent mammary
gland. This method can be applied to mammary whole-mounts of either male or female rodents, and though currently recommended for
use in only early-postnatal to peripubertal glands from rats, it can be applied to mammary glands from mice of all ages. The application is
particularly suitable for mammary glands collected from peripubertal rodents as this period is a recommended endpoint for mammary whole
mount preparation in test guideline studies. Optimization of this method for use in the denser mammary glands of adult rats is currently being
considered.
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