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Abstract

The National Institute of Health's ImageJ is a powerful, freely available image processing software suite. ImageJ has comprehensive particle
analysis algorithms which can be used effectively to count various biological particles. When counting large numbers of cell samples, the
hemocytometer presents a bottleneck with regards to time. Likewise, counting membranes from migration/invasion assays with the ImageJ
plugin Cell Counter, although accurate, is exceptionally labor intensive, subjective, and infamous for causing wrist pain. To address this need,
we developed two plugins within ImageJ for the sole task of automated hemocytometer (or known volume) and migration/invasion cell counting.
Both plugins rely on the ability to acquire high quality micrographs with minimal background. They are easy to use and optimized for quick
counting and analysis of large sample sizes with built-in analysis tools to help calibration of counts. By combining the core principles of Cell
Counter with an automated counting algorithm and post-counting analysis, this greatly increases the ease with which migration assays can be
processed without any loss of accuracy.

Video Link

The video component of this article can be found at https://www.jove.com/video/54719/

Introduction

In vitro cell counting is an important basic technique in a wide range of tissue culture experiments. Accurately determining the number of cells in
a culture is essential for experimental reproducibility and standardization1,2. Cell counting can be performed manually using a hemocytometer as
well as using a variety of automated methods, each with their own advantages and disadvantages3,4,5. Most of the automated methods for cell
counting belong to one of two classes, those that use the Coulter principle or flow cytometry. Coulter counters take advantage of cells electrical
resistance to determine cell number and size. They are fast, accurate and cheaper than flow cytometers. However, they are rarely used for only
cell counting due to their considerable cost compared to manual counting3. Flow cytometers, on the other hand, are expensive but they have
many applications such as cell counting, analysis of the cells shape, structure and measuring internal cell markers4,5. Machines that use either
of these two principles are available from many manufacturers. Manual counting is affordable but time-consuming and subject to bias while the
automated methods come with a fraction of the time required for the manual counting but using expensive machines6.

Other common cell culture procedures are in vitro cell motility assays, namely, cell migration and invasion7. Migration and invasion assays are
commonly used to investigate cell motility and invasiveness in response to a chemotactic response. In addition, they are widely used to study
embryonic development, differentiation, inflammatory response, and metastasis of multiple cell types7-11. Cells that have migrated or invaded
through the porous membrane of a migration assay can be quantified in two different ways. Firstly, by staining the cells with a fluorescent dye,
dissociation from the membrane, and quantification using a fluorescent reader12. A limitation of this method of quantification is that no record can
be retained of the membranes and there is no possibility for further analysis13. The second quantification method is for migrated/invaded cells to
be fixed and stained with fluorescent dye or more commonly, with cytological dyes such as crystal violet, toluidine blue dye or hematoxylin; then
cells are quantified manually using inverted microscopic images of these membranes which is a very time-consuming task12,13.

To overcome the drawbacks of manual cell counting, two reliable and accurate automated cell counters for cell concentration and for the
migration assay were developed. These automated cell counter algorithms were developed for ImageJ as a plugin using Oracle's Java computer
language. ImageJ is a public and widely-used image processing tool developed by the National Institute of Health (NIH)14,15; thus, writing these
plugins for ImageJ facilitates easy integration into the biological community.

Automation of cell counting ensures high throughput and reproducibility compared to manual counting. Although other available software and
plugins can be used to calculate cell concentration through image analysis5,16,17, Cell Concentration Calculator plugin is fast and can also handle
dilutions of cells and treatments. Moreover, all results and calculations from these two counters can be saved and exported. The two plugins
described in this paper are optimized for the use of a phase contrast microscope for live cell imaging and large field of view (entire membrane
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capture) imaging for migration assay membranes through the use of a dissecting scope. The plugins are freely available for download with
installation instructions from: http://peng.lab.yorku.ca/imagej-plugins.

Protocol

1. Compound Microscope and Camera Setup (Cell Concentration Calculator)

1. Increase bulb brightness to full with the light adjustment knob, switch to the 4X objective lens, and ensure phase contrast filters are selected.
 

NOTE: Any inverted phase contrast microscope for tissue culture with a dark background, e.g., PhP phase contrast, can be used following
standard microscope and camera procedures.

2. Within the microscope's software, set image capture settings to default values.
 

NOTE: Refer to the microscope's user manual to find the location of these settings.
1. Set 'brightness', 'contrast', and 'saturation' to 100% and 'gamma' and 'gain' to 1.0.

 

NOTE: Depending on the software, 'brightness' and 'contrast' may default to a value of 0% instead of 100%.
2. Set images to be captured in black and white using the highest resolution available (1,600 x 1,200 pixels (px) or greater).

 

NOTE: A 'saturation' of 0% is sufficient if a black and white setting is unavailable.

3. Place a standard hemocytometer onto the microscope stage and capture an image as depicted in (Figure 1A); this is the 'Volume Calibration
image'. Adjust exposure timing as required.

2. Image Volume Calibration

1. Open ImageJ and from the Plugins menu, start the Cell Concentration Calculator (CCC) plugin, e.g., Plugins > Analyzer > 'Cell Concentration
Calculator'.

1. If the right-side 'Image Volume Calibration' panel is not visible, click on 'Calibrate' to show it.

2. In ImageJ, open the 'Volume Calibration image' from step 1.3 ('File' > 'Open') and in CCC click on the 'Get Image Dimension' button.
 

NOTE: This will fill in both Image Width and Height text boxes with the image resolution in pixels automatically.
3. In ImageJ, select the 'Straight Line Tool' next to the selection tools and draw a straight line across the entire length of the hemocytometer

primary (P)-square demonstrated in (Figure 1B) by clicking and dragging the cursor.
1. Push the 'M' key to display the Results window containing the straight line measurements. Type the value from the Length column into

the 'P-square Length' textbox in CCC (Figure 1B).
2. Click on the 'Calculate Image Volume' button to output the image volume into the Image Volume textbox. Alternately, if the volume of

the image is already known, type the volume in nL into the Image Volume textbox.

4. Click the 'Save' button.
 

NOTE: The plugin is now calibrated.

3. Camera Exposure Calibration

1. Following cell harvesting for counting via hemocytometer, load 10 μL of cells into a chamber of the hemocytometer and place it onto the
microscope stage.

2. Using the same settings from step 1.2, adjust the exposure time so that the background lines of the hemocytometer disappear.
1. Adjust the focus so that the interior of the cells is darker than the cell membrane, indicating focus within the central cross section of the

cell and not the poles.
2. Further adjust the exposure so that the cells are not overexposed and resemble those depicted in (Figure 1C).

 

NOTE: Slightly visible hemocytometer lines are acceptable. It is recommended to save or record these settings to maintain accuracy
and reproducibility.

4. Image Acquisition

1. For each cell sample, load 10 μL into both chambers of the hemocytometer to increase statistical inference power2. Place the hemocytometer
on the microscope stage for imaging.
 

NOTE: The resolution and magnification of each image must be the same as the 'Volume Calibration image'. The plugin counts all images of
any selected folder; keep images to be counted together in the same folder.

1. If a filename auto increment function is available, turn it on and make sure each image is not shown after capturing to increase
throughput.
 

NOTE: Manually saving and closing each image will drastically slow down the process. Refer to the microscope's user manual for
information on the availability of an auto-increment function.

2. Capture at least three non-overlapping images of the central region of the hemocytometer although more (5-10) is recommended to
increase accuracy.
 

NOTE: Avoid both the top and bottom areas of the chambers as cells tend to increase in density at both locations. Take the same
number of images for every chamber. This is required for proper functioning of the plugin during counting.
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5. Image Counting and Dilutions

1. In CCC, click on 'Count Cells' and observe the Choose Directory dialog box. Select a folder to be counted.
2. Observe the sample number input box after selecting a folder. Enter the number of images taken per chamber, i.e., 4.1.2, and click 'Ok'. The

plugin will now count all the jpg, tiff, and png images in the selected folder in alphabetical order.
 

NOTE: Clicking the 'Sample Viewer' button will bring up the Sample Viewer window displaying information about the counted samples.
Sample concentration is the average concentration of all images taken per chamber. Samples with unitless concentrations can be added to
this list, such as the addition of a drug or small molecule treatment.

1. Recount the cell samples if the concentrations vary significantly within counts of the same samples (section 4).
 

NOTE: To calculate dilutions for all the counted-samples, CCC automatically uses the formula C1V1 = C2V2.

3. Use the scenario of seeding 15,000 cells per 200 μL into 30 wells of a 96-well plate + 1 extra:
1. Set the textbox to the right of the C2 label to 15,000 and the concentration volume textbox to 200, changing the adjacent combo box

unit to 'μL'.
 

NOTE: The plugin will ultimately calculate the concentration in cells/mL.
2. Make sure the volume combo box has V2 selected (final volume) and in the textbox to the right enter 6200 (200 μL x (30 + 1)),

selecting 'μL' in the volume unit combo box.

4. Click 'Calculate Dilution' to add the currently entered dilution to the bottom left list box.
 

NOTE: For each dilution added, will be solved for each sample and displayed in the tree diagram to the right. Double click on each entry to
expand.

5. Clicking the 'Save' button below the 'Sample Viewer' button to write to file all sample data and dilutions.
6. NOTE: These data can be recovered at any time by clicking 'Load' and selecting the saved file.

6. Migration and Invasion (Counter)

1. Perform the migration and invasion assays using the standard Boyden chamber method7-9.
2. After cells have migrated/invaded, carefully remove the media within the insert by inverting and gently tapping. Wick away any excess media

adhered to the bottom of the membrane by touching the edge to a paper towel.
 

NOTE: Do not touch the membrane itself to the towel, this may dislodge adhered cells.
3. Fix and stain the cells as reported7-9 in a 24-well plate set up with each row containing ~500 µl of a different solution, e.g., Fixative, Stain 1,

Stain 2, and double distilled water (ddH2O). Fill a second plate with 1x PBS to place the inserts in before cutting.
4. Wash the inserts by placing them into wells filled with ddH2O and fill the insert with ddH2O. Drain the water before swabbing away cells by

inversion.
5. Use a clean cotton applicator to remove un-migrated/un-invaded cells from the top of the membrane taking care not to damage the

membrane. Be thorough around the edges of the membrane.
6. Cut the membrane using a razor or a scalpel and carefully transfer the membrane (bottom-side up) onto a clean glass slide.
7. Add a small drop of mounting solution beneath and on top of the membrane and cover with a thin cover slip.

 

NOTE: Avoid trapping bubbles within the mounting solution to preserve accuracy of the counts.

7. Dissecting Scope and Camera Setup

1. Turn on the microscope's light source and camera.
 

NOTE: Refer to the microscope's user manual for detailed instructions.
2. Within the microscope's software, set image capture settings to default values.

 

NOTE: If an averaging function exists, a value of four is recommended. This is a good compromise between the degree of averaging and
image acquisition time. Likewise, a small degree of sharpening may increase image fidelity.

1. Set 'brightness', 'contrast', and 'saturation' to 100% and 'gamma' and 'gain' to 1.0.
 

NOTE: Depending on the software, 'brightness' and 'contrast' may default to a value of 0% instead of 100%.
2. Set display (real-time) and capture resolution to their maximum settings (1,600 x 1,200 px and 2,592 x 1,944 px, respectively).

 

NOTE: Display resolution can be adjusted as required if the refresh rate is too slow. Lower resolutions will make it more difficult to focus
accurately but increase the refresh rate.

3. For the stage of the dissecting scope, use a solid white background; a black or glass background is insufficient.
4. Use the above-stage light source, preferably from two flexible LED lights to the right and left of the stage.

 

NOTE: A below-stage light source will illuminate the pores within the migration assay membrane which may negatively influence the accuracy
of subsequent counts.

5. Place a completed migration assay membrane slide onto the stage. Looking at the real-time image displayed by the software, adjust the
magnification with the zoom adjustment knob so that the edges of a single membrane are just within the camera's field of view.
 

NOTE: Placing the slide on a glass plate overtop the white background stage makes it easier to maneuver the slide for imaging.
6. Adjust the light source positions (7.6.1) and exposure times to reproduce as closely as possible the ideal image depicted in Figure 2A.

Depending on the brightness, exposure times of 5-60 ms should be sufficient.
 

NOTE: The goal is to produce an image with as little background color as possible and a uniformly illuminated membrane without reducing
image fidelity, i.e., overexposure leading to a loss of visible cells.

1. Position the left and right light sources at a low angle relative to the slide. This will help remove background stain and chromatic
aberrations. Try to keep each light source directly opposite to the other.
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NOTE: While maneuvering each light source into position, turn the other off. This helps to center the area of illumination onto the
membrane itself more easily and accurately.

7. Remove the slide and white balance the image using a single button click in the microscope software.
 

NOTE: The microscope is now calibrated. Save as many settings as possible for future use and take note of the light source positions and
intensity.

8. Image Acquisition and Flatfield

1. Within the software, set the capture folder location, and capture one image per membrane. Name the images following the general template
of: Name - ###, e.g., Control - 001.tif, Control - 002.tif, Test drug - 001.tif, and so on.
 

NOTE: For best image results, save the image file type as tiff over other lossy formats such as jpeg.
 

NOTE: Images not following the general template will still be counted but will not be subject to automated grouping and flat fielding.
1. If flatfield correction is desired, for each slide find an empty area and take a Blank image following the naming convention: Name -

Blank.
 

NOTE: A blank is an area on the slide that contains no membrane and represents the background illumination.
2. Immediately before imaging, flatten each membrane by applying pressure over the coverslip and remove as many trapped bubbles as

possible.

2. In ImageJ, go to Plugins and open the TC plugin; e.g., Plugins > Analyze > 'Transwell Counter'.
3. Within TC, click on the 'Flatfield' button and observe the Choose Directory dialog box. Select the folder where the membrane images were

saved.
 

NOTE: Only images saved with the general template above will be automatically flatfield corrected and saved in a new folder called Flatfield
within the chosen folder. See Figure 2B for an example of a flatfield corrected image.

9. Configuration Settings

1. Open a migration assay membrane image in ImageJ ('File' > 'Open') and select Image > Adjust > 'Color Threshold…'. Observe the Color
Threshold window to adjust what colors will be filtered out of the image.

1. At the bottom of the window, set Thresholding method to 'Shanbhag', Threshold color to 'White', and Color space to 'RGB' (red green
blue); uncheck Dark background if selected.

2. Adjust the top sliders by clicking and dragging the markers to 0 and the bottom sliders to 255 (leave the bottom sliders at 255). Ensure
that the image is fully white.

2. Adjust the green and red top sliders until only the nuclei are visible.
 

NOTE: The settings selected will vary entirely upon the cell stain used. See Figure 2C.
3. In the TC plugin, input the values of the RGB top sliders into the associated Configuration Settings 'RGB Threshold' textboxes. Click the 'Add/

Modify' button and overwrite the configuration.
1. Leave the Size Range Lower and Upper values at 1 - Infinity.

4. Within the Configuration Settings panel, click 'Save' to write the settings to the hard drive.

10. Counting Images and Calibration

1. Open the TC plugin (8.2) and click on 'Count Folder' and observe the Choose Directory dialog box. Select the folder to be counted and wait
for it to finish.

2. Each counted-sample is automatically added to the main table. Key columns are 'Count', 'Quality', and 'Calibrate?'.
 

NOTE: The un-calibrated Count is the number of particles per membrane within the area displayed in the column 'Area range'.
 

NOTE: Quality ranges from approximately -0.8 to 1.7; Q ≥ 0.5 is acceptable.
1. Observe a checkmark in the 'Calibrate?' column if an image is flagged for calibration based on its resemblance to the ideal metrics.

 

NOTE: Both Quality and Calibration may suggest that the current settings are possibly insufficient. If after proper 'Color Thresholding'
and 'Size Ranges' have been selected and calibration is still suggested, inspection of the original and counted images should be the
final determinant of a valid count.

3. Select All the Samples in the Table Flagged for Calibration.
1. Right click in the table and select Recount > 'Suggested size'. This will recount the images with a suggested minimum particle area.
2. Right click again and select 'Show Plot'. Observe the frequency scatter plot of particle areas. An ideal image will have a graph

resembling a long right-tailed normal distribution, i.e., the bell curve. See Figure 3B.
3. Adjust the lower Size Range, if required, by selecting the sample, right clicking, and selecting Recount > 'Manual settings'. Observe the

manual settings dialog. Enter the desired settings and click Count to recount the image with the new settings.

4. To adjust the counts manually, select the samples, right clicking the table, and select 'Open image with counts'. Observe the original image
with red markers representing each particle counted by the plugin.
 

NOTE: Recount > 'Show counted binary image' can be useful to check how well individual cells are being resolved by the color thresholding.
1. To add a count, hold 'Ctrl' and left click. Observe a marker at the cursor location that will be added to the samples total count. To

remove a marker, right click the image. The plugin will remove the marker closest to the cursor.
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2. To remove a group of markers, use a selection tool in ImageJ to select a region of interest (ROI). While holding 'Ctrl', right click the
image and all markers inside the ROI will be removed. Observe the cell number in the 'Count' column.

11. Saving/Opening Results and Exporting to CSV

1. In TC, go to the menu bar and click on 'File' > 'Save results'. Observe the Save Results dialog box. Choose a name and destination and click
'Save'.

1. Use 'File' > 'Open results' to load a file containing all the data displayed in the main table, including the plot.
 

NOTE: The results file saves the directories the images are saved in. If the original images are moved after saving, the 'Open original
image' and 'Open image with counts' functions will fail.

2. To reset the image directory, select the samples, right click the table, and select 'Reset image directory'. Observe the Choose Directory
dialog box. Select the new folder and if the images exist, the directories will be reset. Re-save the results file.

2. To save a Comma Separated Values (CSV) file, in the menu bar go to 'File' > 'Export to .csv'. This produces a file with samples organized
into statistical groups with the mean count and standard error of the mean; its layout is designed for quick graphing in common graphing
programs.
 

NOTE: The statistical groups are based on the groups created within TC.
1. If the samples follow the general naming template, select the samples to be grouped, right click and select 'Auto grouping'. This adds

samples with the same 'Name' to the same group. Using the example Control - 1, Control - 2, Treatment - 1, Treatment - 2: both
controls would be added to the group 'Control' and treatments to 'Treatment'.

2. Add samples manually to groups by double clicking the sample's 'Group' cell and typing in the group name. Select the samples to be
added to this group, right click and select 'Add to group'.

Representative Results

Cell Concentration Calculator

Figure 1 presents the overall process of CCC calibration and countable image acquisition. Figure 1A and 1B depict the P-square calibration
image and calculation of P-square length in pixels. CCC determines cell concentration in a given volume using the formula:

A hemocytometer's P-square has a volume of 100 nL (1 mm x 1 mm x 0.1 mm) and given this constant, the total image volume can be calculated
after converting pixels to mm. Figure 1C is an ideal countable image with in-focus cells displaying the characteristic phase illumination and no
background hemocytometer graduations. Finally, the scatter plot of Figure 1D shows a highly correlated, manual versus automated count of cells
from 57 images taken over various experiments and cell types including HTR8, ES-2, and Swan71. Of note, the upper range of concentration
was ~5.6 x 106 cells/mL with a low end of ~2.3 x 103 cells/mL (≈ 5 cells per image). It is suggested that if counts are below 10-15 cells per image,
the sample should be suspended in a smaller volume to increase statistical power.

Acquisition and Processing of Images for Migration Assay Counter

Hundreds of migration assay membranes were imaged over many experiments, all of which were seeded with the Human trophoblast cell
line HTR8, Swan71, or ovarian cancer cell line ES-2. Of these images, multiple were chosen to represent a range of categories from very
poor to excellent quality based on brightness, clarity and color of stained cells, and the degree of background staining and unwanted particles
(noise). Using these images, the default RGB Threshold color settings (≈ 150, 120, 0) were determined (Figure 2C) and used as a baseline
in all subsequent developments of the algorithm. The goal was to maximize the nuclear color to total color ratio, i.e., the majority of colored
pixels should be within cell nuclei. The upper panel in Figure 2A depicts the ideal image brightness, cell nuclei clarity and color, and negligible
background noise. The brightness of the image is important to ensure there is a great enough contrast between cell and background to produce
a black and white binary image.

If this difference is not met, large or unpredictable areas may be counted by the ImageJ Analyze Particles function; the best case scenario
is a completely white background. In opposition, the lower panel of Figure 2A has extreme background staining and cells that are nearly
indistinguishable. Membranes with this degree of staining will most likely produce unreliable results from the migration assay counter.

In some instances, increasing brightness to the ideal level may affect image fidelity by overexposing the image. Similarly, high exposure or
brightness may produce systemic chromatic effects with progressive or irregular light and dark regions. With flatfield correction, these effects can
be minimized or removed entirely as shown in Figure 2B (upper vs. lower panel). Furthermore, flatfield correction is a good way to equalize the
brightness of multiple membrane images.

https://www.jove.com
https://www.jove.com
https://www.jove.com


Journal of Visualized Experiments www.jove.com

Copyright © 2016  Journal of Visualized Experiments November 2016 |  117  | e54719 | Page 6 of 10

Calibration and Validation of Migration Assay Counter

To assist the user in better determining if migration assay membrane images meet the required criteria for accurate counting, two qualifiers
were designed, called image quality (Q), and calibration recommendation (CR). Importantly, both qualifiers, as the name CR suggests, are
recommendations only and act as guides rather than absolute judges of the countability of each image. Both Q and CR are based on the
metrics of the frequency scatter plot of particle area (10.3.2). For simplification, a metric can be regarded as the various shapes of the curve
that make up the frequency plot. The desired metric of an adequate Q (≥0.5) was determined by the observed approximate normal distribution
of cell size. Commonly, cells that are unresolvable from each other, over-stained, or just particularly large, shift the skewedness to a right-
tailed normal distribution (Figure 3B). As such, this is the ideal metric of a typical calibrated image. With the addition of background noise,
this normally leads to a large number of particles in the 1-5 pixel area range (Figure 3A). In order to calculate the plot metrics, the data are
fitted with ten Savitzky-Golay smoothed curves of differing polynomial degrees produced by Dr. Michael Thomas Flanagan's Java Scientific
Library (http://www.ee.ucl.ac.uk/~mflanaga/java/).  Essentially, this creates multiple points in the approximate region of each extremum.  Through
a series of density cluster maps of local minima and maxima, a general picture of the plot metrics can be computed as an ordered list, i.e.,
minimum, maximum, minimum/maximum overlap, …, nth extremum. In brief, the degree to which the smoothed curves fit the frequency data
determines how tightly packed the extrema points are. The greater the clustering of non-overlapping extrema, the greater Q becomes. In theory,
Q represents overall image clarity based on the distribution of distinct particle sizes.

Whether the Boolean CR is true or not depends on the sequence of extrema. From Figure 3A, the ordered list would be minimum, maximum,
and a sequence of overlapping extrema based on the properties of the Savitzky-Golay curve. Since Figure 3A represents an uncalibrated
image, this general sequence of extrema flags CR as true, suggesting to the user that the image may need calibration. Moving forward, it can
be seen that from Figure 3B, this list would be identical but with the exclusion of the first minimum. Thus the metrics of ideal uncalibrated and
calibrated images were determined. Deviations from these metrics will generally flag an image for calibration and reduce Q ≤ 0, such as the case
with the high background noise membrane in Figure 3C. Applying these qualifiers to a selection of modest to excellent images, with regards to
brightness and background noise, it is clear that calibrated image counts are significantly closer to manual counts than uncalibrated (1.9% ± 0.3
vs. 21.7% ± 2.9, respectively; Figure 3D, E). Given the overall high quality of images chosen for analysis (uncalibrated  = 0.71 ± 0.04; mean ±
SE), there was an expected modest increase only in Q following calibration (  = 0.90 ± 0.04). Taken together, Q suggests the overall countability
potential of an image whereas CR is a strong indicator of whether calibration is successful or not.

Timing Comparisons of Both Cell Concentration Counter and Migration Assay Counter

Two researchers (User 1 and User 2) were used to test the speed comparisons between manual and automated methods. Both researchers
had substantial experience with cell counting and the migration assay but User 1 was experienced in the usage of both CCC and TC while User
2 had to follow written instructions. Figure 4A compares CCC calibration time between User 1 and 2. As expected, User 1 was substantially
faster than User 2, together, taking on average approximately five minutes for CCC calibration. In order to compare manual hemocytometer
counting and automated rates, the manual rate of counting using a tally counter was compared to the time it took to take nine images of the
hemocytometer chamber and counted in CCC (Figure 4B). A typical cell concentration of 1.15 x 106 cells/mL was used to compare timings,
leading to an average of 1x increase in throughput. This rate will vary depending on the number of cells loaded into the hemocytometer as the
total time taken to capture images and process them is independent of cell number.

Lastly, timings encompassing image acquisition of membranes, quantification within TC, and manual adjustments of these images was measured
in Figure 4C. Notably, 12 migration assay membranes with low cell number (Total = 10,571 cells) and substantial background staining and
cellular debris were chosen to facilitate a worst case scenario that would require manual adjustments to cell number. This is reflected in Figure
4C adjustment (Adj) column where it took an average of 13 min to remove unwanted counts and add missed cells. For comparison to manual
counting, optimal cell counting rates were determined with Cell Counter; high quality membrane images with high cell density were used (results
not shown). This yielded an average maximal rate between User 1 and 2 of 9.1 x 103 cells/h (~2.5 cells/s). Using these numbers, the membranes
from Figure 4C were counted 4.4x faster with TC than would be expected at maximal manual rate. The time savings are directly dependent
on cell number and image quality, by counting migration membranes that required little or no adjustment and high cell density (~7,000 cells/
membrane), TC generated cell counts 1,395x faster than the maximal manual rate.
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Figure 1: Cell Concentration Calculator. (A) Phase contrast micrograph of the central primary square of the hemocytometer taken at
40X total magnification. Scale bar represents 200 µm. (B) A cropped version of the image from (A) depicting what length to measure on the
hemocytometer. The Results window Length column was highlighted for easy identification. Yellow bar = 1 mm. (C) An ideal micrograph of a
hemocytometer containing HTR8 cells after microscope and software calibration at 40X total magnification with a resolution of 1,600 x 1,200 px.
Scale bar = 200 µm. (D) A scatter plot comparing manual counts using the ImageJ plugin Cell Counter compared to automated counts of the
same images using Cell Concentration Calculator. n = 57 images. Please click here to view a larger version of this figure.

 

Figure 2: Migration assay counter representative images. (A) The upper panel is a one eighth portion of a total membrane depicting
an ideal image with minimal background; Scale bar = 200 µm. The lower panel contains an image with significant background staining that
severely affects the accuracy of the automatic counting; Scale bar = 585 µm. (B) The upper panel represents a dark image of good quality which
produced inaccurate counts. The bottom panel is a countable version of the same image after flatfield correction. Scale bars = 593 µm. (C)
The upper panel represents a zoomed-in view of a typical membrane. The lower panel is the same image followed by the desired ImageJ color
thresholding (RGB Threshold = 150, 120, 0) to remove intercellular background and the majority of the visibly stained cytoplasm. All images were
taken at 1.35X total magnification with a calibrated dissecting scope at a resolution of 2,592 x 1,944 px from multiple migration assay invasions
of HTR8 stained with hematoxylin. Scale bars = 100 µm. Please click here to view a larger version of this figure.
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Figure 3: Calibration and validation of migration assay counter. (A) Typical example of an uncalibrated image of high quality. (B) The
calibrated version of (A) using migration assay counter's Recount > 'Suggested size'. (C) A typical frequency plot of a low image quality
membrane with significant background stain or overall darkness. (D) A scatter plot comparing manual counts using the ImageJ plugin
Cell Counter and migration assay counter automated counts. (E) A bar graph showing the average percent difference of calibrated versus
uncalibrated automated counts. Data are Mean ± SE. P < 0.0001, n = 30, unpaired t-test with Welch's correction. The same images were used
for D and E. Calibration of both was done with the Recount > 'Suggested size' and Recount > 'Manual settings' to further refine the minimum size
counted and color threshold. No manual count adjustments were made using the 'Open image with counts' function. Please click here to view a
larger version of this figure.

 

Figure 4: Timing of Cell Concentration Counter and migration assay counter usage. (A) Comparison of CCC calibration times (steps 1 and
2) between User 1 (CCC/TC expert) and User 2 (CCC/TC novice). (B) Manual cell counting times were averaged over five trials and expressed
in cells counted per min. Automatic counts were calculated by averaging times to capture nine images of a hemocytometer chamber and counted
with CCC. Cell concentration used was ~1.15 x 106 cells/mL. Data are Mean ± SE. n = 5. (C) Transwell Counter timings were compared over
three categories: acquisition (Acq; steps 7 and 8), quantification (Qnt; steps 10.1-10.3.3 using default configuration settings), and manual
adjustment (Adj; steps 10.4-1.4.2). The membranes quantified had a high degree of background staining and debris in order to necessitate
substantial manual adjustment for accurate counts. Please click here to view a larger version of this figure.
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Discussion

Critical Steps, Troubleshooting, and Limitations

The very nature of automated computational methods, specifically those of particle analysis, necessitates the mathematical ability to define these
particles. Consequently, the accuracy of both Cell Concentration Calculator and migration assay counter is majorly dependent on image fidelity,
that is, how closely the captured image resembles the cell sample or migration assay membrane. It is therefore of the upmost importance to
follow microscope and associated software calibration protocols as best as possible. This includes limiting background noise, reducing unwanted
particles, capturing bright and uniformly in-focus images, and saving in non-lossy file formats such as tiff. Thus, both plugins are likely to produce
erroneous results if these requirements are not met. It is therefore always good practice to double check cell counts to determine if they match
visual expectations when in doubt. If indeed the results do not match, comparing the original image with the binary image may help elucidate
the issue (10.4 note). In some cases, darker migration assay images may contain large areas that have been counted due to pixel values falling
within the color threshold limits. In general, using a flatfield image will remove darkness and blotchiness and prevent most unwanted counts due
to chromatic irregularities.

Given these possible and relatively common issues, it is important to follow standard image integrity guidelines like those proposed by the Nature
Publishing Group and others13. To keep counts consistent, any adjustment to one image should be applied equally to all others. This includes
but is not limited to contrast, saturation, brightness, gain, filters such as averaging and sharpness, and color filters. Adjustment of gamma should
be avoided as it applies a non-linear change of pixel color and so may affect each image differently14. When applying a common exposure time
to images with few cells (<1,000), this can lead to overexposure and loss of image fidelity. Conversely, a membrane with thousands of cells can
require higher exposure times to prevent underexposure. Accordingly, it is best practice to adjust images as little as possible, and only when
necessary, to maintain the highest image fidelity achievable.

Even with a high fidelity image, true particle counts can be severely skewed by unwanted particles. When using Cell Concentration Calculator, if
a sample contains significant amounts of cell debris, specifically of areas similar to those of suspended cells, this may skew the result. In some
cases, this could prevent automated analysis if the debris cannot be minimized. Likewise, migration assay membranes that contain high levels of
background staining of similar color to stained cells or unremoved cells from the backside of the membrane, will likely produce inaccurate results.
These unwanted particles can normally be removed in a few ways: increasing the light source brightness or exposure time, modifying the color
thresholding to be more stringent, or manually removed via 'Open image with counts' (10.4). It is important to note that this protocol produces the
optimal quality of image required for CCC and TC to maintain accuracy. However, TC is capable of counting images of significantly less quality,
varying magnifications, or different color stains, generally only requiring more time spent on manual adjustments (10.4).

During calibration of any migration assay membrane image it is important to take into consideration the resolution of the image and the relative
size of the cells. As previously described, Image Quality (Q) and Calibration recommendation (CR) are dependent on frequency plot metrics of
particle area. Of the images analyzed, each cell takes up on average 1/100,000 of the total image area. When using images of just millions of
pixels with a small cell size ratio, the variation in cell size is also small. That is, the variance may only range from 10-60 px. But as the cell area
to image area ratio gets larger, the distribution of cell sizes increases, reducing the Kurtosis of the cell size normal distribution by decreasing the
frequency of any given area. This in turn can make automated calculation of cell area more difficult or impossible because a definite minimum
area cannot be determined. Similarly, this also applies to images with few numbers of cells where the frequency of different cell sizes may be
very low (<50). As a result, when analyzing images with different resolutions than those used in this study or different distributions of cell size,
manual identification of cell size range may be needed (10.3.3).

Significance and Future Directions

The ImageJ plugin Cell Counter was initially released in 2001 by Dr. Kurt De Vos and has served as a staple for manual cell counting to this
day. To continue the trend of freely available tools for the biological community, Cell Concentration Calculator and migration assay counter offer
the next step in free tools to help increase throughput and inter-experimental reproducibility of migration assays. The end result of migration
assays is highly dependent on the number of cells seeded. Ergo a reliable cell count is a necessity for reproducibility. In this way, CCC offers
both increased accuracy due to higher statistical certainty of cell concentration and shorter count times preserving cell health.

Moreover, the end result of both plugins is a count of cell number and not a relative index such as fluorescence. Various other protocols exist
that measure fluorescence after staining but these methods suffer from lack of sensitivity13. Adobe's Photoshop offers its own particle analysis
tool but the program must be purchased for use and does not offer the post-counting analysis available from migration assay counter20. Both
plugins rely on the particle counting feature from ImageJ and consequently can be modified by the end user by editing the macros used
by ImageJ. This offers greater flexibility for the user to expand the scope of the plugins to other particles by creating new macros. Further
development to increase the breadth of countable particles and incorporate end user contributions is the next logical step. By combining the core
principles of Cell Counter with an automated counting algorithm and post-counting analysis, this greatly increases the ease with which migration
assays can be processed without any loss of accuracy. The plugins are freely available for download with installation instructions from: http://
peng.lab.yorku.ca/imagej-plugins.
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