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SUMMARY
This protocol presents a step-by-step guide for the Simultaneous Label-free Autofluorescence Multi-harmonic (SLAM) microscopic technique, including details on how to generate the laser light source, prepare a tissue sample, conduct imaging, and analyze the data. SLAM advances nonlinear microscopy by measuring four complementary label-free contrasts to investigate the tissue microenvironment. 

ABSTRACT
Nonlinear optical microscopy images biological samples by detecting signals from the nonlinear interaction of ultrashort laser pulses with endogenous molecules. This method allows fast chemical and structural identification at subcellular resolution in a label or tag-free and nondestructive manner, thereby enabling a powerful approach to investigate cells and tissues. These distinctive nonlinear contrasts include multiphoton-excited autofluorescence and harmonic generation. Because each of these contrasts offers unique advantages and limitations, their combination and their spatiotemporal co-registration provide a complementary contrast palette that enhances the analytical capabilities of nonlinear optical microscopy. Therefore, our group developed Simultaneous Label-free Autofluorescence Multi-harmonic (SLAM) microscopy, an imaging technique that measures four concurrently generated nonlinear optical signals, aiming to identify distinct morphological, metabolic, and functional features in biological specimens. Here, we present a protocol for SLAM imaging of tissues, focusing on essential components of the technique, including the laser source, pulse compression, and microscope. In addition, we discuss sample preparation and outline the data processing pipeline for SLAM data. The presented workflow is suitable for investigating the metabolic state, arrangement, cellular responses, and composition of both human and animal tissues without relying on exogenous labels.

INTRODUCTION
[bookmark: _Hlk199516904][bookmark: _Hlk199388515]Nonlinear optical microscopy leverages the response of a specimen to intense optical radiation (light with electric fields larger than 3 x 103 V/cm) to derive image contrast, where the induced polarization (and thus the signal generated) depends nonlinearly on the incident intensity1–3. Because these multiple contrasts are each mediated by different light-matter interactions, nonlinear microscopy provides simultaneous access to unique information regarding both the morphology and chemical landscape of a specimen1–3. While traditional microscopy techniques involving a linear interaction with the illumination light also enable quantitative imaging, nonlinear microscopy permits a more multimodal approach, often having improved imaging depth and optical sectioning, while also causing less photodamage to the sample4. In the context of biomedical applications, such as intraoperative histology-like evaluation of tissue5,6, this technique enables the direct probing of native biomolecules, facilitating seamless investigations of living cells without the need for external markers or modifications. This approach avoids the use of tags, labels7, exogenous molecules, genetically expressed fluorescent proteins, or nanoparticles, which not only require extensive labor but also have the potential to disrupt the specimen’s native biochemistry and negatively impact target cells or tissues8–10. Thus, the nonlinear microscope serves as a powerful and genuine analytical tool that provides continuous imaging of microscopic structures without altering the specimen's chemical and structural integrity. This capability opens a wide array of applications, ranging from diagnosis and drug discovery to cell signaling and systems biology.

[bookmark: _Hlk199389113][bookmark: _Hlk199392540]Multiphoton contrasts such as two-photon autofluorescence (2PAF), three-photon autofluorescence (3PAF), second-harmonic generation (SHG), and third-harmonic generation (THG) each confer analytical advantages in characterizing samples. 2PAF is generated by endogenous flavins, with flavin adenosine dinucleotide (FAD) being the most abundant in biological systems11. 3PAF leverages near-infrared excitation to visualize intrinsic chromophores such as NAD(P)H and enables metabolic imaging while circumventing UV-related phototoxicity and attenuation issues12. SHG specifically reveals non-centrosymmetric molecular structures such as fibrillar collagen (types I, II, and III) and protein arrays13–17, providing structural insights1. Lastly, THG, sensitive to interfaces and small structural features, excels in imaging lipid distributions and extracellular vesicles18–22.

Each of these contrast signals has been independently explored by research groups, establishing the niche for multiphoton nonlinear microscopy as a reliable and versatile tool for biological applications23–26. These efforts were spearheaded by the inventors of the 2PAF microscope, who harnessed their innovative technology to make new insights into tissue morphology, cell metabolism, and even the morphofunctional features of pathologies such as Alzheimer’s disease and cancer23. Their work has ultimately driven groundbreaking applications in neuroscience27,28. In the following years, several researchers highlighted the sensitivity of the SHG to changes in the extracellular matrix, the scaffold that provides structural support to cells and which undergoes substantial alterations during cancer pathogenesis29. Notably, Campagnola et al.14,24,30,31 demonstrated that SHG microscopy enables the visualization of macromolecular and supramolecular assemblies, revealing details such as the arrangement, concentration and type of collagen that are not detectable with conventional fluorescence-based techniques. These results underscored the potential of SHG microscopy as a viable diagnostics tool in clinical settings. Finally, THG microscopy was successfully applied to visualize retinal layers in rodents at subcellular resolution25, map brain structures32, and capture the multi-interfacial topography of melanoma cell invasion33.

These historical implementations of nonlinear microscopy generally involved a mode-locked femtosecond (fs) laser coupled to a high numerical aperture (NA) objective to generate and collect the nonlinear signals, which were then directed with a dichroic mirror to a bandpass filter and collected with a photomultiplier tube (PMT)34. Despite similar implementations, most applications focused on acquiring only one, or, at most, two contrasts, while overlooking the others. To fully realize the potential of the multiphoton microscope, Boppart et al. first implemented the sequential acquisition of multiple nonlinear contrasts21,35–37, followed by their simultaneous detection4,22,38–41. The resulting technique, known as Simultaneous Label-free Autofluorescence Multi-harmonic (SLAM) microscopy, spatially and temporally co-registers the nonlinear 2PAF, 3PAF, SHG, and THG signals through single-shot excitation and multiplex detection, thereby achieving superior analytical power. The spatiotemporal co-localization of these four channels provides highly ranked and feature-rich data42 offering advantages over sequentially acquired data by eliminating motion artifacts and ensuring improved image registration. Consequently, SLAM enables the generation of composite features, such as optical reduction-oxidation ratios, that effectively characterize metabolic properties43–45. Moreover, the combined analysis of signals across modalities facilitates the engineering of additional features based on the correlation and colocalization of channels. For instance, Shi et al. demonstrated the importance of the colocalization features of SLAM microscopy in accurately classifying Chinese Hamster Ovary (CHO) cells used in pharmaceutical production42. In this way, SLAM lays the groundwork for what is now considered the state-of-the-art in multiphoton microscopy, paving the way for future advancements in the field46.

In this protocol, we outline the key components of a SLAM microscope (Figure 1) and describe a step-by-step methodology for its implementation. This includes the generation and shaping of the excitation pulses, representative tissue specimen preparation, imaging procedures, and the processing, as well as the display of the resulting data. By utilizing off-the-shelf technology and established techniques, this protocol is universal, transferable, and can be easily reproduced using similar optical systems across different laboratories.

[Place Figure 1 here]

PROTOCOL 
All animal studies were performed as per the protocol UIUC#23031 approved by the University of Illinois Institutional Animal Care and Use Committee and strictly followed all relevant guidelines and regulations.

1. Cleaving and aligning photonic crystal fiber (PCF)

1.1. Using fiber cutters or wire cutters, cut a section of photonic crystal fiber (PCF, Table of Materials) to a length of slightly over 15 cm.

[bookmark: _Hlk199104311]NOTE: Lengths of at least 1.5 cm will be cleaved from each end of the PCF since this length is required to securely clamp the PCF during cleaving. The final length of the PCF (12 cm) used in this study was determined based on a previous simulation using the generalized nonlinear Schrödinger equation47 and empirical testing. In general, the best PCF length may vary depending on the PCF type, the pump laser input, and the desired supercontinuum.

CAUTION: While cutting PCF, wear personal protective equipment (PPE) to protect the experimenter’s eyes and skin. Immediately dispose of fiber scraps into the sharps disposal container.

1.2. Strip off about 3 cm of the plastic coating from each end of the PCF using a fiber stripper (Table of Materials) or razor blade, and clean any residual plastic with tissue paper (Table of Materials) and 100% methanol.

1.3. Place one end of the PCF into the holder on a precision optical fiber cleaver (Table of Materials) and align the blade 1.5 cm from the end of the PCF. Carefully close the clamps and press the cleave button.

NOTE: Carefully follow the user manual of the fiber cleaver, including specific guidelines for cleaving PCFs. The settings, such as fiber tension, may require fine-tuning for consistent and high-quality cleaves for each type of PCF.

1.4. [bookmark: _Hlk199351796]Inspect the cleaved face and side of the PCF using the integrated microscope (10x magnification) on a glass fiber processing workstation (Table of Materials), ensuring the cleave is of good quality (Figures 2A,C). Re-cleave if there is debris (Figure 2D), scratches (Figure 2E), or the cleaved surface is not flat and perpendicular to the length of the PCF (Figure 2B).

NOTE: Extreme care should be taken in this step and subsequent steps to avoid touching the cleaved ends of the PCF to any surface to avoid causing damage.

1.5. Cleave the second end of the PCF, ensuring the desired final length.

NOTE: The PCF used in this protocol is cut to 12 cm.

1.6. As with previous steps, inspect the newly cleaved end of the PCF (refer to step 1.4). If the cleave appears faulty or inconsistent, discard the current PCF and repeat the process with a new one.

1.7. Clamp the input end of the PCF on a 3-axis stage (Table of Materials) at approximately the focal length of the fiber coupling lens as measured with a ruler. Securely support the other end of the PCF with a temporary post or mount.

NOTE: Do not clamp the output yet to avoid breaking the PCF during gross adjustment.

CAUTION: Supporting the output end, and surrounding it with sufficient beam blocks, is necessary to reduce the risk of laser exposure.

1.8. Place an optical power meter (Table of Materials) in the beam path just before the PCF to measure the input power. Ensure that the femtosecond laser (Table of Materials) is blocked by shutter 1 before turning on the laser.

NOTE: Always complete any required laser safety training programs to understand the risks associated with laser use. 

CAUTION: When operating the laser, wear appropriate laser safety eyewear specifically rated for the wavelength and power of the laser in use. Before operating the laser, remove all jewelry, watches, and other reflective items that can cause dangerous stray reflections.

1.9. Turn on the laser and allow it to warm up for the laser’s specified “cold warm up time”. Open shutter 1 and adjust the power using the half wave plate (HWP1) just before the polarizing beam splitter until the power meter reads 260 mW or less.

NOTE: The use of 260 mW for alignment was determined empirically as being low enough to avoid damaging the PCF (even while misaligned) while still providing a bright beam for visualization on an IR viewer or fluorescent target.

1.10. Block the laser using shutter 1 and move the power meter to the output end of the PCF.

1.11. Unblock the laser and adjust the optical axis of the PCF input face using the 3-axis stage until signal appears on the power meter, indicating some light is coupled into the core, cladding, or plastic coating of the PCF. If positioning the PCF input at the focus of the beam is beyond the range of the 3-axis stage, block the laser, then adjust and re-clamp the PCF.

NOTE: An infrared (IR) viewer or fluorescent target can be used to visualize where the beam is focused. 

1.12. Using the 3-axis stage, adjust one dimension of the optical axis of the PCF to find the range over which light is coupled, calculate the middle of that range, and move the stage there. Repeat this for the second dimension to approximately center the beam on the core of the PCF.

NOTE: The µm tick marks on the 3-axis stage can help measure distances and find the center of the PCF.

1.13. Iteratively adjust the three dimensions of the 3-axis stage in a repeating sequence while optimizing coupling efficiency to precisely center and focus the beam into the core of the PCF. 

NOTE: If the maximum coupling efficiency, as measured by the power meter, is noticeably lower than 80% of the input power close shutter 1, unclamp the PCF and inspect it for damage. If damaged, restart from step 1.1, else, block the laser, re-clamp the PCF and restart alignment from step 1.11.

1.14. Block the beam with shutter 1 and increase the laser power to 1.6 W. 

NOTE: The use of 1.6 W was determined through simulation and empirical testing to generate a sufficiently broad supercontinuum, while staying below the damage threshold of the PCF.

1.15. Open shutter 1 and once again iteratively adjust the 3-axis stage to adjust the PCF input location to optimize coupling efficiency.

NOTE: Empirically, the maximum efficiency is typically about 80%.

1.16. Close shutter 1 and clamp the output of the PCF at approximately the focal length of the parabolic mirror. Place a beam block at the output of the parabolic mirror.

1.17. Reduce the laser power again to 260 mW or less.

1.18. Open shutter 1 and use the parabolic mirror’s 3-axis stage to align the optical axis of the parabolic mirror to minimize distortion of the beam. Next, adjust the focus and collimate the beam in the far-field. 

NOTE: Use an IR viewer or fluorescent target to view the output beam.

1.19. Adjust mirrors after the parabolic mirror to ensure the beam is aligned to the rest of the optical system. 

NOTE: Install permanent flip alignment targets or irises to make this step reproducible.

1.20. Close shutter 1 and increase the laser power to 1.6 W. Open shutter 1 and verify the beam path is unchanged.

1.21. Measure the output power of the pulse shaper (Table of Materials) using a power meter. Rotate the half-wave plate in front of the pulse shaper (HWP3) to optimize the transmission efficiency of the pulse shaper.

2. Pulse characterization and optimization

2.1. Using a spectrometer or optical spectrum analyzer (OSA, Table of Materials), measure the laser after the parabolic mirror to verify the supercontinuum generation of the PCF.

2.2. Rotate the half wave plate after the polarizing beam splitter (HWP2) to optimize the width of the supercontinuum.

2.3. [bookmark: _Hlk199353743]Turn on the microscopy autocorrelator (Table of Materials). Using the software, set the detector to the internal detector and set the scan range to 5 ps to ensure the entire width of the pulse autocorrelation will be captured.

[bookmark: _Hlk199468148]NOTE: For setups with longer pulse widths (for example, due to dispersion in a long PCF), the scan range should be increased appropriately. Keep in mind that the pulse width measured by an intensity autocorrelator is not the true pulse duration, but it can still serve as a useful reference for pulse compression. For accurate and complete characterization of both the pulse amplitude and phase, spectrally resolved techniques such as Frequency-Resolved Optical Gating (FROG)48 should be used.

2.4. Unblock the laser and align the autocorrelator to the beam exiting the pulse shaper until a signal appears.

NOTE: Placing temporary mirrors (two at the input and two at the output of the autocorrelator) will enable alignment of the beam to the autocorrelator without affecting the rest of the optical system.

2.5. Ensure that shutter 1 is closed and apply the appropriate immersion media (such as water or oil) to the objective lens (Table of Materials). Place the autocorrelator external detector on the microscope stage (Table of Materials) and adjust the stage to position the detector directly above the objective.

[bookmark: _Hlk199092771]NOTE: Unlike typical microscope objectives, the recommended objectives used for SLAM microscopy are ultraviolet transmissive to improve the detection of THG38.

2.6. Turn on the scanning galvanometer mirrors (Table of Materials) and set their voltage to zero. Open the shutter and use an IR viewer or fluorescent target to verify that the beam is reaching the external detector.

2.7. Set the autocorrelator detector to be the external detector. Adjust the stage position until the signal shows up. 

NOTE: If the detector saturates, lower the power using the neutral density filter.

2.8. [bookmark: _Hlk199354242]Adjust the polynomial coefficients (orders of dispersion) of the pulse shaper to iteratively minimize the pulse width measured by the autocorrelator. Reduce the autocorrelator scan range appropriately as the pulse width decreases to improve accuracy and visualization of the autocorrelation function.

NOTE: The optimal pulse width as measured with a Gaussian fit should be a few tens of femtoseconds (fs).

3. Sample preparation

NOTE: For simplicity, this protocol describes ex vivo tissue imaging. However, due to the label-free nature of SLAM, in vivo imaging procedures are easily adapted38.

3.1. Euthanize the animal via CO2 asphyxiation or other IACUC-approved method of euthanasia.

3.2. Harvest the organ(s) of interest using standard necropsy procedure49 within 10 min post-mortem and rinse with pre-chilled phosphate-buffered saline (PBS) to remove blood. 

NOTE: In this study, the liver and lungs were harvested. 

3.3. Dissect the organ vertically or horizontally using a blade, depending on the required orientation for analysis. Ensure that the dissection is performed with precision to maintain the integrity of the tissue structure. 

3.4. Place the piece of tissue in a sterile tissue culture dish filled with phenol red-free complete cell culture media. Refrigerate the tissue at 20 °C if not collecting images immediately. 

NOTE: The cell culture media used in this study was HEPES buffered-Dulbecco's Modified Eagle's Medium (DMEM) supplemented with 10% Fetal Bovine Serum (FBS), 4 mM glutamine, and endothelial cell growth medium supplements (Table of Materials). This media was carefully chosen to maintain the physiological viability of the epithelial and endothelial cells residing in the renal tissue sample during the imaging duration50. 

3.5. To prepare fluorescence calibration standards, zero a precision scale to the weight of an anti-static weighing boat and measure approximately 5 mg of flavin adenine dinucleotide disodium salt (FAD, Table of Materials) or 5 mg of reduced nicotinamide adenine dinucleotide disodium salt (NADH, Table of Materials). 

3.6. Use a single-channel pipette to dispense an appropriate volume of 1 M HEPES buffer into the weighing boats containing pre-weighed FAD or NADH powders to prepare 5 mM stock solutions. Pipette up and down repeatedly to dissolve the powder. 

3.7. Prepare 1 mM working solutions from the stock solutions by 1:5 dilution into the HEPES buffer. 

NOTE: The 1 mM working concentration used in this study was determined empirically to produce high signal while avoiding detector saturation.

3.8. Store the stock FAD and NADH solutions in microcentrifuge tubes at 4 °C.
 
NOTE: Solution standards may be stored refrigerated for several days, but it is recommended to prepare fresh solutions for each experiment.

3.9. Just prior to collecting SLAM microscopy images, place the tissue samples into 35 mm glass bottom imaging dishes (Table of Materials). Alternatively, use a glass coverslip.  Aliquot the FAD and NADH solutions into identical dishes or coverslips.
 
[bookmark: _Hlk199513087]NOTE: Uncoated glass or poly-D-lysine coated glass is strongly recommended due to reduced background signal. Ensure that the glass thickness is appropriate for the microscope objective being used (this study used #0).

4. SLAM setup and operation

4.1. Verify that the laser input to the PCF is blocked and switch on the laser. Let the laser warm up for the specified “cold warm up time” of the laser.

NOTE: 30 min cold warm up time is used for the laser in this study.

4.2. Verify that the beam path is clear of obstructions and place an optical power meter in the beam path just before the PCF. Unblock the laser and measure the input power.

4.3. Block the laser and move the power meter to the output of the PCF after the parabolic mirror. Maximize the PCF output using the input 3-axis stage.

4.4. Let the PCF warm up for 10 min, then maximize the output power again. Record the transmission of the PCF. If the transmission falls below 50%, replace the PCF.

NOTE: Throughout operation of the SLAM microscope (in the steps that follow), it is recommended to measure the output power of the PCF every hour to ensure consistent data.

4.5. Move the power meter after the neutral density (ND) filter and rotate the filter to control the laser power that reaches the sample. 

[bookmark: _Hlk199385864][bookmark: _Hlk199385947]NOTE: Multiply the measured power by the transmittance of the remaining optical components. The transmittance is measured by placing the power meter after the objective lens. For this study, an average laser power of 20 mW at the sample was used. The laser power was determined empirically for the given sample, imaging depth, and microscope system to generate high-quality images while avoiding sample damage or detector nonlinearity. While there is no definitive standard, typical label-free multiphoton imaging is limited to several tens to hundreds of milliwatts 7,32,33,51,52.

4.6. Turn on the galvanometers and stage. Open the acquisition software and enter the desired parameters for imaging.

NOTE: This study used 512 × 512 pixels and a pixel dwell time of 13.65 µs to image a 360 × 360 µm field of view. Five frames taken at 0.333 Hz were averaged into a single high-quality frame.

4.7. Place the sample on the stage using the appropriate immersion media for the objective as was used before in step 2.5.

4.8. Turn off the room lights and close curtains.
 
NOTE: To avoid damaging detectors, never turn on room lights while detectors are on, or detector shutters are open.

4.9. Turn on the detector power supplies and amplifiers.

4.10. Shut the light box surrounding the stage.

4.11. Use the electronic control switches to manually open the detector shutters (S3, S4, S5, S6).

4.12. In the microscope acquisition software, click Click to Start Acquisition to begin collecting SLAM images. Adjust the focus of the microscope by rotating the knob on the microscope stage controller (Table of Materials) until the sample comes into focus.

NOTE: The glass coverslip generates a strong THG signal, which can be used to accurately determine the depth of imaging using the stage position displayed on the microscope stage controller. For example, all images of solution standards taken in this study were taken at a focal plane 20 µm above the coverslip.

4.13. Use the joystick on the microscope stage controller to locate the desired field of view in the sample, then click Stop and Reset.

NOTE: If the image saturates, return to step 4.5, and lower the power. If the image has a signal to noise ratio below 10, the power may instead be carefully increased.

4.14. Under the Saving tab, click Save Data to toggle it to Yes, then click Click to Start Acquisition. Wait until the acquisition finishes before continuing.

4.15. To change or manipulate the sample during imaging, close the detector shutters and use a flashlight or headlamp for light. Once the sample is modified, return to step 4.10.

NOTE: To enable repeatability and quantitative analysis, collect SLAM images of FAD and NADH solution standards. Ensure that the field of view, image size and excitation power is consistent with what was used for the biological samples.

4.16. To end SLAM image acquisition, close the detector shutters, and turn off the detectors before turning on the room lights.

4.17. Block the laser using shutter 1, then turn off the laser.

4.18. Turn off the galvanometers and stage. Close the microscope acquisition software.

4.19. Dispose of the tissue appropriately and clean the workplace.

5. Data visualization

NOTE: The following image analysis may occur in an image analysis software such as ImageJ53 (Table of Materials) or a programming language with image analysis capabilities, such as Python or MATLAB. The following steps describe how to perform data visualization using ImageJ.

5.1. Ensure that the images from each channel are in a lossless image format (e.g., TIFF or PNG). 

NOTE: The custom microscope control software used in this study automatically saved images as TIFFs. To save an image as a TIFF, open it in ImageJ and select File > Save As > Tiff.

5.2. [bookmark: _Hlk199392904] To generate illumination standard images, open the FAD and NAD(P)H channel images of FAD and NADH solutions, respectively, into ImageJ. For each image, select Process > Filters > Gaussian Blur…, set Sigma (Radius) to 41, then click OK.

NOTE: Adjust the Sigma (Radius) of the Gaussian filter as needed to sufficiently smooth the image.

5.3. To simultaneously correct uneven illumination and normalize the fluorescence intensity, open the FAD and NAD(P)H channel images of the sample. For each image, select Process > Image Calculator…, for Image1 select the sample image, for Operation select Divide, and for Image2 select the illumination standard image that corresponds with the sample image’s channel, then click OK. 

NOTE: This step is critical for correcting system variability and maintaining consistency in quantitative evaluations of autofluorescence, such as the optical redox ratio (ORR).

5.4. If multiple images are taken to form a larger field of view or z-stack, stitch or combine the images together into single image or stack of images.

5.5. To generate an ORR image, first sum the FAD and NAD(P)H images. Select Process > Image Calculator…, for Image1 and Image2, select the FAD and NAD(P)H channel images respectively, for Operation select Add, then click OK. To compute the ORR image, select Process > Image Calculator…, for Image1 select the FAD channel image, for Operation select Divide, and for Image2 select the result of the sum of FAD and NAD(P)H, then click OK.

5.6. To apply a colormap to the ORR image, select Image > Color > Edit LUT…, click Open, select the desired look-up-table (.lut) file and click OK. Select Image > Adjust > Brightness/Contrast and adjust the contrast as desired. 

NOTE: It is recommended to use an isoluminant colormap such as the (inverted) CET-I254,55 colormap used in this study. To invert a colormap in ImageJ after applying it to an image, select Image > Color > Invert LUTs.

5.7. To improve the clarity of the features in the ORR image, scale the brightness by the intensity of the fluorescence channels. First, select the result of the sum of FAD and NAD(P)H and select Process > Enhance Contrast…, make sure Normalize is checked, then click OK. Select Edit > Copy to copy this result to the clipboard. Next, select the ORR image and select Image > Type > RGB Color”, then select Image > Type > HSB (32-bit). Move the slider at the bottom of the image all the way to the right to view the Brightness channel, select Edit > Paste, then select Image > Type > RGB Color. 

5.8. To visualize the SLAM image as a composite, open the four SLAM channels in ImageJ and select: Image > Color > Merge Channels… For C2 (green), select the SHG channel image, for C5 (cyan) select the NAD(P)H channel image, for C6 (magenta) select the THG channel image, and for C7 (yellow) select the FAD channel image. Make sure Create composite is checked and click OK.

REPRESENTATIVE RESULTS
The complex multichannel, multimodal approach of the SLAM microscope (Figure 1) can make it difficult for new users to troubleshoot issues and understand results. First, a well-cleaved PCF features a clean face (Figure 2C) with a flat surface that is perpendicular to the PCF’s length (Figure 2A). An angled, chipped cleave face (Figure 2B) and the presence of scratches (Figure 2E) indicate a poor cleave. Dirt or debris on the surface of the PCF shown in Figure 2D indicates a poor cleave or improper handling of the PCF after cleaving. Most importantly, the core of the PCF, which is the small central area surrounded by the honeycomb pattern of air holes, should be free from debris or scratches in a successful cleave. That said, it is normal to observe small scratches and a few debris, particularly on the outer cladding of the PCF (Figure 2C), and these PCFs are most likely still usable. Over the lifespan of the PCF, it will incur damage, the coupling efficiency will drop, and the PCF will need to be replaced. Improper pumping of the PCF or airborne particles settling on the ends of the PCF may accelerate this process. Such a damaged PCF will have a dark spot burned onto its core (Figure 2F).
 
[bookmark: _Hlk199401903]Careful placement and precise alignment of the PCF are critical for the generation of the supercontinuum. The width and power spectrum of the supercontinuum depend on various factors, including alignment, input power, repetition rate, PCF core size, and PCF length. An example of the supercontinuum used in this protocol is provided in Figure 3A. Pulse compression by adjustment of the spectral phase profile of the pulse shaper can easily result in compressed pulses with high peak power, as shown in Figure 3B. When correctly aligned and compressed, the autocorrelation of the pulse should be symmetrical and have a width of a few tens of fs (Figure 3B). Stability in the supercontinuum power and spectral shape is important for reliable pulse compression and ultimately nonlinear signal generation in the sample. Therefore, to ensure consistent results and optimal performance of the SLAM microscope, 8 h measurements of the optical power (Figure 3C) and spectrum (Figure 3D) of the supercontinuum were conducted. The results demonstrated high stability of the supercontinuum over a time much longer than the duration of imaging in this study. If this level of stability is not observed, this likely indicates an unstable pump laser or unstable coupling into the PCF.

[bookmark: _Hlk199092521]The spectral profile of the supercontinuum and the pulse compression achieved have a strong impact on the quality of SLAM images. Figure 4A shows the SHG and THG signals generated from a properly functioning SLAM source. A narrowed supercontinuum limits the degree of possible pulse compression and shrinks parts of the spectrum important for generating one or more of the SLAM modalities. Notably, even with the use of an ultraviolet transmissive objective lens, the longer wavelengths in the supercontinuum are needed to generate THG signals that are not strongly attenuated. For this reason, a characteristic effect of a narrowed supercontinuum is the loss of THG signal intensity (Figure 4B). This effect is a common symptom of neglecting to replace an old PCF that has low coupling efficiency and spectral broadening. Issues with pulse shaping, on the other hand, are typically much more profound. If the pulse shaper is not operating properly, the pulses will not be well compressed, and all the nonlinear signals of SLAM will be diminished (Figure 4C). 

[bookmark: _Hlk199393183]Collecting successful SLAM microscopy data requires careful preparation of the biological specimen and use of appropriate microscopy hardware and settings for the chosen sample type. Figure 5A and Figure 5C contain examples of successful SLAM images of ex vivo mouse kidney. Because the high NA objective used has high magnification, multiple adjacent 360 × 360 µm fields of view were taken over the course of 12.5 min and stitched into a single image. The presence of strong magenta THG and cyan NAD(P)H signals in the composite SLAM image indicates effective pulse compression enabling efficient three-photon processes. Nephron structures are also visible in the SLAM image. SHG shows up in the renal interstitium, indicating the presence of some collagen fibers. In the computed ORR image shown in Figures 5B and Figure 5D, one observes a higher redox ratio in the proximal tubules of the renal cortex compared to the medulla. This observation aligns with the high oxidative phosphorylation occurring in the proximal tubules and the lower oxygen levels and glycolytic metabolism in the medulla56 and is further supported by recent work in optical label-free imaging of kidney tissue52. Analysis methods like ORR capitalize on the unique spatial and temporal overlap of the four channels, play a crucial role in realizing the full potential of SLAM microscopy.

FIGURE AND TABLE LEGENDS
Figure 1: The optical design of a simultaneous label-free autofluorescence multiharmonic (SLAM) microscope. The femtosecond laser outputs 1040 nm light in 370 fs pulses at a repetition rate of 10 MHz. Intensity and polarization of the laser are carefully controlled before pumping a photonic crystal to generate a supercontinuum. The pulses are then compressed in by a pulse shaper and directed into a customized laser scanning microscope (dashed box). Dichroic mirrors and bandpass filters isolate the nonlinear signals generated by the sample before they are detected by high-sensitivity photon detectors such as photomultiplier tubes (PMTs) or hybrid photodetectors (HPDs). Optical design is based on the system described in41.

Figure 2: Cleaved ends of the photonic crystal fiber (PCF). (A, B) Images of the side of the cleave. (C-F) Images of the face of the cleave. (A) A well-cleaved PCF has a flat and perpendicular face. (B) A poorly cleaved PCF with an angled and chipped face. (C) A well-cleaved PCF with a clean face. (D) A mishandled PCF that has dirt on its surface. (E) A poorly cleaved PCF with scratches on its surface. (F) An old PCF that was replaced. There is visible damage to the core of the PCF as seen by the dark spot in the center of the PCF.

[bookmark: _Hlk199401951]Figure 3: Supercontinuum generation and pulse shaping. (A) The power spectrum of the supercontinuum generated by the PCF was measured by an optical spectrum analyzer. (B) Autocorrelation of the pulse after compression by the pulse shaper. A Gaussian fit of the autocorrelation indicates an approximate pulse width of 26 fs. (C) The power output of the PCF measured was relatively stable over 8 h. (D) Spectrogram of the supercontinuum shows a stable spectral profile over 8 h.

Figure 4: A single field of view of a freshly excised mouse lung imaged with different degrees of spectral broadening and pulse shaping. For clarity, the images only show SHG and THG channels, which are two and three-photon processes, respectively. Each image was taken with equivalent average power on the sample. (A) Image generated with the original SLAM source. (B) Image generated with a narrowed supercontinuum. Loss of broadening was achieved by pumping the PCF at half the original power. (C) Image generated with an uncompressed supercontinuum. The pulse shaper’s polynomial coefficients (orders of dispersion) were set to zero.

Figure 5: Representative SLAM and ORR images of a freshly excised mouse kidney. Multiple 360 x 360 µm fields of view were stitched together to generate a larger field of view. (A, B) Sagittal cross-section highlights the long loops of Henle of juxtamedullary nephrons. (C, D) Transverse cross section highlights the proximal tubules. (A, C) SLAM composite images magenta: THG, cyan: 3PAF (NAD(P)H), green: SHG, yellow: 2PAF (FAD). THG shows the boundaries in refractive index and SHG identifies regions of interstitial collagen. NAD(P)H and FAD autofluorescence signals arise from the metabolic cofactors in intracellular spaces. (B, D) Optical redox ratio (ORR) images are computed from the two autofluorescence channels to produce a new contrast that displays the relative redox and metabolic state of the cells. Low ORR is associated with a reduced environment and glycolysis, while high ORR is typical of an oxidized environment and oxidative phosphorylation.

DISCUSSION
[bookmark: _Hlk199352944]Generating a suitable supercontinuum is crucial for successful SLAM imaging, but it can be challenging due to the complexity of setting up the PCF. Ensuring precise cleaving and careful handling of the PCF is essential to maintain clean surfaces free from debris, dirt, or scratches, all of which can interfere with effective coupling, supercontinuum generation, and even shorten the lifespan of the PCF. Since the PCF requires regular replacement, practicing fiber cleaving and fine-tuning cleaver settings can help achieve optimal cleaves. Additionally, precise alignment of the PCF and periodic realignment before each use are critical to ensure the desired supercontinuum is generated. Misalignment can also damage the PCF. Since the supercontinuum generation by the PCF is a critical aspect of SLAM microscopy, the choice of PCF core size and length is an important consideration. A longer PCF can produce a broader supercontinuum; however, it may reduce output power, increase dispersion, complicate installation, and increase the cost of replacement. Smaller core size PCFs can also generate a broader supercontinuum but tend to have a shorter lifespan and lower damage threshold compared to larger core diameters57. One limitation of the described SLAM microscopy method is the variable quality of PCFs, their sensitivity to alignment, and performance degradation over time. Moreover, the cost and time associated with replacing the PCF are significant factors. As a result, alternative supercontinuum sources are being explored for SLAM microscopy40.

Compression of the supercontinuum is vital for generating short pulses and high peak powers in the SLAM microscope, enabling efficient nonlinear signal generation while keeping average power low to preserve sensitive biological samples. Proper alignment of both the beam to the pulse shaper and the pulse shaper itself is crucial to maintain control over the entire spectrum. If the pulse shaper uses a liquid crystal modulator, it is also necessary to align the polarization of the input light with the polarization axis of the modulator for effective pulse compression. Alternatively, for simpler and lower cost implementation, a typical prism or grating-based pulse compressor may be used in place of a programmable pulse shaper. On the other hand, adaptive phase compensation methods such as multiphoton intrapulse interference phase scan (MIIPS)58 may be used to achieve optimal pulse compression. In existing SLAM microscopes, the edges of the supercontinuum are typically clipped before pulse shaping to select an optimal bandwidth for the excitation and detection of endogenous nonlinear signals. For instance, shorter wavelengths are often clipped because standard glass optics and objective lenses absorb THG signals generated in the ultraviolet.

While the main focus of SLAM microscopy is the generation of nonlinear signals, proper detection is just as important. Optical filters and photomultipliers should be carefully chosen to optimally measure each distinct channel. Still, due to overlapping spectra and the broadband excitation and simultaneous detection used in SLAM, there is significant crosstalk between channels and contribution from autofluorophores other than FAD and NAD(P)H, such as lipofuscins, and elastin59. To address these challenges, linear unmixing based on reference samples and fluorescence lifetime imaging microscopy (FLIM) have been applied to SLAM41,42. FLIM allows for quantitative molecular characterization of fluorophores, making it a powerful addition to SLAM. For simplicity, the use of FLIM with SLAM was omitted from this work; a detailed protocol for collecting and analyzing FLIM of FAD and NAD(P)H has been previously published60.

[bookmark: _Hlk199399777]Another important consideration in SLAM microscopy is the polarization state of the excitation beam and detected light. This is of particular importance for the coherent processes SHG and THG, where the intensity is highly dependent on the polarization of light with respect to structural and molecular orientation in the sample. Additionally, the fluorescence anisotropy of FAD and NAD(P)H depends on the polarization of the excitation light and the rotational mobility of the molecules. In the described SLAM configuration, the incident light is linearly polarized and fixed to the axis of the pulse shaper. The tight focusing of the high-NA objective lens distorts the polarization state, and the detectors are not polarization-sensitive. These limitations, however, present an opportunity: the incorporation of polarization control of the incident beam (e.g., with a half-wave plate), polarization-sensitive detection, and polarization-preserving optics could improve consistency and enable polarization-resolved harmonic generation to investigate tissue organization61 and allow fluorescence anisotropy measurements to probe the molecular environment62.

To measure relevant biology using SLAM microscopy, it is vital to ensure that the highest possible viability of the sample is maintained. In the case of ex vivo imaging demonstrated in this study, The type of media required to preserve cell functions should be tested and selected empirically, as different tissues and cell types may require distinct conditions for optimal preservation. Factors such as temperature, pH, nutrient composition, and oxygen availability should be carefully adjusted to maintain cellular integrity and function for the desired duration63. The viability of freshly excised tissue slices in each type of media at given data time points may be evaluated in parallel or a priori by applying a variety of staining techniques64. Importantly, however, the use of additives such as phenol red that significantly generate or reduce signal in any of the SLAM channels should be strictly avoided during SLAM imaging.

Overall, SLAM microscopy represents a significant advancement in intravital microscopy. Unlike conventional methods, which rely on sequential imaging or the use of exogenous labels, SLAM microscopy enables simultaneous collection of multiple label-free channels in living tissues4,22,38–41. While the individual four label-free modalities of SLAM are widely used, the simultaneous approach offers not only faster acquisition but also unique spatial and temporal registration of each channel. The current and future application of SLAM microscopy spans several research areas, including cancer research22,38,39 and biopharmaceutical development42. In cancer research, SLAM microscopy facilitates near real-time visualization of tumor microenvironment and characterization of individual extracellular vesicles, obtained from tissues or biofluids, for cancer diagnosis and/or progression22,65. Its ability to quickly provide highly detailed biological information on a cellular level without exogenous labels makes it especially valuable for clinical applications such as digital histopathology5,21 and intraoperative imaging6.
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