

[bookmark: _26in1rg]		
[bookmark: gjdgxs]TITLE: 
A Label-Free Segmentation Approach for Intravital Imaging of Mammary Tumor Microenvironment
[bookmark: 30j0zll]
AUTHORS AND AFFILIATIONS:
Brian M. Burkel1, David R. Inman1, María Virumbrales-Muñoz1,2, Erica J. Hoffmann1, Suzanne M. Ponik1,3

Email addresses of co-authors:
Brian M. Burkel 		(bmburkel@wisc.edu)
David R. Inman 		(drinman@wisc.edu)
María Virumbrales-Muñoz 	(virumbralesm@wisc.edu)
Erica J. Hoffmann 		(ejhoffmann@wisc.edu)
Suzanne M. Ponik 		(ponik@wisc.edu)

Corresponding author:
Suzanne M. Ponik 		(ponik@wisc.edu)

[bookmark: kix.dnstqay1kwjl]SUMMARY: 
The intravital imaging method described here utilizes collagen second harmonic generation and endogenous fluorescence from the metabolic co-factor NAD(P)H to non-invasively segment an unlabeled tumor microenvironment into tumor, stromal, and vascular compartments for in-depth analysis of 4D intravital images.

[bookmark: 3znysh7]ABSTRACT: 
The ability to visualize complex and dynamic physiological interactions between numerous cell types and the extracellular matrix (ECM) within a live tumor microenvironment is an important step toward understanding mechanisms that regulate tumor progression. While this can be accomplished through current intravital imaging techniques, it remains challenging due to the heterogeneous nature of tissues and the need for spatial context within the experimental observation. To this end, we have developed an intravital imaging workflow that pairs collagen second harmonic generation imaging, endogenous fluorescence from the metabolic co-factor NAD(P)H, and fluorescence lifetime imaging microscopy (FLIM) as a means to non-invasively compartmentalize the tumor microenvironment into basic domains of the tumor nest, the surrounding stroma or ECM, and the vasculature. This non-invasive protocol details the step-by-step process ranging from the acquisition of time-lapse images of mammary tumor models to post-processing analysis and image segmentation. The primary advantage of this workflow is that it exploits metabolic signatures to contextualize the dynamically changing live tumor microenvironment without the use of exogenous fluorescent labels, making it advantageous for human patient-derived xenograft (PDX) models and future clinical use where extrinsic fluorophores are not readily applicable.

[bookmark: 2et92p0]INTRODUCTION: 
[bookmark: _Hlk91501861]The extracellular matrix (ECM) in the tumor microenvironment is known to be dynamically deposited and remodeled by multiple cell types to further facilitate disease progression1–3. These matrix alterations provide both mechanical and biological cues that alter cell behavior and often result in a continuing cycle of matrix remodeling4. Investigation into the dynamic, reciprocal interplay between tumor cells and the extracellular matrix is often conducted using three-dimensional (3D) in vitro culture or microfluidic systems. While these bottom-up approaches have demonstrated mechanisms of ECM remodeling5–7, increased proliferation8, epithelial to mesenchymal transition9–12, and tumor cell migration and invasion7, 13–16, their focus has been primarily on a few cell types (e.g., tumor cells or fibroblasts) within a homogeneous 3D matrix compared to the diversity and heterogeneity of interactions present within a physiological tissue. In addition to in vitro systems, ex vivo tumor histology can also provide some insight into these cell-cell and cell-ECM interactions17.  Immunohistochemistry has the advantage of being able to analyze multiple cell types with respect to the spatially heterogeneous composition and architecture of the ECM, but the static endpoints of fixed tissue do not capture the dynamic nature of interactions between cells and the microenvironment. 

The use of intravital imaging has opened the door to interrogate live interactions within the spatial and temporal context of the native tumor microenvironment, and the capabilities of intravital tumor imaging are advancing rapidly. Improvements in the design of imaging windows and surgical techniques to implant the windows have enabled long-term longitudinal tumor imaging at a variety of anatomical locations i.e., primary tumor, lymph nodes, metastatic sites18–20. Moreover, the capacity of optical instrumentation to visualize and collect data in multiple dimensions (i.e., spectral, spatial fluorescence intensity), and lifetime and at high resolution and speed (video rate) is becoming widely accessible. The improved technology provides an opportunity to explore rapid changes in cell signaling and phenotypic dynamics within a physiological environment. Lastly, the expansion of optogenetic tools and the wide array of genetic fluorescent constructs allow for the tagging of specific cell types to capture cell migration in the tumor microenvironment or cell lineage tracing during development or disease progression21, 22. The use of these tools in combination with CRISPR/Cas9 technology provides researchers the opportunity to generate unique animal models in a timely manner. 

[bookmark: _Hlk91501746]While all these advances make intravital imaging an increasingly powerful method to explore dynamic and physiological cellular interactions, there is still an important need to develop strategies that provide spatial, temporal, and structural context at the tissue level to these biological interactions.  Currently, many intravital imaging studies compensate for the lack of visual landmarks such as blood vessels by injecting fluorescent dyes into the vasculature or employing mouse models that exogenously express fluorescent proteins to delineate physical features. Injectable dyes and substrates like fluorescent dextrans are broadly utilized to successfully label the vasculature in intravital collections19, 23, 24. However, this approach is not without limitations. For one, it requires additional mouse manipulations and its utility is limited to short-term experiments. For longitudinal studies, fluorescent dextran can be problematic as we observe the accumulation of dextran in phagocytic cells or diffusion into the surrounding tissue over time25. Exogenous fluorescent protein incorporation into the mouse model has been presented as an alternative to fluorescent dextrans but presents limitations of its own. The availability and diversity of exogenous fluorophores within mouse models are still limited and expensive to create. Additionally, in specific models, such as PDX models, genetic manipulations are not desirable or possible.  It has also been shown that the presence of fluorescent or bioluminescent proteins within cells are recognized as foreign within the mouse, and within immunocompetent mouse models, this reduces the amount of metastasis due to the response of the host immune system26, 27. Lastly, exogenous fluorescent proteins or fluorescent dyes used for spatial context or to segment subsequent data often occupy prime ranges of the light spectrum that could otherwise be used to investigate the physiological interactions of interest.

The use of the intrinsic signal from the ECM or endogenous fluorescence from cells within the tissue can not only be a useful tool to characterize cell behavior or specific physiological structures but also a universal means to segment the data for more in-depth cellular and spatial analysis. Second harmonic generation (SHG) has long been used to visualize the ECM28. With the subsequent development of important tools to aid in the characterization of fiber organization29–31, it is possible to characterize cell behavior relative to local ECM structure. In addition, autofluorescence from the endogenous metabolite, NAD(P)H, provides another label-free tool to compartmentalize the tumor microenvironment in vivo. NAD(P)H fluoresces brightly in tumor cells and can be used to discriminate the boundaries of the growing tumor nest from its surrounding stroma21, 32. Lastly, the vasculature is an important physiological structure in the tumor microenvironment and the site of key cell-type-specific  interactions33–35. The excitation of red blood cells (RBC) or blood plasma has been used to visualize the tumor vasculature, and using two- or three-photon excitation (2P; 3P) the measurement of blood flow rates has been shown to be possible36. However, while larger blood vessels are easily identifiable by their endogenous fluorescence signatures, the identification of subtle, variable, and less fluorescent small blood vessels requires more expertise. These inherent difficulties hinder optimal image segmentation. Fortunately, these sources of endogenous fluorescence (i.e., red blood cells and blood plasma) can also be measured by fluorescence lifetime imaging37, which capitalizes on the unique photophysical properties of the vasculature and represents a useful addition to the growing intravital toolbox. 
	
In this protocol, a workflow for the investigation of four-dimensional (4D) intravital imaging, from acquisition to analysis, explicitly using intrinsic signals like endogenous fluorescence and SHG is described. This protocol is specifically written for longitudinal studies through a mammary imaging window where exogenous fluorescence may not be practical or possible, as is the case with PDX models. The segmentation principles outlined here, however, are broadly applicable to intravital users investigating tumor biology, tissue development, or even normal tissue physiology. The reported suite of analysis approaches will allow the users to differentiate cellular behavior between regions of aligned or random collagen fiber configurations, compare numbers or behaviors of cells residing in specific regions of the tumor microenvironment, and map the vasculature to the tumor microenvironment using only label-free or intrinsic signal. Together, these methods create an operational framework for maximizing the depth of information gained from 4D intravital imaging of the mammary gland while minimizing the need for additional exogenous labels.


[bookmark: tyjcwt]PROTOCOL: 

All experiments described were approved by the University of Wisconsin-Madison’s Institutional Animal Care and Use Committee. The well-being and pain management in all animal experiments is paramount. Thus, every effort is made to make sure the animal is comfortable and well-cared for at each step of the procedure.

1. Generation of the mammary imaging window (MIW)

1.1 To construct the mammary imaging window, fabricate a 14 mm ring from surgical grade stainless steel. 

1.2 Clean the machined window frame using a hot solution of 5% cleaning detergent, rinse for 10 min under running deionized water (DI) water, soak in 100% ethanol for 10 min, and then dry under a heat lamp. Autoclave the dried MIW frame and store it for later use. 

1.3 Prepare MIW cover glass as follows. Soak the #1.5 12 mm round cover glass in 100% ethanol for 10 min, dry under a heat lamp, and then secure to the metal MIW frame using cyanoacrylate adhesive. Cure the adhesive overnight. 

1.4 Clean the assembled MIW of excess adhesive using an acetone soaked swab, and disinfect by submerging it in 70% ethanol for at least 1 min. Allow the cleaned window to dry. Prepare the MIW in advance and store it in a sterile Petri dish prior to surgical implantation. 

2. Surgical implantation of the MIW

2.1 Autoclave surgical tools and sanitize surfaces with 70% ethanol before beginning the surgery for the window implantation.

2.2 Perform surgery on a sanitized tabletop using a warming blanket covered with a sterile field. Set the warming blanket such that the temperature measured on top of the sterile field is 40 °C.  

2.3 Use auxiliary cold lighting to help prevent tissue drying. Use magnifying glasses to facilitate the surgical procedure. Wear PPE consisting of a sterile, single-use lab coat, surgical sleeves, gloves, eye protection, and face mask as recommended by the surgical best practices.

2.4 Anesthetize the mouse using an anesthesia  vaporizer machine with an isoflurane setting of 2.0% and flow rate of 2.0 L/min. Administer analgesic (10 mg/kg meloxicam) by subcutaneous injection. 

NOTE: Provide additional doses within the first 24 h, preferably every 8–12 h for the first 2 days after surgery.

2.5  Once anesthetized (confirmed by no response to toe-pinch), apply a moisturizing eye gel to prevent drying of the eyes. Use a depilatory cream to remove fur at the surgery site (4th inguinal mammary gland) followed by rinsing with sterile water-soaked gauze. 

2.6 Prepare the depilated surgical site for surgery by sanitizing the skin surface with 3 alternating betadine and ethanol scrubs. 

2.7 To begin the surgery, gently lift the skin over mammary gland number 4 using forceps. Once the skin is pulled away from the body wall, remove a ~1 mm section of the dermal layer at the tip of the forceps with surgical micro-scissors. If bleeding occurs, apply gentle pressure with sterile gauze until the bleeding stops.

NOTE: In general, larger tumors have a greater potential to bleed than smaller tumors or normal tissues.

2.8 Detach the mammary gland from the dermal layer with gentle forceps movements at the surgical opening to avoid cutting which will remove more of the dermal. 

2.9 Create a 10 mm incision and release the mammary gland from the dermal layer at the periphery so that sutures can be placed without penetrating the mammary gland. Add PBS to cover the exposed gland/tumor and to prevent drying. 

2.10 Create a purse-string suture along the periphery of the opening using 5-0 silk braided suture. Insert an edge of the MIW so that the dermal layer engages into the receiving notch of the MIW. 

2.11 Gently stretch the epithelium at the opposite side of the MIW and push the metal MIW into place such that the dermal layer fully engages the receiving notch around the entire MIW circumference. Cinch the purse string tight to draw the dermal layer into the notch and tie it off to fully secure the window. 

2.12 Add a topical antibiotic to the dermal layer at the MIW, and continuously monitor the mouse until it has regained sufficient consciousness to maintain sternal recumbency. House the MIW-implanted mice separately on soft bedding with an igloo placed in the cage, and allow the mouse to recover for 48 h before imaging.

3. Positioning and maintaining mouse on the microscope stage for imaging 

3.1	Set up the heating chamber on the microscope stage.  Use a forced-air system set to 30 °C or any other similar system. Use an additional objective heater to avoid drift in z focus. Allow the system to come to equilibrium for at least 1 h before imaging.

NOTE: Anesthetized mice are incapable of properly maintaining their body temperature, and therefore, it is necessary to have a heated environment for any time-lapse acquisitions. The objective heater helps to combat the effects of thermal expansion, a phenomenon that causes drift in z focus as the objective lens and the tissue being imaged come to thermal equilibrium.

3.2	Once the heating chamber on the microscope has stabilized at 30 °C, anesthetize the recipient mouse with anesthesia machine settings of 2% isoflurane and oxygen flow rate of 2 L/min. Reduce the isoflurane levels to about 1% once the mouse has been anesthetized.

3.3	After the mouse is sedated (confirmed by no-response to toe pinch), clean the outside of the MIW glass with a cotton applicator and glass cleaner, add eye ointment to prevent drying, and insert a tail vein catheter if necessary.

3.4	To maintain proper hydration, give an initial injection of 0.5 mL PBS sub-cutaneously or 100 µL through the tail vein catheter. Repeat every 2 h for the duration of the imaging session.
 
3.5 Once the mouse has been properly prepared, gently transfer it to the pre-warmed microscope stage. 

3.6  Lay the mouse on the microscope stage, fit the isoflurane hose and press the collar of the MIW into a 14 mm receiving hole in the stage insert to stabilize the images. Bring the imaging field into focus using the microscope oculars and bright field illumination observing vasculature with blood flow. 

3.7 Check the stability of the field of view. If breathing movement artifacts are present, apply gentle compression to the backside of the gland with a small foam block and a cincture-like piece of adhesive tape. After compression is applied, verify that blood flow is maintained throughout the field of view.

3.8 Periodically adjust the isoflurane levels in 0.25% increments during the imaging session to maintain a proper level of sedation by manually counting animal respiration. 

3.9 Maintain a rate of 36–40 respirations per min (rpm) to improve animal longevity and optical imaging. Lower respiration rates can result in the mouse not surviving the experiment, whereas respiration rates over 60 rpm may result in poor sedation, which can increase breathing and motion artifacts in the image data.

4. Set up for 4D, intensity-based, label-free intravital imaging of dynamic cell behavior

4.1 Once the mouse is sedated and securely positioned on the inverted microscope stage, start locating regions of interest. For time-lapse measurements, use a water-based gel instead of water for the objective to reduce evaporation that can lengthen the imaging session. Please see the Table of Materials for details of the optical components.

4.2 Using a light source directed at the MIW, use the oculars of the microscope to identify potential areas for investigation. Add and save the x, y positions in the software to return to these positions. 

NOTE: The fine details of the tumor will not be readily visible with this type of illumination. The goal is simply to identify regions for further investigation. The focus is on seeing vasculature and blood flow.

4.3 After several positions have been saved in the software, preview the chosen fields of view using 890 nm excitation and the FAD/SHG filter cube. Use a maximum dwell time of 4 µs with lower power and high PMT setting. The goal is to preview the fields of view without overexposing the tissue to excessive laser light.

4.4 Once appropriate power levels have been set, set up the z-stacks. Observe appearance of abundant collagen fibers (SHG) at 20–50 µm beneath the glass surface of the MIW. Collagen will become less prevalent as the microscope sections deeper into the tumor  (Figure 1B). Voids in the SHG reveal the location of tumor masses. 

4.5 Set the top z-slice, beneath the layer of solitary cells where the first collagen fibers appear at ~50–100 µm. Set the bottom z-slice at ~250 µm, where the fibers fade out and the poor signal dominates. Repeat this for all x-y positions saved.
 
4.6 Once the z-stack range is set, increase the dwell time (up to 8 µs) and optimize the power and detector settings. Optimize the power levels needed to excite the tissue for each experiment. Using powers up to 90 mW at 750 nm or 70 mW at 890 nm at the back aperture of the objective are within an acceptable range. 

NOTE: The imaging depth, amount of scattering within the tissue, objective characteristics, and detector sensitivity will all significantly impact the amount of power needed to get an image. 

4.7 Adjust the time intervals according to experimental goals. Start with 10 min intervals between collection points for most intravital migration movies. 

4.8 Even though 2P excitation is gentle on cells and tissues, be cognizant of signs of phototoxicity, like cell blebbing or rapidly increasing autofluorescence, and excessive photobleaching. Reduce laser power or increase timelapse intervals as conditions indicate. 

5. Fluorescence lifetime imaging (FLIM) of NAD(P)H 

5.1 While preserving the x-y positions from the timelapse acquisitions, set up the microscope to collect a FLIM stack. Insert a 440/80 filter into a filter holder in front of the GaAsP detector, and set the GaAsP detector voltage to 800 in the software.  Turn off the room lights when the detectors are on. 

5.2 In the software, switch from the galvanometer-based intensity imaging to a FLIM imaging mode. 

5.3 For the purpose of identifying and masking the vasculature, set the resolution to 512 x 512 pixels. For collecting complementary metabolic information, set the resolution to 256 x 256 pixels to increase the temporal resolution of the lifetime signature. Set the dwell time to 4 µs and tune the laser to 750 nm. 

5.4 Start preview scanning and begin to adjust the laser power. Adjust the laser power until the readout for the constant fraction discriminator (CFD) is between 1 x 105 and 1 x 106. Do not exceed 1 x 106 as this will result in photon pileup and poor overall results.
 
5.5 Once the power level is set, set the integration time between 90 s and 120 s and start the FLIM collection. It will acquire photons from the field of view for the allotted time. 

5.6	Optional: After all necessary collections have been made and the mouse has been removed from the stage, collect an instrument response function (IRF). Measure the IRF by imaging the surface of commercially available urea crystals in a glass-bottom dish with the same parameters and set up used for imaging the tissue.

NOTE: The IRF accounts for any delays or reflections due to the electronic or optical setup. The IRF is convolved in all FLIM acquisitions, and deconvolving it from the data can improve the accuracy of calculated fluorescence decay curves. With that said, the calculated IRFs can often reasonably replicate the quality of the fluorescence decay curves from measured IRF. It is good practice to measure the IRF until it has been determined that the calculated IRF will yield equivalent fits of the decay curves and adequately approximate the results from the measured IRF. 

6.	Analysis of NADH Lifetime images

6.1 Open FLIM software and import the NAD(P)H lifetime image from the dataset. For more details on how to properly use the software, please consult the fluorescent lifetime handbooks (See Table of Materials). 

6.2 To begin, define the model parameters in the software. In the menu bar, click   Options > Model. Select the following boxes: Settings > Multi-Exponential Decay, Fit Method > MLE, Spatial Binning > Square, Threshold > Peak, and check Fix Shift Before Calculating Image.

6.3 In the menu bar, click Color >  A1% from the drop-down menu. On the right side of the window, define it as a three-component fit. Set the Bin Size > 3.

6.4 Adjust the Threshold > ~10. Re-evaluate threshold accuracy after the decay matrix has been calculated for the first time.

6.5	Fix the τ1 to 200 ps. This represents the short lifetime of red blood cells. Try to find the value that best matches multiple spots in the larger blood vessel, which can be seen in the intensity image. Fix the τ2 to 1200 ps. This represents the long lifetime of red blood cells. 

NOTE: The set values are just the starting point. The values will need to be optimized to bring out the vasculature more. In most cases, but not always, these values will decrease. 

6.6 Under Calculate in the menu bar, select Decay Matrix. This will generate an initial A1% lifetime images with the vasculature having high values. Use the cursor (crosshairs) to hover over the vasculature. Systematically and one at a time, float (uncheck the Fix box) the τ1 and τ2. Record these values as they will help optimize the fixed parameters. 

NOTE: The goal is not necessarily to get the most accurate values in the image, but rather to maximize the disparity between the vasculature and tissue without dramatically decreasing the area identified as vasculature.

6.7 Once the appropriate parameters for τ1 and τ2 have been identified, in the menu bar select Calculate > Batch Processing. Ensure that most settings are similar between z-slices. 

6.8 Make sure to verify that there is no one setting grossly different than the others. If so, adjust the shift first and try again. If the issue persists, refit using new parameters. An incorrect shift can be a large cause of noise in the fits and can increase A1% values in the adjacent tumor regions.

6.9 In the menu tab, save the files and then export A1% files. Upload these files in ImageJ for masking and segmentation.

7.	Image segmentation of the vasculature 

7.1 Open ImageJ and import the A1% image as a text image. Repeat this for all images within the stack.

7.2 With all the A1% images opened, select Image > Stack > Z-Project. Use the  Max Intensity Projection and save the images. See Supplemental Data 1 for a representative image.

7.3 Go to Plugins > Segmentation. Select the trainable WEKA segmentation plugin38.

7.4 Once the WEKA window opens, use the default settings and begin to train the software by creating two classes and tracing lines over the vasculature (high A1% regions) and non-vasculature (low A1% regions). 

7.5 Continue to add new traces to the two classes until the software consistently identifies the high A1% regions of the vasculature while eliminating any higher regions of background noise.  See Supplemental Model for representative classifier model.

7.6 Once the classified image is produced, click on Image > Type > 8 Bit. Threshold the image and create a mask. If the thresholded image still needs to be cleaned up further, use the Analyze Particles function. 

7.7  Adjust the size and circularity until any smaller and circular regions of the thresholded image are excluded. A clean mask with only the vasculature and very little background is obtained.

7.8 Click on Edit > Selection > Create Selection. Transfer the selection to the ROI manager by clicking on Analyze > Tools > ROI manager. 

7.9 Duplicate the classified image. Proceed to Process > Binary. To expand the mask and define the distance from the vasculature that will be included in the image segmentation, select Dilate. Repeat until the mask has expanded to the desired range. Record this region of interest (ROI) in the ROI manager. 

NOTE: The goal of this step is to quantify the amount or behavior within a certain proximity of the blood vessel (for example, the number of cells present within X µm of the blood vessels). The amount of dilation required is entirely determined by the scientific question. 

7.10 To quantify the number of cells within the restrictive regions, select the window (image/channel) of interest. This can be any window that shares the same field of view as the vascular mask. Apply both ROI’s using the XOR function from the drop-down menu. 

NOTE: This operation will measure the items within the desired distance from the vasculature, excluding the vasculature itself. This combined ROI approach can then be used to measure a multitude of parameters, such as intensity, cell number, or migration.

8.	Image segmentation of the tumor nest 

8.1	Open the NADH image from either a high-resolution intensity scan or FLIM collection in ImageJ. 

NOTE: This can be done on individual z-slices, full stacks, or applied to z-projections of a few slices.

8.2 Go to Plugins > Segmentation. Select the trainable WEKA segmentation plugin.

8.3 Once the WEKA window opens, use the default settings and begin to train the software into two classes of NADH high regions and NADH low regions. The NADH-high regions will have a very discernable pattern of cells with nuclei and the software will easily identify it. 

8.4 Continue to toggle back and forth with the overlay to refine the algorithm with additional training until it recognizes all regions of the tumor as determined by eye and prior knowledge of tumor morphology. This is an iterative process.

8.5 Once the algorithm recognizes all the regions of the tumor, select the Create Result button. This will produce a new image. Duplicate this image.  

8.6 Select the first duplicated image and convert it to an 8 bit image by selecting Image > Type > 8 Bit. Threshold this image to create a binary mask. Then create a selection and transfer it to the ROI manager. These ROIs will define the stroma.

8.7 Select the second of the duplicated image and convert it to an 8 bit image. Invert this image by selecting Image > Edit > Invert, and then threshold this image to create a binary mask. Once again create a selection and transfer it to the ROI manager. This ROI will define the tumor nest.

9.	Image segmentation by fiber organization or alignment

9.1 To begin, open the SHG images, prepare any z-projection, and assess the need for any pre-processing. For good results, high-quality images with discernable fibers and low noise are required.

9.2 Optional: For preprocessing in ImageJ to increase signal-to-noise (SNR) of the SHG channel, subtract the background using a rolling ball subtraction. For most applications, use a rolling ball subtraction between 20 pixels and 50 pixels. Then smoothen the image and save it. 
 
9.3 Open the OrientationJ plugin and set the processing parameters. In the OrientationJ window, define the size of the local tensor window. For a 20x image of this fiber density, set 10 pixels to 15 pixels as a starting point.
 
9.4  Select Cubic Spline as the gradient model and check the Color Survey Box. Define the color survey. Set both the Hue and Saturation as Coherency, and then define the Brightness as Original Image, hit Run.

9.5 The output file of the plugin is RGB colormap.  Adjust the value of the local tensor window until aligned regions, as determined by the eye, are properly highlighted with blue and magenta hues.

9.6 Once the output image is satisfactory, separate this RGB image into 3 channels. Select Image > Color > Split Channel.

9.7 To enhance the appearance of aligned regions for the purpose of masking, use the image calculator by selecting Process > Image Calculator. Using this operator, subtract the green image from the blue image. For a more restrictive mask, subtract the green image from the red image. For random regions, subtract the blue channel from the green channel.

9.8 Threshold the resulting image using the Moments algorithm. In most cases, this should not need further adjustments. However, adjust if needed. This will produce a binary image.

9.9 Once the binary image is made, fill the holes by selecting Process > Binary > Fill Holes between fibers and round out the boundaries of the mask using a median filter. A median filter of 10 is a good starting point, adjust it to make a good fit for the data. Manually inspect the mask for agreement and remove any ROIs that are erroneous.

9.10 Once the mask is satisfactory, create a selection by selecting Edit > Selection > Create Selection. Transfer this selection to the ROI manager.
			
[bookmark: 3dy6vkm]REPRESENTATIVE RESULTS: 
The installation of the MIW and basic experimental planning are the first steps in this process. This particular MIW design and protocol are more amenable to longitudinal studies19 and has been successfully utilized with both upright and inverted microscopes. In this case, an inverted microscope was used as it has resulted in greater image stability of the mammary gland with fewer breathing artifacts. In Figure 1A, we provide the dimensions of the rigid MIW and a graphical overview of the implantation process. 

A typical field of view within a label-free MMTV-PyMT39 mammary tumor (Figure 1B–E, Figure 3A) is very heterogeneous, comprising of collagen fibers, numerous stromal cells, masses of tumor cells, and vasculature (Figure 3A). In general, collagen fibers are more abundant near the window and decrease in abundance deeper into the tumor (Figure 1B–E) The organization of the fibers surrounding the tumor masses can also be quite varied, often with regions of more random organization in the same field of view as regions of higher alignment (Figure 2D,H and Figure 3I). 

To develop an analysis pipeline that can segment intravital data into perivascular regions, tumor and stroma, this protocol focused on using the signal from endogenous NAD(P)H and SHG. While identification of the tumor and stroma can be straightforward, the identification of perivascular regions within the tumor microenvironment can be challenging. The vasculature often resides within the narrow ribbons of reduced NAD(P)H signal between the bright NAD(P)H+ cancer cell masses. It is important to note that not all dark boundaries harbor vasculature; rather, some dark regions are simply tumor folds or the butting up of adjacent tumor lobes (yellow arrow, Figure 2G). Moreover, while a seasoned eye can extract the bigger diameter blood vessels from the tumor as they have a distinctive appearance, this distinction is not always trivial. This is especially true for smaller diameter vessels where their appearance may be more subtle and variable. In this case, the use of the fluorescence lifetime of NAD(P)H can aid in the positive identification of the vasculature (Figure 2B,F). Fluorescence lifetime (FLIM) does not measure the abundance or intensity of photons at a location, but the time it takes for those excited molecules to decay to their ground state. Red blood cells (RBC) and blood plasma have been shown to have a characteristically short and distinctive fluorescence lifetime32, 37 that can be leveraged for the identification and segmentation of vessels in tissues. 
	
To determine how well the fluorescence lifetime of NAD(P)H identifies the vasculature intravitally, a 100 µL bolus of a rhodamine-labelled dextran was injected into the tail vein after collecting the FLIM image. Comparisons of maximum intensity projections of NAD(P)H FLIM closely mirror those vessels labeled with a fluorescently labeled dextran (Figure 2I–J).  Repeating this approach in multiple mice demonstrated that the average mask area from the FLIM image over the area of the dextran mask was 78.6% ± 12.3% (Figure 2L).  While the overlay was not 100%, this technique was accurately mapping the entire vascular network. The differences observed in the reported areas could often be attributed to intravital drift or registration issues, thinner vessel diameters due to model fitting, or the loss of fine vessels due to RBC exclusion by the pressure of the growing mass. Importantly, this technique works equally well in the presence of both genetically encoded fluorophores like GFP or label-free tumor models (Figure 2D,H), thereby providing a very robust and broadly applicable means of identifying the vasculature for image segmentation.
 
To delineate the boundaries of label-free tumor masses, NAD(P)H autofluorescence (Figure 1C) was used. This can be captured by either independently collecting a NAD(P)H image or summating the NAD(P)H FLIM data to generate an intensity image. Either route will allow for suitable segmentation of the tumor microenvironment. As a general observation, two-photon excitation of NAD(P)H in cancer cells elicits bright autofluorescence producing an image that shows crisp individual cells with darkened nuclei (Figure 2E,G). This pattern can be used to define the extent of the growing mass. While simple intensity-based thresholding of NAD(P)H is possible to define the boundary of the tumor compartment, a trainable segmentation tool often performs better (Figure 3B,E). Some other common readouts, like cell migration or cellular protrusive analysis, may benefit from genetically encoded exogenous fluorescence within the mouse model or the implantation of fluorescently labeled cell lines (Figure 2A). In these cases, the task of demarcating the boundary of the mass can be accomplished with simple thresholding of the fluorescent protein. Sometimes the expression of the fluorophore can become quite heterogenous after implantation. This should not cause segmentation problems. Also, it has often been observed that tumors created by fluorescent allografts or xenografts have less compartmentalized regions of collagen fibers than tumors created by genetic tumor models like MMTV-PyMT40. 

The stromal compartment encompasses the regions outside the growing mass or between growing masses, and a mask for the stroma is obtained by inverting the tumor ROI (Figure 3B-F). The stromal compartment can then be further compartmentalized into sub-ROIs based on collagen fiber architecture. Collagen fibers are a significant feature in the stroma and have a large diversity of fiber organizations, which are known to modulate cell behavior41, 42. Often numerous local (<100 µm) regions of aligned or random fibers exist within the image40. Therefore, regions of relatively aligned (red/blue hues) or random (green hues) fiber organization (Figure 3I) were identified with the OrientationJ plugin. Using the OrientationJ coherency color map, masks based on the local fiber organization can be created for segmentation purposes (Figure 3J). These masks can then be overlaid to analyze differential dynamic stromal cell behavior (Figure 3K) due to the effects of specific fiber organization (Figure 3H,I).

Now that ROIs for the various compartments of the tumor microenvironment have been defined, they can be applied to the individual frames or channels of the intravital timelapse movie.  At this point, it is important to emphasize that all the signals shown in Figure 3A are derived entirely from endogenous sources. This image demonstrates the rich potential of spatial and contextual cues that can come from purely endogenous, ubiquitous, and label-free sources. Here, we used the MMTV-PyMT tumor model as an example to illustrate the applicabilty of the method to quantify the number and characteristics of macrophages within specific locations of the tumor microenvironment (TME). A previous intravital study43 has shown that cells emitting high levels of FAD autofluorescence (Figure 3A, magenta cells, yellow arrows) stain positively with F4/80 antibodies and represent a population of macrophages within the TME.  Using this workflow to segment the image, it is possible to efficiently and accurately examine the number, monitor cell-cell interactions over time, or even observe the metabolic characteristics of this subset of macrophages (magenta) within different compartments of the TME (Figure 3A, yellow arrows). For example, the behavior of FAD-high macrophages that specifically reside within the NAD(P)H-high tumor nest can be characterized (Figure 3E). Similarly, the behaviors of macrophages with respect to the local organization of the fibers in the stroma region can be examined. Some recent reports have indicated that macrophages and other migrating cells in the stroma are responsive to mechanical cues from their local microenvironment40, 44, 45. Using the fiber alignment masks produced by this method, it is possible to examine their differential behaviors between regions of random and aligned collagen organizations. Lastly, this same focused analysis can also be applied to determine the number and the behavior of macrophages localized within a defined proximity to the vasculature. In Figure 3G, the vasculature can be seen in red, and macrophages can once again be seen in magenta. A mask for the vasculature using NAD(P)H FLIM was created and then expanded through dilation of 10 pixels. The distance chosen was arbitrary for demonstration purposes but can be optimized for the particular needs of the individual experiment. Importantly, while this image is of a single z-slice, this procedure could be easily extrapolated to 3D stacks to observe behavior around the entire volume of the vessel.

[bookmark: 1t3h5sf]FIGURE AND TABLE LEGENDS: 
Figure 1: Graphical abstract of mammary window implantation and the underlying organization of an MMTV-PyMT tumor. (A) The dimensions of the mammary imaging window and schematic for the general implantation process. (B–F) This is a montage from an unlabeled MMTV-PyMT tumor representative starting from 50 µm beneath the surface of the MIW and continuing to a depth of 80 µm. The depth values are provided beneath each image. Collagen fibers (gray) are more prevalent at the surface of the tumor (NAD(P)H, blue) than at greater depths. Scale bar 100 µm.

Figure 2: Representative intravital image of a GFP labeled and label-free PyMT tumor and validation of NAD(P)H FLIM as a marker for the vasculature. A composite image (A) of a typical allograft of GFP-4T1 cells into the mammary fat pad and a representative mammary tumor from an MMTV-PyMT tumor model (E). NAD(P)H FLIM (D) maps the vasculature in both models (B,F). GFP fluorescence (C) and NAD(P)H autofluorescence (G) were used to identify the tumor. Collagen was visualized by SHG (D,H). A composite image using NAD(P)H FLIM to identify vasculature was validated by comparing maximum intensity projections of the intravital stack before and after tail vein injection of fluorescent dextran (I,J,K). The quantification of four mice (color identifies individual mice) and fields of view (individual dots in graph) is shown in (L). Scale bars 100 µm.

Figure 3: Representative image segmentation using endogenous fluorescence within label-free PyMT tumor. A composite image (A) of a single z-slice from a typical mammary tumor was collected using intrinsic signals only. SHG (gray) visualizes the collagen fibers of the tumor. Fluorescence lifetime imaging of NAD(P)H autofluorescence (Tau (τ) mean) reports the metabolic signatures of the cells (green to orange hues) and the location of blood vessels (red). FAD autofluorescence (magenta) identifies macrophages. Using the segmentation scheme outlined in this protocol, the label-free tumor was segmented into compartments for the tumor nest (B,E), stroma (C,F), and vasculature (D,G) using only SHG and NAD(P)H autofluorescence. The stroma and collagen fibers (H) can also be classified into local regions of aligned fibers ((shown in magenta/blue), J,K). Scale bars 100 µm.

Supplemental Data 1: Representative data set of fitted A1% from NAD(P)H FLIM. This is a maximum intensity projection of a fitted A1% from a typical data set. It is a representative of the quality of identification possible and a typical level of background before using the trainable classifier.

Supplemental Model: Representative classifier used on fitted A1% for the identification of the vasculature.  This is a sample classifier model for use in the trainable WEKA segmentation plugin within ImageJ. 

[bookmark: 4d34og8]DISCUSSION: 
The 4D intravital imaging is a powerful tool to investigate dynamic physiological interactions within the spatial and temporal context of the native tumor microenvironment. This manuscript provides a very basic and adaptable operational framework to compartmentalize dynamic cell interactions within the tumor mass, the adjacent stroma, or within proximity to the vascular network using only endogenous signals from second harmonic generation or NAD(P)H autofluorescence. This protocol provides a comprehensive, step-by-step method from implantation of the imaging window to image acquisition, analysis, and segmentation. We believe this technique will contribute to a needed analysis framework to segment and quantify 4D intravital data.

This protocol was developed to be broadly compatible with numerous intravital mouse models, including unlabeled PDX models. PDX’s are an incredibly informative model46 but pose a challenge to intravital imaging because the nature of the PDX model is not well-suited for genetic manipulation. Therefore, it would be quite advantageous to be able to visualize dynamic interactions in PDX models within a physiological environment while still being able to segment the images using solely endogenous metabolites like NAD(P)H and second harmonic generation (SHG). In addition to being advantageous for PDX models, this multidimensional approach could be theoretically applied to any tumor or normal tissue study that needs spatial and structural context to address a physiological question. NAD(P)H autofluorescence and SHG from collagen fibers are ubiquitous to all tissues and represent a universal and free resource in intravital collections.  It is also notable that this FLIM approach to identifying the vasculature is robust even in the presence of fluorescence from exogenous sources like GFP. Lastly, SHG and NAD(P)H emission can be visualized in the blue spectrum, thereby residing in a wavelength that is not typically used in the imaging of fluorescent fusion constructs. 

The aspect of this approach that is novel and has particular added value is the label-free identification of the vasculature. While other approaches can work, the use of the fluorescence lifetime of NAD(P)H easily provides a clear signature without additional labeling. The data shows that the lifetime-defined vessels mirror the vasculature labeled from tail vein injection of fluorescent dextran, the gold standard for vasculature imaging. Our technique excels at visualizing smaller blood vessels compared to simple two-photon or three-photon excitation, where larger vessels are easily visualized, but smaller ones require more expertise to identify. The lifetime signature is unambiguous for all vessels, regardless of size. Moreover, this additional NAD(P)H FLIM acquisition can be easily combined with other markers for the segmentation of the tumor microenvironment. Through a single FLIM acquisition of NAD(P)H, the requirements for defining the vasculature, tumor nest, and stroma are achievable. The FLIM collection can be incorporated into the existing experimental design by collecting a single acquisition at the end or beginning of a time series or interleaving the collections throughout the entire 4D acquisition. Determination of the appropriate amount of FLIM images will depend on specific experimental needs and constraints, like acquisition intervals, experimental duration, or image stability, but at a minimum, one FLIM collection per 4D series will be needed for this method.

 This process of utilizing NAD(P)H FLIM for the identification of the vasculature requires mathematically fitting the FLIM data to an exponential function of the form

with A1+A2+A3=1.  While most lifetime images of NAD(P)H reported in the literature are fitted as a bi-exponential, in this application NAD(P)H was fitted as a tri-exponential where the τ1 and τ2 are set to the reported values of RBC’s and τ3 is allowed to float. Importantly, the goal is not to achieve the most accurate lifetime value, but rather to provide an optimal image for segmentation. When the τ1 and τ2 values are initially fixed at the reported values of RBC’s32, 47 and the matrix is calculated, the blood vessels will stand out with A1% values greater than 60% in the blood vessels and A1% values generally less than 40% in the adjacent tumor. The next step is to try to maximize the A1% in the blood vessels while minimizing the A1% in the adjacent tumor. This is an iterative process, and by the end of it, the A1% values of the blood vessels will be greater than 90% with the A1% values of the tumor less than 10%. Once the A1% values of the blood vessels are uniformly high and the background is uniformly low, export these A1% files into a trainable segmentation tool. This will quickly remove any remaining noise and define the ROI for the vasculature. 

As the mammary fat pad is located outside of the body cavity, the surgery is minimally invasive, and the best results are obtained by implanting the MIW over the 4th inguinal mammary gland. The timing of window implantation and when the experiment will be conducted is critical. It is best to allow for 24 – 48 h of healing post-surgery before the physiological timepoint that will be investigated. While the procedure itself only requires a small incision (≈ 10 mm) to insert the window (Figure 1A), post-surgery healing time will permit any inflammation and fluids that accumulated due to the implantation process to clear. Moreover, it will also allow the tumor to continue to grow into the window. Both factors will improve the overall image quality by decreasing opacity/scattering and increasing image stability. The next thing to consider is the planned total duration of the experiment. While these windows were designed for longitudinal studies, the rigid nature of the window incurs a time limit of 2 to 3 weeks. After that timespan, the window has a tendency to dislodge from the dermal layer, thereby contaminating and terminating the experiment. If a longitudinal study of the mammary gland is not required, other intravital methods like a terminal skin flap procedure22 that eliminates the surgical implantation of a MIW may be a better option. The skin flap procedure provides better access to the entire gland as it is not constrained by the placement and dimensions of the MIW, and it can produce greater image stability as the gland is pulled away from the body cavity. Regardless of the intravital imaging approach, the segmentation of the microenvironment using endogenous fluorescence is still broadly applicable for subsequent image analysis. The last thing to consider is the duration of the individual imaging experiment. It is not unreasonable to acquire movies lasting 6–8 h. However, during the longer collections, hydration becomes an issue, and close monitoring of the health of the mouse is required. 

One significant advantage of this method is that the various images of endogenous fluorescence required for segmentation of the tumor microenvironment can be collected with relative ease and without additional manipulations to the mouse. With the filter/dichroic combination reported here (Table of Materials), both SHG and NADH images can be acquired with the same filter set by switching wavelengths from 890 nm to 750 nm. While this creates an acquisition delay, it does not impact subsequent image segmentation. It is also important to remember that this method represents a mere starting point for a segmentation technique using endogenous fluorescence, and more advanced optical configurations may allow for simultaneous acquisitions if needed.

There are limitations of using FLIM to identify the vasculature. The FLIM approach requires specialized electronics, instrumentation, and expertise to collect. However, all these requirements are increasingly more integrated into modern microscopes and more available through the use of imaging core facilities. FLIM has become a mature technology and acquiring good data does not require much training. A second limitation is that FLIM acquisitions are time-consuming. While the frame rate for an image collected with fluorescent dextran is about a second or less, the average FLIM collection can range from 60 s to 120 s, which may be prohibitive if the physiological timepoints are shorter than that. FLIM identification of the vasculature is not intended to replace all tail vein injected fluorescent dextran or multiphoton excitation of the vasculature; rather, it is yet another approach in the growing toolbox for intravital imaging. Furthermore, we anticipate that longer acquisition times will be made dramatically shorter in the coming years. The detectors and electronics are rapidly improving, decreasing the detector dead time, and thereby requiring shorter acquisition periods to capture the same number of photons. The second reason to be optimistic of shorter acquisition times is the emergence of machine learning software or image restoration algorithm like CSBDeep48.  These algorithms could be potentially trained to work with shorter exposure times and reduce the number of photons needed to accurately identify structures for segmentation purposes. Together, this could rapidly reduce the timeframes needed for these multidimensional acquisitions. 

The use of intravital imaging will only become more important as researchers try to unravel the many complex cell-cell and cell-matrix interactions that occur within the physiological tumor microenvironment. Therefore, continued developments in the acquisition, segmentation and analysis capabilities are needed. Towards this end, it is important to not overlook the potential of endogenous fluorescence images for microenvironment segmentation. In this protocol, the endogenous signal from SHG and fluorescence metabolites, including NAD(P)H intensity and FLIM, was used for segmentation purposes during intravital imaging of the mammary TME. Other endogenous metabolites or intrinsic properties can provide additional signals to reveal the dynamic reciprocity of tumor cells and the microenvironment. For example, FAD can be used to monitor the movement of immune populations43, 3P generation can highlight structural features like plasma membranes or adipose36, and elastin fluorescence can be used to separate arteries from veins47. Therefore, endogenous fluorescence will continue to provide a rich multi-dimensional platform that should be utilized to the fullest as the research community continues to build the toolbox for intravital microenvironment segmentation and analysis.  
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