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SUMMARY:  36 

To quantify microvascular flow from high speed capillary flow image sequences, we developed 37 

STAFF (Spatial Temporal Analysis of Fieldwise Flow) software. Across the full image field and over 38 

time, STAFF evaluates flow velocities and generates a sequence of color-coded spatial maps for 39 

visualization and tabular output for quantitative analyses. 40 

 41 

ABSTRACT:  42 

Changes in blood flow velocity and distribution are vital in maintaining tissue and organ perfusion 43 

in response to varying cellular needs. Further, appearance of defects in microcirculation can be 44 
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a primary indicator in the development of multiple pathologies. Advances in optical imaging have 45 

made intravital microscopy (IVM) a practical approach, permitting imaging at the cellular and 46 

subcellular level in live animals at high-speed over time. Yet, despite the importance of 47 

maintaining adequate tissue perfusion, spatial and temporal variability in capillary flow is seldom 48 

documented. In the standard approach, a small number of capillary segments are chosen for 49 

imaging over a limited time. To comprehensively quantify capillary flow in an unbiased way we 50 

developed Spatial Temporal Analysis of Fieldwise Flow (STAFF), a macro for FIJI open-51 

source image analysis software. Using high-speed image sequences of full fields of blood flow 52 

within capillaries, STAFF produces images that represent motion over time called kymographs for 53 

every time interval for every vascular segment. From the kymographs STAFF calculates velocities 54 

from the distance that red blood cells move over time, and outputs the velocity data as a 55 

sequence of color-coded spatial maps for visualization and tabular output for quantitative 56 

analyses. In normal mouse livers, STAFF analyzes quantified profound differences in flow velocity 57 

between pericentral and periportal regions within lobules. Even more unexpected are the 58 

differences in flow velocity seen between sinusoids that are side by side and fluctuations seen 59 

within individual vascular segments over seconds. STAFF is a powerful new tool capable of 60 

providing novel insights by enabling measurement of the complex spatiotemporal dynamics of 61 

capillary flow. 62 

 63 

INTRODUCTION:  64 

The microvasculature plays a critical role in physiology, ensuring effective perfusion of tissues 65 

under changing conditions. Microvascular dysfunction is associated with myriad conditions 66 

including long-term cardiovascular morbidity and mortality, development of dementia, and 67 

disease of both liver and kidney and thus is a key factor of interest in a broad range of biomedical 68 

investigations1–5. While multiple techniques have been used to evaluate tissue perfusion, only 69 

intravital microscopy enables data collection at the temporal and spatial resolution necessary to 70 

characterize blood flow at the level of individual capillaries.  71 

 72 

Microvascular flow can be visualized in fluorescence microscopy either by the movement of 73 

fluorescent microspheres or by the movement of red blood cells against the background of 74 

membrane-impermeant fluorescent markers (e.g., fluorescently-labeled dextran or albumin)6, 7. 75 

Microvascular flow can be imaged in superficial cell layers using widefield microscopy, or at depth 76 

using either confocal or multiphoton microscopy. However, capillary flow rates are such that the 77 

passage of red blood cells cannot generally be captured at speeds less than 60 frames per second. 78 

Since most laser scanning confocal and multiphoton microscopes require 1–5 s to scan a full 79 

image field, this speed can generally be accomplished only by limiting the field of view, 80 

sometimes to a single scan line8. The process of limiting measurements to selected capillary 81 

segments (1) has the potential to introduce selection bias and (2) makes it impossible to capture 82 

spatial and temporal heterogeneity in the rates of capillary blood flow. In contrast, images of 83 

capillary networks can be collected at speeds exceeding 100 fps using widefield digital 84 

microscopes equipped with scientific complementary metal oxide semiconductor (sCMOS) 85 

cameras9, 10. These inexpensive systems, common in typical biomedical laboratories make it 86 

possible to image microvascular flow across entire two-dimensional networks, essentially 87 

continuously. The problem then becomes one of finding an analysis approach that is capable of 88 

https://www.sciencedirect.com/topics/medicine-and-dentistry/kymograph


  

 
 

extracting meaningful quantitative data from the massive and complex image datasets generated 89 

by high-speed video microscopy.  90 

 91 

To enable analysis of full-field flow data we have developed STAFF, a novel image analysis 92 

software that can continuously measure microvascular flow throughout entire microscope fields 93 

of image series collected at high speed11. The approach is compatible with a variety of different 94 

experimental systems and imaging modalities and the STAFF image analysis software is 95 

implemented as a macro toolset for the FIJI implementation of ImageJ12. The underlying principle 96 

used here to visualize microvascular flow is that first, some contrast must be provided to be able 97 

to image the red blood cells within capillaries. In our studies, contrast is provided by a bulk 98 

fluorescent probe that is excluded by the red blood cells. The velocity of flow can then be 99 

quantified from the displacement of the red blood cells that appear as a negative stain within the 100 

fluorescently labeled plasma in images collected at high speed from a living animal8. We then use 101 

STAFF to make plots of distance along each capillary segment over multiple intervals of time 102 

called kymographs, then detect the slopes present in the kymographs13, and from those slopes 103 

calculate the rates of microvascular flow. The approach can be applied to images collected from 104 

any capillary bed that can be accessed for imaging. Here we describe the application of IVM and 105 

STAFF to studies of blood flow in the liver.  106 

 107 

PROTOCOL:  108 

All animal experiments were approved and conducted according to the Institutional Animal Care 109 

and Use Committee guidelines of Indiana University, and adhered to the NRC guide for the care 110 

and use of animals.  111 

 112 

1. Surgical preparation for intravital microscopy 113 

 114 

Note: This is not a survival surgery. Once section 1 “Surgical preparation for intravital microscopy” 115 

is begun, work cannot be paused until the completion of section 2 “Intravital microscopy”.  116 

 117 

1.1. Acclimatize 9–10-week-old male C57BL/6 mice, for at least 4 days and fast for 16 h prior to 118 

studies.  119 

 120 

1.2. Weigh the animal, sedate with 5% isoflurane and place on a heating pad to maintain body 121 

temperature. Use an oxygen flow rate of 1–2 L/min. Check reflexes by toe pinch. Monitor 122 

temperature using a rectal thermometer. Monitor heart rate and respiration visually.  123 

 124 

1.3. When anesthesia is stable, shave the area for jugular cannulation placement and the area 125 

below the rib cage for the exposure of the liver.  126 

 127 

1.4. For jugular cannulation, make a 1 cm left ventral incision 1–2 cm below the mouse’s jaw. 128 

Clear away all fat and fascia surrounding the jugular vein. Tie off the anterior end of the jugular 129 

using 06 suture string to prevent bleeding.  130 

 131 

1.4.1. Make a tiny nick in the jugular vein and slide the cannula (30 G x ½ in, needle), needle 132 



  

 
 

holder and polyethylene tubing (0.011 in. x 0.024 in. attached to a Luer stub adapter and filled 133 

with 0.9% saline) in about 1 cm, and secure at the posterior end of the jugular using 0-6 suture 134 

string.  135 

 136 

1.5. Using the jugular cannula deliver 70 kDa fluorescein dextran (to a dose of 30 mg/kg via 137 

injection of 0.1 mL of a 9 mg/mL solution in saline). 138 

 139 

1.6. Expose the liver for imaging by making a 4–6 cm incision across the torso, 1–2 cm below the 140 

middle of the rib cage.  141 

 142 

1.7. Place a wet (soaked in 0.9% saline) 2 in. x 2 in. gauze sponge below the left lateral liver lobe. 143 

Place tape on the periphery of the glass window of a 40 mm coverslip-bottomed dish and apply 144 

cyanoacrylate adhesive to the tape. Press the glass plate to the liver and using cotton tipped 145 

applicators press the gauze into the glue on the tape to minimize tissue motion for microscopy.  146 

 147 

1.8. Move animal to the microscope stage. Add sterile 0.9% saline into the coverslip-bottomed 148 

dish to keep the liver moist throughout the imaging session. Maintain temperature at 36–37 °C 149 

via heating pads mounted on the stage, a heating pad placed over the animal and an objective 150 

heater.  151 

 152 

2. Intravital microscopy 153 

 154 

2.1. Perform intravital microscopy on an inverted epifluorescence microscope equipped with a 155 

video camera capable of high-speed image capture.  156 

 157 

NOTE: Here, a Xenon arc lamp, fluorescein-specific excitation (480–500 nm) and emission (507–158 

543 nm) filters, Plan Fluor 20X, N.A. 0.75 water immersion objective, and a high-speed sCMOS 159 

camera were used. 160 

 161 

2.2. Select the area of interest for capillary blood flow analysis using minimal illumination.  162 

 163 

2.3. Set the exposure time short enough for the camera to be able to acquire 100 fps. Set 164 

illumination level to clearly visualize red blood cell shadows and the topology of the vasculature 165 

while also avoiding phototoxicity and photobleaching of the fluorescent probe. 166 

  167 

2.4. Collect images at a rate of 100 fps. Set the camera pixel resolution between ~0.65 and ~1.3 168 

µm/pixel. Set frame size between 512 x 512 and 1024 x 1024 pixels. Set bit depth between 8 and 169 

16 bits. Use the highest resolution, frame size and bit depth that still allows 100 fps image 170 

collection on the system.  171 

= 172 

2.5. Save time series file(s) as a sequence of TIF files or as native camera/microscope format if 173 

Bio-Formats14 in FIJI can open the native format files.  174 

 175 

2.6. Image multiple areas over time. Maintain the mouse on the microscope stage for up to two 176 



  

 
 

hours. Euthanize the mouse at the end of imaging.  177 

 178 

NOTE: The duration of thetime series will be based upon balancing the need to image for an 179 

interval of time that embraces the variability, while not affecting the viability of the tissue. The 180 

duration of the time series may also be dictated by file size considerations; a 1 min time series of 181 

1024 x 1024 pixel 16-bit images collected at 100 fps will generate a file that is 12 GB in size. File 182 

size considerations may also dictate frame size and bit depth used. There are no explicit size limits 183 

within STAFF.  184 

 185 

3. Define the vascular network using TrakEM2 in FIJI 186 

 187 

NOTE: The protocol can be paused after saving work at any point in section 3.  188 

 189 

3.1. Download and install FIJI from https://imagej.net/Fiji/Downloads.  190 

 191 

NOTE: Version 1.51n of Fiji was used for this project, and can be downloaded from 192 

https://downloads.imagej.net/fiji/Life-Line/fiji-win64-20170530.zip. Note that on Windows, FIJI 193 

should be installed in the user space and not in Program Files. 194 

  195 

3.2. Open the movie file in FIJI using File > Open or using File > Import > Image sequence. Select 196 

a single image from the stable images between respirations where the topology of the vascular 197 

network is easy to see. Select Image > Duplicate and duplicate the selected single image (not the 198 

stack) and save the image in a new folder. Do not include spaces in file or folder names.  199 

 200 

3.3. Set up a new blank TrakEM2 project by selecting File > New > TrakEM2 (blank). Select the 201 

new folder containing the single image from the movie as the project folder. The TrakEM2 202 

windows will open.  203 

 204 

3.4. Right-click in the main work area and select Import > Import Image. Navigate to the single 205 

image saved in step 3.3 and select it.  206 

 207 

3.5. Right-click in the main work area again and select Display > Autoresize canvas/Layer set. 208 

Left-click in the main work window. The image will fill the work area.  209 

 210 

3.6. To select the areas in the image that contain the vascular network, setup area list selection 211 

in TrakEM2. In the smaller TrakEM2 window (Template, Project Objects, Layers) right-click on “• 212 

anything”. Select Add new child > area list. 213 

  214 

3.7. In the smaller TrakEM2 window, drag the "Template > anything > • area list" icon onto 215 

“Project Objects > project”. Under Project Objects “Project > anything > • area list” is now 216 

present.  217 

 218 

3.8. In the main TrakEM2 window under the Z space tab, a bar labeled area list was created. Click 219 

to select it. In the main TrakEM2 window also select the paintbrush tool. Press Shift and roll the 220 

https://imagej.net/Fiji/Downloads
https://downloads.imagej.net/fiji/Life-Line/fiji-win64-20170530.zip


  

 
 

mouse wheel to select an appropriate size for the paintbrush, e.g., smaller than the diameter of 221 

the vasculature. To save the TrakEM2 setup press Control + S keys.  222 

 223 

3.9. Paint the vascular network using the paintbrush tool. To erase hold down Alt while using the 224 

paintbrush tool. Do not include out-of-focus regions. Save often using Control + S.  225 

 226 

3.10. When labeling of the vascular network is complete, right-click in the main TrakEM2 window 227 

and select Export > AreaLists as labels (tif). In the popup window select Scale 100% and Export 228 

All area list. Close TrakEM2 windows and choose yes for Save project.  229 

 230 

3.11. The image of AreaLists will open and may appear as a blank black image. In the main FIJI 231 

Menu select Image > Adjust > Brightness/Contrast. In the B&C window press the auto button 232 

and the AreaList will become visible. In the main FIJI menu select Image > Lookup Tables > Invert 233 

LUT. Save this image of black labels on white background and close the image.  234 

 235 

3.12. Open the labels file in FIJI. Select Plugins > Skeleton > Skeletonize. Save the skeletonized 236 

image as a tif. Use the skeleton.tif file as one of the input files needed to run the STAFF flow 237 

analysis. When saving the file, do not use spaces in file name.  238 

 239 

3.13. Manually edit the skeleton file as needed, by placing a gap (using the paint tool) in the line 240 

drawing for example at locations where branches in the vasculature have not been captured 241 

because they go out of the image plane.  242 

 243 

4. Prepare the movie sequence for STAFF analysis 244 

 245 

4.1. Open the movie file in FIJI using File > Open or File > Import > Image sequence. Select a time 246 

period of the image sequence for flow analysis (can be seconds to minutes, hundreds to tens of 247 

thousands of frames) where tissue position has remained stable over time, except for during 248 

respiration.  249 

 250 

4.2. Select Image > Duplicate and duplicate the selected portion of the sequence by typing in the 251 

numbers of the beginning and end frames. Check image spatial and temporal calibration under 252 

Image > Properties and correct if necessary. Save the image file as a TIF (or as an uncompressed 253 

AVI). This movie.tif is needed as an input file to run STAFF analysis. Do not include spaces in file 254 

name.  255 

 256 

5. Install STAFF macros into FIJI 257 

 258 

NOTE: (Important) Multiple folders within the FIJI folder subdirectories have similar file names, 259 

some capitalized, some not. Be certain that the correct folders are selected when installing 260 

STAFF.  261 

 262 

5.1. Download the STAFF macros from https://github.com/icbm-iupui/STAFF. 263 

 264 

https://github.com/icbm-iupui/STAFF


  

 
 

5.2. To install, first open the FIJI folder.  265 

 266 

5.2.1. On Windows find the folder where FIJI is installed in the user space, most commonly on 267 

the desktop. On MacOS find the FIJI icon in the Applications folder, right click and select Open. 268 

 269 

5.3. In the FIJI folder, open the plugins folder. Inside the plugins folder, open the Macros folder. 270 

Copy STAFF.ijm into this Macros folder: Fiji\plugins\Macros\STAFF.ijm. 271 

 272 

5.4. In the FIJI folder, open the plugins folder. Copy STAFF_Dir.jar into this plugins folder: 273 

Fiji\plugins\STAFF_Dir.jar. 274 

 275 

5.5. In the FIJI folder, open the macros folder. Inside this macros folder, open the AutoRun folder. 276 

Copy STAFF_Loader.ijm into this AutoRun folder: Fiji\macros\AutoRun\STAFF_Loader.ijm. 277 

 278 

5.6. Start FIJI and verify macro installation. To verify installation, select Plugins > Macros. When 279 

correctly installed the dropdown menu will include: Open-Create Project, Analyze Skeleton, Edit 280 

Time Intervals, Analyze Flow and Produce Spatial Map. 281 

 282 

5.7. If these commands are not present in the Macros menu, select Plugins > Macros > Install, 283 

open the Fiji\plugins\Macros folder, select the STAFF.ijm file, then click the OK button. The 284 

commands should now appear in the Plugins > Macros menu. 285 

 286 

6. Quantifying vascular flow using STAFF 287 

 288 

6.1. Create a new project. 289 

 290 

6.1.1. Select Plugins > Macros > Open-Create Project and follow prompts to create or update a 291 

configuration file. 292 

 293 

6.1.2. From the Open-Create Project menu, navigate to and select the Project Directory, Input 294 

File Folder and the input files Movie.tif and Skeleton.tif. Edit the auto-populated output file 295 

names if necessary.  296 

 297 

6.1.3 Input values for shortest segment length (20 µm), max speed measured (2000 µm/s) and 298 

max speed mapped (1000 µm/s).  299 

 300 

NOTE: The product of shortest segment length and frames per second gives the max flow speed 301 

that can theoretically be measured. The highest capillary flow speeds reported in literature are 302 

around 2000 µm/s15. In the liver, we observed that capillary flow speeds generally averaged 303 

around 300 µm/s and rarely exceeded 1000 µm/s. 304 

  305 

6.1.4. Type in the values for pixel size and frame rate for the image sequence (from image 306 

metadata or experimental notes). These values require user input. Check the Flicker Correction 307 

box if the images have periodic background intensity flicker.  308 



  

 
 

 309 

6.1.5. Select parameters for best visualization of the data. Select max speed mapped to include 310 

about 95% of the data so that the data is mapped across the full range of the color scale. STAFF 311 

maps high speed outliers to the high-speed end of the color scale.  312 

 313 

6.2. Analyze the skeleton. 314 

 315 

6.2.1. Select Plugins > Macros > Analyze Skeleton. The skeleton.tif file will open and the Region 316 

of Interest (ROI) Manager will open and run.  317 

 318 

NOTE: Analyze Skeleton classifies each pixel by its number of neighbors as either at an endpoint, 319 

at a junction, or within a segment. For each segment an identifying number (ID number), a 320 

calibrated branch length and the spatial coordinates of the branch ends are recorded. 321 

  322 

6.2.2. Wait for segment IDs to appear on the skeleton, the segment list to appear in the ROI 323 

manager, and a popup indicating that ROI Manager file for the skeleton is saved. Click OK.  324 

 325 

6.2.3. Verify that between respiration movements, the skeleton remains over where red blood 326 

cells pass through the capillary (e.g., not the edge and not outside the capillary). Display the 327 

labeled segments as an overlay on the movie, by opening the movie file, then dragging the ROI 328 

zip file onto the open movie. Play the movie with the segments overlaid.  329 

 330 

6.3. Select time intervals. 331 

 332 

6.3.1. Select Plugins > Macros > Select Time Intervals. Wait while the macro generates a 333 

kymograph from a single segment over the total time for the movie. From this kymograph, the 334 

user selects time intervals for analysis. Use Control + + keys to increase the size of the kymograph 335 

if needed.  336 

 337 

6.3.2. The rectangle selection tool is automatically activated. Draw a rectangle around each time 338 

interval. A good starting point for time interval length is the 1–2 s interval between respirations, 339 

which are apparent as horizontal blurred regions in the kymograph.  340 

 341 

6.3.3. Click the T key or the Add button in the ROI manager to record time interval selections. 342 

Repeat for as many time intervals as desired. Make selections sequentially from the top (or left) 343 

to bottom (or right) of the kymograph. 344 

  345 

6.3.4. Evaluate parameter choices (from Open-Create Project) by selecting a small number of 346 

time intervals (3 to 4) and completing analysis for just those intervals, since Analyze Flow (the 347 

next step) can take hours for large datasets. 348 

  349 

6.3.5. Click OK in the Make an ROI for each time interval window when done. A popup window 350 

appears when the selected intervals have been saved in the Project Folder. Click OK.  351 

 352 



  

 
 

6.4. Analyze flow. 353 

 354 

6.4.1. Select Plugins > Macros > Analyze Flow and the Analyze Flow Parameters dialogue box 355 

opens and displays the values entered in the Open-Create Project step. Edit if needed then click 356 

OK.  357 

 358 

6.4.2. The Output File Names dialogue box opens and displays the names entered in the Open-359 

Create Project step. Edit if needed then click OK.  360 

 361 

6.4.3. A dialogue box opens asking if the user is ready to begin analysis. Click OK and the analysis 362 

will begin. Wait for a dialog box that opens to indicate when Flow Analysis is complete.  363 

 364 

NOTE: Time needed depends on processor speed and size of the dataset. 365 

 366 

6.4.5. Confirm that results files have been stored as .csv format spreadsheet files in the Project 367 

Folder.  368 

 369 

NOTE: Output files include: segment_velocities.csv contains velocity values that have positive and 370 

negative values indicating flow direction. Cells representing segments less than the minimum 371 

length contain the text SHORT. Cells with velocity values greater than the maximum measured 372 

speed contain the text OUT (for outlier). kym_ang.csv contains kymograph angles measured by 373 

the Directionality plugin in FIJI. good_fit.csv contains goodness of fit of a curve to the distribution 374 

of angles measured from each kymograph. Poor goodness of fit (< 0.8) can indicate hidden branch 375 

points in a segment, change in velocity during the time interval, lamp or room light flicker.  376 

 377 

6.4.6. Check to verify that segment_velocities.csv contains few OUT values. If there are a large 378 

number of OUT values, verify that the minimum segment length to analyze is not less than 15–379 

20 µm, then rerun Analyze Flow. If the new segment_velocities.csv still contains a large 380 

proportion of OUT values, then check the flicker correction box, then rerun Analyze Flow.  381 

 382 

6.5. Produce spatial maps. 383 

 384 

6.5.1. Select Plugins > Macros > Produce Spatial Map and the Spatial Map Parameters window 385 

will open, displaying the values entered in the Open-Create Project step. Edit if needed, or to 386 

continue select OK.  387 

 388 

6.5.2. Watch as a temporal sequence of spatial maps of flow velocities is generated with color 389 

indicating flow speed. The output is in the form of a .tif image stack with one image for each time 390 

interval. Scroll through the .tif stack to visualize spatial and temporal variation in flow. Save the 391 

stack as an AVI file (uncompressed for maximum portability) to share as a movie.  392 

 393 

7. Quantitative analysis using STAFF output 394 

 395 

7.1. Open the segment_velocities.csv file in a spreadsheet or statistical analysis program. These 396 



  

 
 

values have positive or negative sign that indicates direction of flow relative to the start/stop 397 

points of that segment (recorded in the Segment ROI file).  398 

 399 

7.2. Make a new spreadsheet page containing the absolute values of all the velocity values. Use 400 

these values to calculate overall average flow velocity, average flow velocity for all vascular 401 

segments over time, flow velocity for each vascular segment over time, and make histograms of 402 

velocity distributions.  403 

 404 

7.3. Calculate values around specific morphological regions, or other regions of interest by first 405 

finding the specific relevant segments in the labeled skeleton and then performing analyses on 406 

these selected segments.  407 

 408 

REPRESENTATIVE RESULTS:  409 

STAFF analysis generates a complete census of microvascular velocities across entire microscope 410 

fields over periods of time extending from seconds to minutes. Representative results are 411 

presented in Figure 1, Figure 2, Figure 3, and Figure 4. Figure 1 shows an example of a time series 412 

of the microvascular network in the liver of a mouse, the generation of the skeletonized image 413 

that is used to define the axis of microvascular flow, and the STAFF-generated map of individual 414 

vascular segments identified for quantification. STAFF then uses the skeletonized image to break 415 

the microvascular network down into individual segments, then generates images of kymographs 416 

for each segment. These images are provided to the user, along with tools to identify the time 417 

intervals to be used for kymograph analysis (Figure 2). STAFF then uses the skeleton, and the 418 

user-supplied time intervals to break the kymograph of each segment into individual segment-419 

time intervals. STAFF then identifies the predominant angle in the kymograph from each 420 

segment-time interval and provides velocity measurements as .csv data files (Figure 3) and in the 421 

form of stacks of color-coded velocity map images (Figure 4). In order to support exploration of 422 

the data analysis pipeline, STAFF also provides .csv files containing all kymograph angle 423 

measurements and goodness-of-fit values. 424 

 425 

FIGURE AND TABLE LEGENDS: 426 

 427 

Figure 1: Generating the vascular skeleton. (A) Original image of a single frame from time series 428 

images collected from the liver of a living mouse. Bar = 100 µm. (B) Image shown in Panel A with 429 

central veins (CV) and portal triads (PT) indicated, to identify main directions of sinusoid flow. (C) 430 

Image from Panel A with overlay of TrakEM2 segmentation of sinusoids. (D) Binary image of 431 

TrakEM2 segmentation. (E) Skeletonization of TrakEM2 segmentation. (F) STAFF output image of 432 

individual vascular segments with labels. 433 

 434 

Figure 2: Kymograph analysis. (A) Magnified image of vascular segments shown in Figure 1F. (B) 435 

Typical kymograph from one segment collected over two inter-respiratory time intervals. Periods 436 

of respiration are noted with arrows. (C) Kymographs for segments 240, 252 and 254 from panel 437 

A. 438 

 439 



  

 
 

Figure 3: Velocity data analysis. (A, B) Tables of velocity measurements of four segments over 440 

19 time intervals expressed either as velocity with direction (A) or as absolute velocity (B). (C) 441 

Histogram showing distribution of absolute velocity values across the entire field over the entire 442 

20 s time period. (D) Graph of the velocities of the three segments whose kymographs are shown 443 

in Figure 2C over the entire 20 s period. 444 

 445 

Figure 4: Velocity map. (A) STAFF output image of the color coded velocity map for a single time 446 

interval for the field shown in Figure 1. (B) Composite of velocity maps for all time intervals 447 

presented as a 3D volume. 448 

 449 

DISCUSSION: 450 

There are multiple critical steps in this protocol. First, minimization of motion during intravital 451 

imaging of the liver is essential for generating movies that are usable for capillary flow analysis 452 

using STAFF. Due to the proximity of the diaphragm, short periods of respiration-induced motion 453 

occur, with the secured liver returning to its initial position after each breath. Securing the 454 

surgically exposed liver against the coverslip-bottomed dish using gauze, then imaging from 455 

below using an inverted microscope serves to immobilize the organ between respirations16–19. 456 

Second, an image acquisition speed of 100 fps is strongly recommended because the speed of 457 

flow that can be measured is a function of the speed of image acquisition and the minimum 458 

length of the segments in which flow is measured11. Third, producing a high-quality skeleton, the 459 

line drawing representation of the vascular network, is the next critical step in obtaining capillary 460 

flow velocities using STAFF. Skeleton line segments should lie near the midpoint of the 461 

vasculature between respirations over the time course being analyzed and vascular branching 462 

out of the image plane should be identified. The locations of these hidden branches along a 463 

vascular segment can be inferred by viewing the movie, by examining the kymograph or 464 

examining the velocity values over time for that segment. Viewing the movie, these vascular 465 

segments are seen either as having bidirectional flow, emanating away from or converging 466 

towards the location of the unseen branch, or as having an abrupt change in flow speed at that 467 

point along the vascular segment. The location of hidden branch points can be identified in 468 

kymographs as the location of a change in angle that is produced by the change in flow direction 469 

or velocity. In the spreadsheet, vascular segments with hidden branch locations may spuriously 470 

change direction (sign) or change between the values of the two contributing segments. If the 471 

time series includes too many branch points that are out of the image plane, STAFF analysis 472 

should be repeated after manually editing the skeleton, by placing a gap (using the paint tool) in 473 

the line drawing at the locations of the missed branch points.  474 

 475 

We uncovered a common issue in image acquisition that typically goes unnoticed but had a 476 

strong effect on measuring flow velocities using STAFF. In image acquisition, instability or “flicker” 477 

in the intensity of the epi-illumination lamp light source or from area lighting in the microscope 478 

room can occur. From either source, light/dark banding over time with the period of the flicker 479 

occurs at zero angle in the kymographs. If the zero angle peak is the major peak, then even if the 480 

angle produced by motion of red blood corpuscles through the vessel where flow speed is being 481 

measured is obvious to the human eye, the directionality plugin fits a curve to the zero peak and 482 

reports a value very near zero degrees, resulting in velocity measurements that are unfeasibly 483 



  

 
 

high. Even if the zero-angle peak is not the major peak, it will influence the directionality curve 484 

fit such that the velocity reported is shifted toward a higher value. To address this problem, STAFF 485 

provides a “Flicker correction” option that ignores peak angles occurring at 0°. This modification 486 

eliminated the effects of lamp flicker without affecting velocity quantifications. 487 

 488 

The main limitation of obtaining flow velocities using widefield microscopy is that image 489 

acquisition is restricted to thin preparations such as mesenteric vasculature, or the zebrafish 490 

intersegmental vessels or the superficial layers of organs such as liver or kidney that can be 491 

exteriorized.  492 

 493 

A significant advantage of using STAFF over existing methods of flow quantification is that it 494 

enables rapid and unbiased detection of spatial and temporal patterns of vascular flow. 495 

Collection and analysis of microvascular flow data using raster scanning systems are generally 496 

limited to measurements of single user selected capillaries at a time20–23. Methods exist to extract 497 

flow velocities across fields24–26, however none of these approaches support analysis across 498 

entire fields and all are labor intensive. Using STAFF, analysis of every capillary segment over time 499 

across the entire image field of a dataset with tens of thousands of images can be accomplished 500 

within a day. Manual analysis of even a single dataset of full-field vascular flow would take 501 

months to years. Thus, manual analysis is impractical even for characterization of normal flow 502 

and clearly does not permit comparison of multiple treatment groups.  503 

 504 

The ease of STAFF quantification of spatiotemporal patterning of vascular flow provides the 505 

opportunity for future users to link vascular morphological observations to effects on capillary 506 

flow velocity patterning. By defining the relationship between the vascular morphology measures 507 

of vessel diameters and network topology to flow velocity patterning we may then be able to 508 

predict flow patterns from vascular morphology. Similarly, correlating vascular flow patterning 509 

and vascular morphology with events such as timing, localization and extent of immune cell 510 

infiltration, tissue damage from toxicant exposure or disease, or status of intracellular transport, 511 

would not only give us a better understanding of flow patterning and cellular function in health 512 

and disease, but would also provide a framework for identifying particularly harmful 513 

pathophysiological scenarios.  514 
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Name of Material/ Equipment Company Catalog Number

#5 forceps Fine Science Tools 11251-20   

C57BL/6 mice Jackson Labs

Cannula Instech BTPE-10

CMOS camera Hamamatsu C11440-42U30

Coverslip-bottomed dish Electron Microscopy Sciences

Dissecting scissors Fine Science Tools

Fiji ImageJ Image analysis software

Fluorescein dextran Thermo Fisher, Invitrogen D1822

Gauze sponge Fisher 22-415-504

Heating pad Reptitherm RH-4

Heating pad Sunbeam 000732-500-000U

Inverted epifluorescence microscope Nikon

Isis Rodent electric shaver Braun Aesculap GT420

Isofluorane Abbott GmbH  PZN4831850

Luer stub adapter Fisher 14-826-19E

Micro scissors Castro Viejo

Microscope objective Nikon

Needle Fisher

Needle holder Olsen-Hegar

Objective heater BioScience Tools MTC-HLS-025

Rectal thermometer Braintree Scientific, INC TH-5A

STAFF macros

Suture string Harvard Bioscience 723288
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Comments/Description

Dumont #5 Inox Forceps   

male 9-12 weeks old

Polyethylene Tubing .011x.024in 

4.0LT Scientific CMOS

WillCo Dish glass bottom GWST5040   

https://fiji.sc/ ;  https://downloads.imagej.net/fiji/Life-Line/fiji-win64-20170530.zip

Dextran, Fluorescein, 70,000 MW, Anionic, Lysine Fixable

2x2 inch Dukal sterile gauze sponges

between mouse and stage

over mouse

Nikon TiE inverted microscope

Catheter adapter 

Plan Fluor 20x, NA 0.75 water immersion

30 Ga.x1/2"

Temperature controller with objective heater

Mouse Body Temperature monitoring

https://github.com/icbm-iupui/STAFF

silk black suture, 6-0, spool  
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Title of Article: 

Author(s):  

Item 1: The Author elects to have the Materials be made available (as described at 
http://www.jove.com/publish) via: 

 Standard Access  Open Access

Item 2: Please select one of the following items: 

 The Author is NOT a United States government employee.

 The Author is a United States government employee and the Materials were prepared in the
course of his or her duties as a United States government employee. 

 The Author is a United States government employee but the Materials were NOT prepared in the
course of his or her duties as a United States government employee. 

ARTICLE AND VIDEO LICENSE AGREEMENT 

1. Defined Terms. As used in this Article and Video
License Agreement, the following terms shall have the
following meanings: “Agreement” means this Article and
Video License Agreement; “Article” means the article
specified on the last page of this Agreement, including any
associated materials such as texts, figures, tables, artwork,
abstracts, or summaries contained therein; “Author”
means the author who is a signatory to this Agreement;
“Collective Work” means a work, such as a periodical issue,
anthology or encyclopedia, in which the Materials in their
entirety in unmodified form, along with a number of other
contributions, constituting separate and independent
works in themselves, are assembled into a collective whole; 
“CRC License” means the Creative Commons Attribution-
Non Commercial-No Derivs 3.0 Unported Agreement, the
terms and conditions of which can be found at:
http://creativecommons.org/licenses/by-nc-
nd/3.0/legalcode; “Derivative Work” means a work based
upon the Materials or upon the Materials and other pre-
existing works, such as a translation, musical arrangement,
dramatization, fictionalization, motion picture version,
sound recording, art reproduction, abridgment,
condensation, or any other form in which the Materials may 
be recast, transformed, or adapted; “Institution” means
the institution, listed on the last page of this Agreement, by
which the Author was employed at the time of the creation 
of the Materials; “JoVE” means MyJove Corporation, a
Massachusetts corporation and the publisher of The Journal 
of Visualized Experiments; “Materials” means the Article
and / or the Video; “Parties” means the Author and JoVE;
“Video” means any video(s) made by the Author, alone or
in conjunction with any other parties, or by JoVE or its
affiliates or agents, individually or in collaboration with the
Author or any other parties, incorporating all or any portion 

of the Article, and in which the Author may or may not 
appear. 
2. Background. The Author, who is the author of the 
Article, in order to ensure the dissemination and protection 
of the Article, desires to have the JoVE publish the Article
and create and transmit videos based on the Article. In
furtherance of such goals, the Parties desire to memorialize 
in this Agreement the respective rights of each Party in and 
to the Article and the Video.
3. Grant of Rights in Article. In consideration of JoVE 
agreeing to publish the Article, the Author hereby grants to 
JoVE, subject to Sections 4 and 7 below, the exclusive,
royalty-free, perpetual (for the full term of copyright in the
Article, including any extensions thereto) license (a) to
publish, reproduce, distribute, display and store the Article
in all forms, formats and media whether now known or
hereafter developed (including without limitation in print,
digital and electronic form) throughout the world, (b) to
translate the Article into other languages, create
adaptations, summaries or extracts of the Article or other
Derivative Works (including, without limitation, the Video)
or Collective Works based on all or any portion of the Article 
and exercise all of the rights set forth in (a) above in such
translations, adaptations, summaries, extracts, Derivative
Works or Collective Works and(c) to license others to do any 
or all of the above. The foregoing rights may be exercised in 
all media and formats, whether now known or hereafter
devised, and include the right to make such modifications
as are technically necessary to exercise the rights in other
media and formats. If the “Open Access” box has been
checked in Item 1 above, JoVE and the Author hereby grant
to the public all such rights in the Article as provided in, but
subject to all limitations and requirements set forth in, the
CRC License.
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4. Retention of Rights in Article. Notwithstanding 
the exclusive license granted to JoVE in Section 3 above, the 
Author shall, with respect to the Article, retain the non-
exclusive right to use all or part of the Article for the non-
commercial purpose of giving lectures, presentations or
teaching classes, and to post a copy of the Article on the
Institution’s website or the Author’s personal website, in
each case provided that a link to the Article on the JoVE
website is provided and notice of JoVE’s copyright in the
Article is included. All non-copyright intellectual property
rights in and to the Article, such as patent rights, shall
remain with the Author.
5. Grant of Rights in Video – Standard Access. This
Section 5 applies if the “Standard Access” box has been
checked in Item 1 above or if no box has been checked in
Item 1 above. In consideration of JoVE agreeing to produce,
display or otherwise assist with the Video, the Author
hereby acknowledges and agrees that, Subject to Section 7
below, JoVE is and shall be the sole and exclusive owner of
all rights of any nature, including, without limitation, all
copyrights, in and to the Video. To the extent that, by law,
the Author is deemed, now or at any time in the future, to
have any rights of any nature in or to the Video, the Author
hereby disclaims all such rights and transfers all such rights
to JoVE. 
6. Grant of Rights in Video – Open Access. This
Section 6 applies only if the “Open Access” box has been
checked in Item 1 above. In consideration of JoVE agreeing
to produce, display or otherwise assist with the Video, the
Author hereby grants to JoVE, subject to Section 7 below, 
the exclusive, royalty-free, perpetual (for the full term of
copyright in the Article, including any extensions thereto)
license (a) to publish, reproduce, distribute, display and
store the Video in all forms, formats and media whether
now known or hereafter developed (including without
limitation in print, digital and electronic form) throughout
the world, (b) to translate the Video into other languages,
create adaptations, summaries or extracts of the Video or
other Derivative Works or Collective Works based on all or
any portion of the Video and exercise all of the rights set
forth in (a) above in such translations, adaptations,
summaries, extracts, Derivative Works or Collective Works
and (c) to license others to do any or all of the above. The 
foregoing rights may be exercised in all media and formats,
whether now known or hereafter devised, and include the
right to make such modifications as are technically
necessary to exercise the rights in other media and formats. 
For any Video to which this Section 6 is applicable, JoVE and
the Author hereby grant to the public all such rights in the
Video as provided in, but subject to all limitations and
requirements set forth in, the CRC License.
7. Government Employees. If the Author is a United
States government employee and the Article was prepared
in the course of his or her duties as a United States
government employee, as indicated in Item 2 above, and
any of the licenses or grants granted by the Author
hereunder exceed the scope of the 17 U.S.C. 403, then the
rights granted hereunder shall be limited to the maximum

rights permitted under such statute. In such case, all 
provisions contained herein that are not in conflict with 
such statute shall remain in full force and effect, and all 
provisions contained herein that do so conflict shall be 
deemed to be amended so as to provide to JoVE the 
maximum rights permissible within such statute. 
8. Protection of the Work. The Author(s) authorize
JoVE to take steps in the Author(s) name and on their behalf
if JoVE believes some third party could be infringing or
might infringe the copyright of either the Author’s Article
and/or Video.
9. Likeness, Privacy, Personality. The Author hereby
grants JoVE the right to use the Author’s name, voice,
likeness, picture, photograph, image, biography and
performance in any way, commercial or otherwise, in
connection with the Materials and the sale, promotion and 
distribution thereof. The Author hereby waives any and all
rights he or she may have, relating to his or her appearance 
in the Video or otherwise relating to the Materials, under
all applicable privacy, likeness, personality or similar laws.
10. Author Warranties. The Author represents and
warrants that the Article is original, that it has not been
published, that the copyright interest is owned by the
Author (or, if more than one author is listed at the beginning 
of this Agreement, by such authors collectively) and has not 
been assigned, licensed, or otherwise transferred to any
other party. The Author represents and warrants that the
author(s) listed at the top of this Agreement are the only
authors of the Materials. If more than one author is listed
at the top of this Agreement and if any such author has not
entered into a separate Article and Video License
Agreement with JoVE relating to the Materials, the Author
represents and warrants that the Author has been
authorized by each of the other such authors to execute this 
Agreement on his or her behalf and to bind him or her with 
respect to the terms of this Agreement as if each of them
had been a party hereto as an Author. The Author warrants 
that the use, reproduction, distribution, public or private
performance or display, and/or modification of all or any
portion of the Materials does not and will not violate,
infringe and/or misappropriate the patent, trademark,
intellectual property or other rights of any third party. The
Author represents and warrants that it has and will
continue to comply with all government, institutional and
other regulations, including, without limitation all
institutional, laboratory, hospital, ethical, human and
animal treatment, privacy, and all other rules, regulations,
laws, procedures or guidelines, applicable to the Materials,
and that all research involving human and animal subjects
has been approved by the Author's relevant institutional
review board.
11. JoVE Discretion. If the Author requests the
assistance of JoVE in producing the Video in the Author’s
facility, the Author shall ensure that the presence of JoVE
employees, agents or independent contractors is in
accordance with the relevant regulations of the Author's
institution. If more than one author is listed at the
beginning of this Agreement, JoVE may, in its sole
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discretion, elect not take any action with respect to the 
Article until such time as it has received complete, executed 
Article and Video License Agreements from each such 
author. JoVE reserves the right, in its absolute and sole 
discretion and without giving any reason therefore, to 
accept or decline any work submitted to JoVE. JoVE and its 
employees, agents and independent contractors shall have 
full, unfettered access to the facilities of the Author or of 
the Author’s institution as necessary to make the Video, 
whether actually published or not. JoVE has sole discretion 
as to the method of making and publishing the Materials, 
including, without limitation, to all decisions regarding 
editing, lighting, filming, timing of publication, if any, 
length, quality, content and the like.  
12. Indemnification. The Author agrees to indemnify
JoVE and/or its successors and assigns from and against any 
and all claims, costs, and expenses, including attorney’s
fees, arising out of any breach of any warranty or other
representations contained herein. The Author further
agrees to indemnify and hold harmless JoVE from and
against any and all claims, costs, and expenses, including
attorney’s fees, resulting from the breach by the Author of
any representation or warranty contained herein or from
allegations or instances of violation of intellectual property
rights, damage to the Author’s or the Author’s institution’s
facilities, fraud, libel, defamation, research, equipment,
experiments, property damage, personal injury, violations
of institutional, laboratory, hospital, ethical, human and
animal treatment, privacy or other rules, regulations, laws,
procedures or guidelines, liabilities and other losses or
damages related in any way to the submission of work to
JoVE, making of videos by JoVE, or publication in JoVE or
elsewhere by JoVE. The Author shall be responsible for, and 
shall hold JoVE harmless from, damages caused by lack of
sterilization, lack of cleanliness or by contamination due to

the making of a video by JoVE its employees, agents or 
independent contractors. All sterilization, cleanliness or 
decontamination procedures shall be solely the 
responsibility of the Author and shall be undertaken at the 
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August 30, 2019 

Alisha DSouza, Ph.D. 

JoVE Senior Review Editor 

 

Dear Dr. Dsouza, 

Below are our responses to the editorial and reviewer comments for our manuscript, JoVE60493 

"Spatial temporal analysis of fieldwise flow in microvasculature".  

We thank the editor and the reviewers for their helpful comments. They have improved the 

manuscript. 

Sincerely yours,  

 
Kenneth Dunn, Ph.D.  

Professor of Medicine and Biochemistry 

Director of the Indiana Center for Biological Microscopy 

 

Editorial comments: 

 

• Please take this opportunity to thoroughly proofread the manuscript to ensure that there are no 

spelling or grammatical errors. 

 

• Textual Overlap: Significant portions show significant overlap with previously published work. 

Please re-write both abstracts to avoid this overlap. 

Both Abstracts have been rewritten.  

 

• Introduction: 

1) Please expand your Introduction to include the following: The advantages over alternative 

techniques with applicable references to previous studies; Description of the context of the 

technique in the wider body of literature; Information that can help readers to determine if the 

method is appropriate for their application. 

Text outlining advantages of the method, context within existing literature and when the 
method is appropriate has been clarified and added. 

2) Please do not highlight contents in this section. 

Highlighting in introduction has been removed.  

3) Several statements are lacking appropriate literature references. 

Appropriate literature references have been added.  

 

• Protocol Language: Please ensure that all text in the protocol section is written in the imperative 

voice/tense as if you are telling someone how to do the technique (i.e. “Do this”, “Measure that” 

etc.) Any text that cannot be written in the imperative tense may be added as a “Note”, however, 

Rebuttal Letter Click here to access/download;Rebuttal
Letter;Response_to_Editorial_and_Reviewer_comments.docx

http://www.jove.com/
https://www.editorialmanager.com/jove/download.aspx?id=1104627&guid=3d38c143-b273-436c-a54b-32f73fb8c775&scheme=1
https://www.editorialmanager.com/jove/download.aspx?id=1104627&guid=3d38c143-b273-436c-a54b-32f73fb8c775&scheme=1


notes should be used sparingly and actions should be described in the imperative tense wherever 

possible. 

 Protocol language was changed to the imperative where possible and use of notes was 
reduced.  

 

1) For example, the opening paragraph should be trimmed and made into a note or merged with 

the introduction. 

Opening paragraph was shortened and merged with the Introduction.  

2) Steps 6.1.3-6.1.7,6.2.3, 6.3.4., 6.4.4., 6.4.5 need to be rewritten in the imperative voice. 

Indicated steps were rewritten in the imperative. Some were also merged.  

 

• Protocol Detail: Please note that your protocol will be used to generate the script for the video, 

and must contain everything that you would like shown in the video. Please add more specific 

details (e.g. button clicks for software actions, numerical values for settings, etc) to your protocol 

steps. There should be enough detail in each step to supplement the actions seen in the video so 

that viewers can easily replicate the protocol. 

 

1) 1.2: What is the oxygen flow rate? 

2) 1.3: mention how you test for depth of anesthesia, e.g., toe pinch? 

3) 1.4: Mention surgical tools used. 

4) 1.5: Via tail vein? Mention needle gauge. 

5) 2.1: Mention excitation and emission filter wavelengths. 

Requested information has been added to the protocol.  

6) 6.1.3-6.1.7, 6.2.2. : Unclear what actions are to be performed here. Please mention button clicks 

and menu selections explicitly. These steps cannot be filed as written. 

Indicated steps have been rewritten for clarification. Some were merged.  

 

• Protocol Numbering: Please adjust the numbering of your protocol section to follow JoVE’s 

instructions for authors, 1. should be followed by 1.1. and then 1.1.1. if necessary and all steps 

should be lined up at the left margin with no indentations. There must also be a one-line space 

between each protocol step. 

 Numbering has been corrected, indentations have been removed and spaces between steps 
have been added.  

 

• Protocol Highlight: Please highlight ~2.5 pages or less of text (which includes headings and 

spaces) in yellow, to identify which steps should be visualized to tell the most cohesive story 

of your protocol steps. Please see JoVE’s instructions for authors for more clarification. Remember 

that the non-highlighted protocol steps will remain in the manuscript and therefore will still be 

available to the reader. 

 The amount of text highlighted has been reduced to include only those steps needed to 
visualize the sections “Define the vascular network using TrackEM2 in FIJI” and “Quantifying 
vascular flow using STAFF”.  

 

1) The highlighting must include all relevant details that are required to perform the 

step. For example, if step 2.5 is highlighted for filming and the details of how to perform the step 

are given in steps 2.5.1 and 2.5.2, then the sub-steps where the details are provided must be 

included in the highlighting. 



2) The highlighted steps should form a cohesive narrative, that is, there must be a logical flow from 

one highlighted step to the next. 

3) Please highlight complete sentences (not parts of sentences). Include sub-headings and spaces 

when calculating the final highlighted length. 

4) Notes cannot be filmed and should be excluded from highlighting. 

 Highlighting has been edited.  
 

• Discussion: JoVE articles are focused on the methods and the protocol, thus the discussion should 

be similarly focused. Please ensure that the discussion covers the following in detail and in 

paragraph form (3-6 paragraphs): 1) modifications and troubleshooting, 2) limitations of the 

technique, 3) significance with respect to existing methods, 4) future applications and 5) critical 

steps within the protocol. 

 The discussion covers the requested topics. The discussion has been edited for clarity.   

 

• Figures: A scale bar on fig 1 will be useful 

 A scale bar has been added to Figure 1.  
 

• Commercial Language: JoVE is unable to publish manuscripts containing commercial sounding 

language, including trademark or registered trademark symbols (TM/R) and the mention of 

company brand names before an instrument or reagent. Examples of commercial sounding 

language in your manuscript are Jackson Labs, Willco, (GWST5040, Warner Instruments, 

Reptitherm, Bioscience Tools, Sunbeam, Nikon Plan Fluor, Hamamatsu Orca Flash 4.0, 

1) Please use MS Word’s find function (Ctrl+F), to locate and replace all commercial sounding 

language in your manuscript with generic names that are not company-specific. All commercial 

products should be sufficiently referenced in the table of materials/reagents. You may use the 

generic term followed by “(see table of materials)” to draw the readers’ attention to specific 

commercial names. 

 Commercial names have been removed from the body of the manuscript.  

 

• Please define all abbreviations at first use. 

Abbreviations have been defined at first use.  

 

• If your figures and tables are original and not published previously or you have already obtained 

figure permissions, please ignore this comment. If you are re-using figures from a previous 

publication, you must obtain explicit permission to re-use the figure from the previous publisher 

(this can be in the form of a letter from an editor or a link to the editorial policies that allows you to 

re-publish the figure). Please upload the text of the re-print permission (may be copied and pasted 

from an email/website) as a Word document to the Editorial Manager site in the "Supplemental 

files (as requested by JoVE)" section. Please also cite the figure appropriately in the figure legend, 

i.e. "This figure has been modified from [citation]." 

Figures and tables are original and not published previously.  

 

Reviewers' comments: 

Reviewer #1:  

Manuscript Summary: 

Clendenon et al. present a manuscript to describe the use of a new tool called STAFF (Spatial 

temporal analysis of fieldwise flow) for the analysis of microcirculatory flow using epifluorescence 



based intravital microscopy. The authors present evidence of feasibility using hepatic sinusoidal 

microcirculatory beds of rodents under anesthesia. 

 

General Comments: 

The authors present a clear manuscript of importance to the field. Indeed, the authors should be 

commended for undertaking this important, yet very difficult task. This is a very significant 

contribution to the literature and to the tools researchers will have to analyze microcirculatory 

videos. As the authors well state, to date manual analysis continues to be required given that no 

reliable software exists to analyze these type of videos. Below, some I enumerate a few comments 

and suggestions to the authors. 

 

Major Concerns: 

1. The series of steps to set up TrakEM2 project (under 3. Define the vascular network using 

TrakEM2 in FIJI) are clear, however, either a video demonstrating how to set this up or a pdf as 

supplementary material providing screen shots of the steps will help clarify for the users. I am 

familiar with FIJI and did it myself, and still took me a while to get it done. 

 We appreciate your effort and agree with your comment. TrakEM2 is not initially intuitive to 
use even for long time users of FIJI. Therefore we plan to include “Define the vascular network 
using TrakEM2 in FIJI” as part of the JoVE filmed video.  

 

2. In the section of 'Intravital microscopy' in step 2.4 the authors state: 'save time series file(s) as 

native camera/microscope format or as sequence of tif files'. Will any native camera format will do? 

We have camera format coming from a Leica instrument, and this file type was not recognized 

using these steps. Files had to be converted to tiff to be able to use it. Can the authors 

discuss/clarify this further? 

 We have edited the text to reflect that while most native camera formats are readable by FIJI 
using Bio-Formats (https://www.openmicroscopy.org/bio-formats/), not all are and in those 
cases a sequence of tif images can be used.  

 

3. In step 3.6, what does 'setup area list selection in TrakEM2' mean? In the toolset in TrakEM2 

there are several 'area selection tools' available. Should users use a squared area, how broad 

should the selection be? Please see comment 2 which may offer an easy alternative to clarify these 

steps. 

 We have clarified the text and we plan for these steps to be included in the JoVE video.  

  

4. How accurate is the skeletonization of the vascular network using only one image to represent 

the entire time series? Is there a maximal permissible 'movement' of the image that would preclude 

flow analysis and make the skeletonization inaccurate? Along those same lines, what is the 

recommended duration of video clips to analyze? 

  The accuracy of one image to represent the entire time series depends on the stability 
of that individual time series. The duration of a video clip to analyze also depends on the 
stability of that individual time series. Additionally, duration of video clip acquisition is limited 
by the time period that the animal can be maintained on the microscope stage. For imaging the 
exteriorized liver we limit this time period to under two hours because this is a period during 
which the animal’s temperature and respiration can be reliably maintained. Keeping an organ 
preparation stable on the microscope stage is highly operator dependent and improves with 

https://www.openmicroscopy.org/bio-formats/


experience. We have used STAFF to analyze videos of up to 60,000 frames representing 10 
minutes.  

  We routinely assess movement but have not formally described our assessment.  We 
recognize that this is critical for the end user. Excluding the short periods of motion during 
respiration, as long as the skeletonization still overlies any part of the capillary that the red 
blood cells pass through (e.g. not the edge and not outside the capillary) then STAFF analysis 
works. This can be visually assessed by overlaying the skeleton on the movie and playing the 
movie.  Step 6.2.4. now includes how to overlay the skeleton (in the form of labeled segments) 
on the movie and assess stability.  

 

5. Can the authors comment on how this analytic tool handles and reports the normal time-

dependent variability in velocity within individual microvessels? Furthermore, there are vessels that 

will have intermittent flow particularly if exposed to pathologic conditions like infections. How does 

the software analyze and report these variations in flow in time? 

  We generally select time intervals to encompass a single period between respirations 
(Section 6.3). For each time period, for each segment a velocity is calculated and the data is output 
as a spreadsheet. Velocity over time can be read across the velocity spreadsheet for each individual 
segment. Indeed, changes in flow and intermittent flow are observed over time within individual 
segments.   

  What is not captured are the changes in velocity that occur within a single time period. If a 
change in velocity occurs within a time period, the velocity that occurs over most of that time 
period is reported. This is because the Directionality plugin detects the directional banding within 
each kymograph, then plots all the angles by frequency and fits a curve to the highest peak in that 
plot and uses the value at the peak of that fitted curve to calculate distance/time for that time 
interval. Calculated velocity from such segments can appear to vary between two values over time 
and have poor goodness of fit values. At this time we think that reporting the predominant velocity 
that occurs within each time period is sufficient, given the vast increase overall in capillary flow data 
that we can now collect, analyze and visualize using STAFF.  

 

6. In relation to the Kymographs generated by this analytical tool (Figure 2B), can the authors 

specify how much time are these Kymographs constructed in? In other words, what is 't' in figure 

2B? Is this variable? Does it matter? The reason why this is important goes back to comment No. 7. 

 We selected the period between respirations as the unit of time for our analysis. The overall 
time period between respirations in our anesthetized mice varied between one and two 
seconds. It is variable insomuch as the period between respirations is slightly variable. In 
response to does it matter? Early in our development of STAFF we briefly examined dividing 
each respiratory period into two time periods and/or selecting a standard amount of time from 
each respiratory period and the results overall did not differ.   

 

7. Can the authors clarify in the methods how is velocity calculated from these kymographs? Is the 

result reported an average of the time-distance relationship in time? 

 The Directionality plugin detects the directional banding within each kymograph, then plots all the 
angles by frequency and fits a curve to the highest peak in that plot and uses the value at the peak 
of that fitted curve to calculate distance/time for that time interval. We have clarified this in the 
manuscript.  

 

8. Can the authors comment on whether this tool can be used with videos collected at lower speed 

(i.e. < 100 fps). Can this still tool be useful to assess changes between different biologic conditions 

or in time? 



  “The product of shortest segment length and frames per second gives the max flow 
speed that can theoretically be measured. The highest capillary flow speeds reported in 
literature are around 2000 microns/sec2. In liver we observed capillary flow speeds generally 
averaged around 300 microns/sec and rarely exceeded 1000 microns/sec.”  

  Our image capture at 100 fps with the minimum vascular segment length set to 15 
microns allows capture of flow speeds up to 1500 microns/second and at a minimum segment 
length of 20 microns allows capture of flow speeds up to 2000 microns/second. If we were to 
capture at 30 fps with minimum segment lengths of 15 and 20 microns it would allow capture 
of flow speeds up to 450 and 600 microns/second respectively. If you can be certain that your 
velocity distribution mostly falls within some lower range then it could work. You could assess 
this by looking at a histogram of your velocity values.  

  Yes, this tool can be used to assess changes in flow patterning and velocity between 
different biological conditions over time. In development we used this method to look at 
differences in blood flow in livers of mice treated with acetaminophen compared to untreated 
mice. We found profound changes in the spatial patterning of flow velocity and an increase in 
proportion of vascular segments with little to no flow while the average flow velocity was 
nearly unchanged. This could be applied similarly to other drug treatments or disease 
conditions.  

 

9. Along the same lines, can this tool be used with other acquisition techniques other than 

epifluorescence (i.e. 2P-microscopy?).  

 

          The limitation to using confocal or multiphoton microscopy to generate image 

sequences for fullfield flow analysis is scan speed. Scan speed for a single 512x512 image in 

these systems is typically 1 second. Scan speed can be increased by decreasing the x,y 

dimensions of the image down as far as to a single line scan to achieve the speed, but then 

you have a single vessel segment or at best a small group of segments rather than most of a 

cross section of a lobule. Scan speed in some raster scanning systems can also be increased 

by using a resonant scanner, but the images produced tend to be noisy enough to cause 

difficulty with detection of the directional banding in kymographs.  

           To see if we could apply STAFF to other imaging modalities we have tested the 

approach using an old dataset of diffraction interference contrast (DIC) images of blood 

flow in the forming intersegmental vessels in zebrafish embryos. The contrast was sufficient 

to generate kymographs and calculate flow velocities. These images had however been 

collected at low frames per second so we did not capture data from segments with higher 

flow speeds.  

 

Minor Concerns: 

1. What type of video files can this software analyze? 

 Any video file that can be opened using Bio-Formats within FIJI ImageJ can be opened then be 
saved as tif or AVI and analyzed using STAFF. We have clarified this in the manuscript.  

 

2. In that same section, in step 3.4 although its intuitive, could specify which image should be 

imported. 

 We have specified the image that should be imported.  

 



 

Reviewer #2:  

Manuscript Summary: 

This manuscript from the Dunn lab describes a new macro for FIJI, called STAFF, that enables the 

analysis of data on microvascular flow acquired by intravtial microscopy. This method is very well-

written and easy to follow by a broad audience. 

I do not have any concern 

          

 

Reviewer #3: 

Manuscript Summary: 

This manuscript demonstrates a computational pipeline for quantifying blood velocity for a whole 

field of vessels using high frame rate widefield microscopy and a novel software called STAFF. It 

should be of interest for those looking to automate quantitative analysis of blood flow. 

 

Major Concerns: 

No major concerns 

 

Minor Concerns: 

- The underlying principle for calculating flow is straightforward but could be better explained. The 

manuscript states "The underlying principle used by STAFF to quantify rates of microvascular flow is 

that the velocity of red blood cells in capillaries can be quantified from the angle formed by their 

shadows as they pass through capillaries labeled with a bulk fluorescent probe". Angle here refers 

to a kymograph with one axis being time and the other parallel to the direction of flow so slope is 

naturally unit length/time. Better just to say, it calculates the slope on a kymograph as defined 

above, slope is in the right units whereas angle is not. 

-Further use of the word "shadow" is confusing in that context as it sounds like the authors are 

measuring the spatial angle of the shadow cast by an object, as with a sundial. Can simply say, that 

some contrast must be provided to visualize the blood. This could be positive staining of the blood 

cells or a negative stain by labeling the plasma. It of course is physically not a shadow (something 

blocking light) but rather the lack of fluorescent label within the blood cells. 

 We thank you for these suggestions for alternate and clearer phrasing. We have made the 
suggested changes in the manuscript. (last paragraph of the Introduction) 

 

-The authors use 1024x1024 16-bit images as example. My guess is that this is way overkill for xy 

resolution and bit depth. Can the authors give more typical guidance. The software presumably 

accepts images of different resolutions and bit depths. 

 We have tested the software with images of 1024x1024, 800x800, and 512x512 pixels at 16, 12 
and 8-bit depth. There are no explicit size limits within STAFF. We have added this information 
to the manuscript.  

 

-The authors note that care must be taken to avoid artifacts caused by respiration which would 

shift the vessel outside the ROI. Presumably such artifacts could be automatically flagged by the 

software. Otherwise, is there a good way for the user to catch such errors? 

 In the second half of our answer to Reviewer #1’s comment 4 we describe our approach to 

verifying the stability of an image sequence over time.  
 


