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SUMMARY: 19 
The described pipeline is designed for the segmentation of electron microscopy datasets larger 20 
than gigabytes, to extract whole-cell morphologies. Once the cells are reconstructed in 3D, 21 
customized software designed around individual needs can be used to perform a qualitative and 22 
quantitative analysis directly in 3D, also using virtual reality to overcome view occlusion. 23 
 24 
ABSTRACT: 25 
Serial sectioning and subsequent high-resolution imaging of biological tissue using electron 26 
microscopy (EM) allow for the segmentation and reconstruction of high-resolution imaged stacks 27 
to reveal ultrastructural patterns that could not be resolved using 2D images. Indeed, the latter 28 
might lead to a misinterpretation of morphologies, like in the case of mitochondria; the use of 29 
3D models is, therefore, more and more common and applied to the formulation of morphology-30 
based functional hypotheses. To date, the use of 3D models generated from light or electron 31 
image stacks makes qualitative, visual assessments, as well as quantification, more convenient 32 
to be performed directly in 3D. As these models are often extremely complex, a virtual reality 33 
environment is also important to be set up to overcome occlusion and to take full advantage of 34 
the 3D structure. Here, a step-by-step guide from image segmentation to reconstruction and 35 
analysis is described in detail. 36 
 37 
INTRODUCTION: 38 
The first proposed model for an electron microscopy setup allowing automated serial section and 39 
imaging dates back to 19811; the diffusion of such automated, improved setups to image large 40 
samples using EM increased in the last ten years2,3, and works showcasing impressive dense 41 
reconstructions or full morphologies immediately followed4–10. 42 
 43 
The production of large datasets came with the need for improved pipelines for image 44 
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segmentation. Software tools for the manual segmentation of serial sections, such as 45 
RECONSTRUCT and TrakEM211,12, were designed for transmission electron microscopy (TEM). As 46 
the whole process can be extremely time-consuming, these tools are not appropriate when 47 
dealing with the thousands of serial micrographs that can be automatically generated with state-48 
of-the-art, automated EM serial section techniques (3DEM), such as block-face scanning electron 49 
microscopy (SBEM)3 or focused ion beam-scanning electron microscopy (FIB-SEM)2. For this 50 
reason, scientists put efforts into developing semi-automated tools, as well as fully automated 51 
tools, to improve segmentation efficiency. Fully automated tools, based on machine learning13 52 
or state-of-the-art, untrained pixel classification algorithms14, are being improved to be used by 53 
a larger community; nevertheless, segmentation is still far from being fully reliable, and many 54 
works are still based on manual labor, which is inefficient in terms of segmentation time but still 55 
provides complete reliability. Semi-automated tools, such as ilastik15, represent a better 56 
compromise, as they provide an immediate readout for the segmentation that can be corrected 57 
to some extent, although it does not provide a real proofreading framework, and can be 58 
integrated using TrakEM2 in parallel16. 59 
 60 
Large-scale segmentation is, to date, mostly limited to connectomics; therefore, computer 61 
scientists are most interested in providing frameworks for integrated visualizations of large, 62 
annotated datasets and analyze connectivity patterns inferred by the presence of synaptic 63 
contacts17,18. Nevertheless, accurate 3D reconstructions can be used for quantitative 64 
morphometric analyses, rather than qualitative assessments of the 3D structures. Tools like 65 
NeuroMorph19,20 and glycogen analysis10 have been developed to take measurements on the 3D 66 
reconstructions for lengths, surface areas, and volumes, and on the distribution of cloud points, 67 
completely discarding the original EM stack8,10. Astrocytes represent an interesting case study, 68 
because the lack of visual clues or repetitive structural patterns give investigators a hint about 69 
the function of individual structural units and consequent lack of an adequate ontology of 70 
astrocytic processes21, make it challenging to design analytical tools. One recent attempt was 71 
Abstractocyte22, which allows a visual exploration of astrocytic processes and the inference of 72 
qualitative relationships between astrocytic processes and neurites. 73 
 74 
Nevertheless, the convenience of imaging sectioned tissue under EM comes from the fact that 75 
the amount of information hidden in intact brain samples is enormous and interpreting single 76 
section images can overcome this issue. The density of structures in the brain is so high that 3D 77 
reconstructions of even a few objects visible at once would make it impossible to distinguish 78 
them visually. For this reason, we recently proposed the use of virtual reality (VR) as an improved 79 
method to observe complex structures. We focus on astrocytes23 to overcome occlusion (which 80 
is the blocking of the visibility of an object of interest with a second one, in a 3D space) and ease 81 
qualitative assessments of the reconstructions, including proofreading, as well as quantifications 82 
of features using count of points in space. We recently combined VR visual exploration with the 83 
use of GLAM (glycogen-derived lactate absorption model), a technique to visualize a map of 84 
lactate shuttle probability of neurites, by considering glycogen granules as light-emitting 85 
bodies23; in particular, we used VR to quantify the light peaks produced by GLAM.  86 
 87 
PROTOCOL: 88 



  

1. Image processing using Fiji 89 
 90 
1.1. Open the image stack by dragging and dropping the native file from the microscope 91 
containing the stack, or by dragging and dropping the folder containing the whole image stack 92 
into the software window. 93 
 94 
NOTE: Fiji is able to automatically recognize all the standard image formats, such as .jpg, .tif, and 95 
.png, as well as proprietary file formats from microscope providers. While the following protocol 96 
has been optimized for image stacks from 3DEM, these steps might be used for light microscopy 97 
datasets as well. 98 
 99 
1.2. Once the stack is opened, go to Image > Properties to make sure the voxel size has been 100 
read from the metadata. If not, it can be manually entered. 101 
 102 
1.3. Make sure to transform the image into 8-bit. Click on Image > Type and select 8-bit. 103 
 104 
1.4. If the original stack was in different sequential files/folders, use Concatenate to merge them 105 
in a single stack by selecting Image > Stacks > Tools > Concatenate. 106 
 107 
1.5. Save the stack by selecting File > Save as. It will be saved as a single .tif file and can be used 108 
as a backup and for further processing. 109 
 110 
1.6. If the original stack is acquired as different tiles, apply stitching within TrakEM2. 111 
 112 
1.6.1. Create a new TrakEM2 project using New > TrakEM2 (blank). 113 
 114 
1.6.2. Within the viewport graphical user interface (GUI), import the stacks by clicking the right 115 
mouse button > Import > Import stack, and import all the tiles opened in the Fiji main GUI. Make 116 
sure to resize the canvas size to fit the entire stack by right-clicking > Display > Resize 117 
Canvas/Layer Set, and choose the y/x pixel size depending on the final size of the montage.  118 

 119 
NOTE: For instance, if the montage should be finalized using four tiles of 4,096 x 4,096 pixels, the 120 
canvas size should be at least 8,192 x 8,192 pixels. Consider make it slightly bigger, and crop it 121 
later. 122 
 123 
1.6.3. Superimpose the common portions of individual tiles by dragging and dropping them on 124 
the layer set. Use the top left slider to modify the transparency to help with the superimposition. 125 
 126 
1.6.4. Montage and realign the stacks by clicking the right mouse button > Align, and then select 127 
one of the options (see note below).  128 

 129 
NOTE: SBEM or FIB-SEM are usually already well aligned, but minor misalignments might occur. 130 
Align layers is the automated pipeline for z alignment; Montage multiple layers is the automated 131 
pipeline for aligning tiles on each z stack, for the entire volume; Align multilayer mosaic combines 132 



  

the two previous options. This operation is time-consuming and subject to the random-access 133 
memory (RAM) of the machine. Consider using a high-end computer and let it run for hours/days, 134 
depending on the size of the stack. 135 
 136 
1.6.5. Finally, export the image stacks and save them by using mouse right click > Make flat 137 
image, and then make sure to select the first to the last image in the drop-down menus Start and 138 
End. 139 
 140 
1.6.6. Using TrakEM2 embedded functions, segment structures of interest if needed.  141 
 142 
1.6.6.1. In the TrakEM2’s GUI, right-click on Anything under the Template window and select 143 
Add new child > Area_list. 144 
 145 
1.6.6.2. Drag and drop Anything on top of the folder under Project Objects, and one Anything 146 
will appear there. 147 
 148 
1.6.6.3. Drag and drop the Area list from the template to the Anything located under Project 149 
Objects. 150 
 151 
1.6.6.4. On the image stack viewport, select the Z space with the cursor. The area list will appear, 152 
with a unique ID number. Select the brush tool on top (bottom right) and use the mouse to 153 
segment a structure by filling its cytosol, over the whole z stack. 154 
 155 
1.6.6.5. Export the segmented mask to be used in ilastik as seed for carving by right-clicking either 156 
on the Area list object on the Z space list, or on the mask in the viewport, and select Export > 157 
Area lists as labels (tif). 158 
 159 
1.7. Depending on the resolution needed for further reconstructions, if possible, reduce the pixel 160 
size of the image stack by downsampling, considering the memory requirements of the software 161 
that will be used for segmentation and reconstruction. Use Image > Adjust > Size. 162 
 163 
NOTE: ilastik handles stacks of up to 500 pixels on xy well. Also, downsampling will reduce the 164 
resolution of the stack; therefore, take into account the minimum size at which the object still 165 
appears recognizable and, thus, can be segmented.  166 
 167 
1.8. To enhance contrast and help the segmentation, the Unsharp mask filter can be applied to 168 
make membranes crisper. Use Process > Filter > Unsharp mask. 169 
 170 
1.9. Export the image stack as single images for further processing in segmentation software, 171 
(e.g., ilastik), using File > Save as... > Image sequence and choose .tif format. 172 
 173 
2. Segmentation (semi-automated) and reconstruction using ilastik 1.3.2 174 
 175 
2.1. In the main ilastik GUI, select the Carving module. 176 



  

 177 
2.2. Load the image stack using Add New > Add a single 3D/4D volume from sequence. 178 
 179 
2.3. Select Whole directory and choose the folder containing the image stack saved as single 180 
files. At the bottom of the new window, where options for loading the images are present, make 181 
sure to keep Z selected. 182 
 183 
2.4. For the following steps, all operations and buttons can be found on the left side of the main 184 
software GUI. Under the Preprocessing tab, use the standard options already checked. Use bright 185 
lines (ridge filters) and keep the filter scale at 1.600. This parameter can be modified afterward. 186 
 187 
2.5. Once the preprocessing is finished, select the next page in the drop-down menu of the 188 
Labeling module. One Object and one Background are present by default.  189 
 190 
2.6. Select the object seed by clicking on it, and draw a line on top of the structure of interest; 191 
then, select the background seed and draw one or multiple lines outside the object to be 192 
reconstructed. Then, click on Segment, and wait.  193 

 194 
NOTE: Depending on the power of the computer and the size of the stack, segmentation could 195 
take from a few seconds to hours. Once it's done, a semitransparent mask highlighting the 196 
segmentation should appear on top of the segmented structure. 197 
 198 
2.6.1. Scroll through the stack to check on the segmentation. The segmentation might not be 199 
accurate and not follow the structure of interest accurately or spill out from it. Correct any 200 
spillover by placing a background seed on the spilled segmentation, and add an object seed over 201 
the nonreconstructed segment of the object of interest. 202 
 203 
2.6.2. If the segmentation is still not correct, try to modify with the Bias parameter, which will 204 
increase or decrease the amount of uncertain classified pixels as accepted. Its value is 0.95 by 205 
default; decrease it to limit any spillover (usually to not less than 0.9) or increase if the 206 
segmentation is too conservative (up to 1). 207 
 208 
2.6.3. Another possibility is to go back to step 2.4 (by clicking on Preprocessing) and to modify 209 
the size of the filter; increasing the value (e.g., to 2) will minimize the salt-and-pepper noise-like 210 
effects but will also make membranes more blurred and smaller details harder to detect. This 211 
might limit spillover. 212 
 213 
2.7. Reiterate as much as needed, as long as all desired objects have been segmented. Once an 214 
object is finished, click on Save current object, below Segment. Two new seeds will appear, to 215 
start the segmentation of a new object. 216 
 217 
2.8. Extract surface meshes right away as .obj files by clicking on Export all meshes. 218 
 219 
2.9. If further proofreading is needed, segmentation can be extracted as binary masks. Select the 220 



  

mask to export it by clicking Browse objects; then, right-click on Segmentation > Export and, 221 
then, under Output file info, select tif sequence as format.  222 
 223 
3. Proofreading/segmentation (manual) in TrakEM2 (Fiji) 224 
 225 
3.1. Load the image stack and create a new TrekEM2 project as per step 1.6.1. 226 
 227 
3.2. Import the masks that need proofreading using the option Import labels as arealists, 228 
available in the same import menu used to import the image stack. 229 
 230 
3.3. Select the arealist imported in the Z space and use the Brush tool to review the 231 
segmentation. 232 
 233 
3.4. Visualize the model in 3D by right-clicking on Area list > Show in 3D. In the following window 234 
asking for a resample number, a higher value will generate a lower resolution mesh.  235 

 236 
NOTE: Depending on the size of the object, consider using a value between 4 and 6, which usually 237 
gives the best compromise between resolution and morphological detail. 238 
 239 
3.5. Export the 3D mesh as wavefront .obj by choosing from the menu File > Export surfaces > 240 
Wavefront. 241 
 242 
4. 3D analysis 243 
 244 
4.1. Open Blender. For the following steps, make sure to install the NeuroMorph toolkit (available 245 
at https://neuromorph.epfl.ch/index.html) and the glycogen analysis toolkit (available at 246 
https://github.com/daniJb/glyco-analysis). 247 
 248 
4.1.1. Import the objects using the NeuroMorph batch import by clicking Import Objects under 249 
the Scene menu, to import multiple objects at once. Make sure to activate Use remesh and 250 
Smooth shading.  251 
 252 
NOTE: It is not recommended to click on Finalize remesh if there is uncertainty about the initial 253 
size of the object. Import tree depth at value 7 (default) is usually good to maintain an acceptable 254 
resolution and morphology of the object. 255 
 256 
4.1.2. Select the object of interest from the outliner and modify the octree depth of the remesh 257 
function under the Modifiers menu iteratively to minimize the number of vertices and to avoid 258 
losing details in resolution and correct morphology. When changing the octree depth, the mesh 259 
on the main GUI will change accordingly. Once finished, click on Apply to finalize the process. 260 
 261 
NOTE: Values around 4 are usually good for small objects (such as postsynaptic densities), values 262 
around 7 for larger ones (such as long axons or dendrites), and values around 8 or 9 for complete 263 
cellular morphologies where details of different resolutions should be maintained.  264 



  

 265 
4.1.3. Use the image superimposition tool Image stack interactions on the left panel, under the 266 
NeuroMorph menu, to load the image stack. Make sure to enter the physical size of the image 267 
stack for x, y, and x (in microns or nanometers, depending on the units of the mesh) and select 268 
the path of the stack by clicking on Source_Z. X and Y are orthogonal planes; they are optional 269 
and will be loaded only if the user inserts a valid path.  270 
 271 
4.1.4. Then, select a mesh on the viewport by right-clicking on it, enter the edit mode by pressing 272 
Tab, select one (or more) vertices using mouse right click, and finally, click on Show image at 273 
vertex. One (or more) cut plane(s) with the micrograph will appear superimposed on top of the 274 
mesh.  275 

 276 
4.1.5. Select the cut plane by right-clicking on it, press Ctrl + Y, and scroll over the 3D model using 277 
the mouse scroll. This can also be used as proofreading method. 278 
 279 
4.1.6. Use Measurement tools for quantifications of surface areas, volumes, and lengths. These 280 
operations are documented in more details by Jorstad et al.19 and on the NeuroMorph website24. 281 
 282 
4.1.7. Use the Glycogen analysis tool for quantifying glycogen proximity toward spines and 283 
boutons. Operations are documented in more details in a previous publication10 and in the 284 
glycogen analysis repository25. 285 
 286 
4.2. Run GLAM23. The code, executable, and some test files are available in the GLAM 287 
repository26. 288 
 289 
4.2.1. Prepare two geometry files in .ply format: one source file containing glycogen granules and 290 
one target file containing the morphology surfaces. 291 
 292 
4.2.2. Prepare three .ascii colormap files (each line containing t_norm(0..1) R(0..255) G(0..255) 293 
B(0..255)) for representing local absorption values, peak values, and average absorption values. 294 
 295 
4.2.3. Execute the C++ script GLAM, with the geometry files (step 4.2.1) and colormap files (step 296 
4.2.2), by setting the influence radius (in microns), the maximum expected absorption value, and 297 
a normalized threshold for clustering the absorption peaks. For information about other 298 
parameters, execute the script with the –help option. 299 
 300 
4.2.4. Export the results as .ply or .obj files: target objects color-mapped with GLAM values, 301 
absorption peak markers represented as color-coded spheres, and target objects color-coded 302 
with respect to the mean absorption value. 303 
 304 
4.3. Open VR Data Interact. VR Data Interact-executable code is available in a public repository27. 305 
 306 
4.3.1. Import meshes to be visualized, following the instructions in the VR menu. Make sure to 307 
import the .obj files computed in step 4.2.1, in case a GLAM analysis is needed. 308 



  

 309 
REPRESENTATIVE RESULTS:  310 
By using the procedure presented above, we show results on two image stacks of different sizes, 311 
to demonstrate how the flexibility of the tools makes it possible to scale up the procedure to 312 
larger datasets. In this instance, the two 3DEM datasets are (i) P14 rat, somatosensory cortex, 313 
layer VI, 100 µm x 100 µm x 76.4 µm4 and (ii) P60 rat, hippocampus CA1, 7.07 µm x 6.75 µm x 314 
4.73 µm10.  315 
 316 
The preprocessing steps (Figure 1) can be performed the same way for both datasets, simply 317 
taking into account that a larger dataset such as the first stack, which is 25 GB, requires more 318 
performing hardware to handle large data visualization and processing. The second stack is only 319 
1 GB, with a perfectly isotropic voxel size.  320 
 321 
The size of the data might not be directly related to the field of view (FOV), rather than to the 322 
resolution of the stack itself, which depends on the maximum pixel size of the sensor of the 323 
microscope, and the magnification of the stack. In any case, logically, larger FOVs are likely to 324 
occupy more physical space compared to smaller FOVs, if acquired at the same resolution. 325 
 326 
Once the image stack is imported, as indicated in section 1 of the protocol, in Fiji software (Figure 327 
1A), a scientific release of ImageJ12, one important point is to make sure that the image format is 328 
8-bit (Figure 1B). This because many acquisition software different microscopy companies 329 
producers generate their proprietary file format in 16-bit to store metadata relevant to 330 
information about the acquiring process (i.e., pixel size, thickness, current/voltage of the electron 331 
beam, chamber pressure) together with the image stack. Such adjustments allow scientists to 332 
save memory, as the extra 8-bit containing metadata does not affect the images. The second 333 
important parameter to check is the voxel size, which then allows the reconstruction following 334 
the segmentation to be performed on the correct scale (micrometers or nanometers; Figure 1B). 335 
 336 
Stacks might need realignment and/or stitching if they have been acquired using tiling; these 337 
operations can be performed within TrakEM2 (Figure 2A), although regarding realignment, 338 
automated 3DEM techniques like FIB-SEM or 3View are usually well realigned. 339 
 340 
One last step requires filtering and, possibly, downsampling of the stack, depending on which 341 
objects need to be reconstructed and whether downsampling affects the recognition of the 342 
reconstructable features. For instance, for the larger stack (of the somatosensory cortex of P14 343 
rats), it was not possible to compromise the resolution for the benefit of the reconstruction 344 
efficiency, while for the smaller stack (of the hippocampus CA1 of P60 rats), it was possible to do 345 
so because the resolution was far above what was needed for the smallest objects to be 346 
reconstructed. Finally, the use of the unsharp mask enhances the difference between the 347 
membranes and the background, making it favorable for the reconstructions of software like 348 
ilastik which uses gradients to pre-evaluate borders. 349 
 350 
Following the image processing, reconstruction can be performed either manually using 351 
TrakEM2, or semi-automatically using ilastik (Figure 2C). A dataset like the smaller one listed here 352 



  

(ii), that can be downsampled to fit into memory, can be fully segmented using ilastik (Figure 2B) 353 
to produce a dense reconstruction. In the case of the first dataset listed here (i), we have 354 
managed to load and preprocess the entire dataset with a Linux workstation with 500 GB of RAM. 355 
The sparse segmentation of 16 full morphologies was obtained with a hybrid pipeline, by 356 
extracting rough segmentation that was manually proofread using TrakEM2. 357 
 358 
The 3D analysis of features like surface areas, volumes, or the distribution of intracellular 359 
glycogen can be performed within a Blender environment (Figure 3) using custom codes, such as 360 
NeuroMorph19 or glycogen analysis10. 361 
 362 
In case of datasets containing glycogen granules as well, analysis on their distribution can be 363 
inferred using GLAM, a C++ code that would generate colormaps with influence area directly on 364 
the mesh. 365 
 366 
Finally, such complex datasets can be visualized and analyzed using VR, which has been proven 367 
to be useful for the analysis of datasets with a particular occluded view (Figure 4). For instance, 368 
peaks inferred from GLAM maps were readily inferred visually from dendrites in the second 369 
dataset discussed here. 370 
 371 
FIGURE AND TABLE LEGENDS: 372 
 373 
Figure 1: Image processing and preparation for image segmentation. (a) Main Fiji GUI. (b) 374 
Example of stacked images from dataset (i) discussed in the representative results. The panel on 375 
the right shows properties allowing the user to set the voxel size. (c) Example of a filer and resize 376 
operation applied to a single image. The panels on the right show magnifications from the center 377 
of the image. 378 
 379 
Figure 2: Segmentation and reconstruction using TrakEM2 and ilastik. (a) TrakEM2 GUI with 380 
objects manually segmented (in red). (b) The exported mask from panel a can be used as input 381 
(seed) for (c) semi-automated segmentation (carving). From ilastik, masks (red) can be further 382 
exported to TrakEM2 for manual proofreading. (d) Masks can be then exported as 3D triangular 383 
meshes to reveal reconstructed structures. In this example, four neurons, astrocytes, microglia, 384 
and pericytes from dataset (i) (discussed in the representative results) were reconstructed using 385 
this process. 386 
 387 
Figure 3: 3D analysis of reconstructed morphologies using customized tools. (a) Isotropic 388 
imaged volume from FIB-SEM dataset (ii) (as discussed in the representative results). (b) Dense 389 
reconstruction from panel a. Grey = axons; green = astrocytic process; blue = dendrites. (c) 390 
Micrograph showing examples of targets for quantifications such as synapses (dataset (i)) and 391 
astrocytic glycogen granules (dataset (ii)) in the right magnifications. (d) Mask from panel c 392 
showing the distribution of glycogen granules around synapses. (e) Quantification of glycogen 393 
distribution from the dataset from panel c, using the glycogen analysis toolbox from Blender. The 394 
error bars indicate standard errors. N = 4,145 glycogen granules. (f) A graphic illustration of the 395 
input and output visualization of GLAM. 396 



  

 397 
Figure 4: Analysis in VR. (a) A user wearing a VR headset while working on (b) the dense 398 
reconstruction from FIB-SEM dataset (ii) (as discussed in the representative results). (c) 399 
Immersive VR scene from a subset of neurites from panel b. The green laser is pointing to a GLAM 400 
peak. (d) Example of an analysis from GLAM peak counts in VR. N = 3 mice per each bar. Analysis 401 
of FIB-SEM from a previous publication28. The error bars indicate the standard errors; *p < 0.1, 402 
one-way ANOVA.  403 
 404 
DISCUSSION: 405 
The method presented here is a useful step-by-step guide for the segmentation and 3D 406 
reconstruction of a multiscale EM dataset, whether they come from high-resolution imaging 407 
techniques, like FIB-SEM, or other automated serial sectioning and imaging techniques. FIB-SEM 408 
has the advantage of potentially reaching perfect isotropy in voxel size by cutting sections as thin 409 
as 5 nm using a focused ion beam, its FOV might be limited to 15–20 µm because of side artifacts, 410 
which are possibly due to the deposition of the cut tissue if the FOV exceeds this value. Such 411 
artifacts can be avoided by using other techniques, such as SBEM, which uses a diamond knife to 412 
cut serial sections inside the microscope chamber. In this latter case, the z resolution can be 413 
around 20 nm at best (usually, 50 nm), but the FOV might be larger, although the pixel resolution 414 
should be compromised for a vast region of interest. One solution to overcome such limitations 415 
(magnification vs. FOV) is to divide the region of interest in tiles and acquire each of them at a 416 
higher resolution. We have shown here results from both an SBEM stack—dataset (i) in the 417 
representative results—and a FIB-SEM stack—dataset (ii) in the representative results. 418 
 419 
As the generation of larger and larger datasets is becoming increasingly more common, efforts 420 
in creating tools for pixel classification and automated image segmentation are multiplying; 421 
nevertheless, to date, no software has proven reliability comparable to that of human 422 
proofreading, which is therefore still necessary, no matter how time-consuming it is. In general, 423 
smaller datasets that can be downsampled, like in the case of dataset (ii), can be densely 424 
reconstructed by a single, expert user in a week, including proofreading time. 425 
 426 
The protocol presented here involves the use of three software programs in particular: Fiji 427 
(version 2.0.0-rc-65/1.65b), ilastik (version 1.3.2 rc2), and Blender (2.79), which are all open-428 
source and multi-platform programs and downloadable for free. Fiji is a release of ImageJ, 429 
powered by plugins for biological image analysis. It has a robust software architecture and is 430 
suggested as it is a common platform for life scientists and includes TrakEM2, one of the first and 431 
most widely used plugins for image segmentation. One issue experienced by many users lately is 432 
the transition from Java 6 to Java 8, which is creating compatibility issues; therefore, we suggest 433 
refraining from updating to Java 8, if possible, to allow Fiji to work properly. ilastik is a powerful 434 
software providing a number of frameworks for pixel classification, each one documented and 435 
explained on their website. The carving module used for the semi-automated segmentation of 436 
EM stacks is convenient as it saves much time, allowing scientists to reduce the time spent on 437 
manual work from months to days for an experienced user, as with a single click an entire neurite 438 
can be segmented in seconds. The preprocessing step is very intense from a hardware point of 439 
view, and very large datasets, like the SBEM stack presented here, which was 26 GB, require 440 



  

peculiar strategies to fit into memory, considering that one would acquire large dataset because 441 
cannot compromise field of view and resolution. Therefore, downsampling might not be an 442 
appropriate solution in this case. The latest release of the software can do the preprocessing in 443 
a few hours with a powerful Linux workstation, but the segmentation would take minutes, and 444 
scrolling through the stack would still be relatively slow. We still use this method for a first, rough 445 
segmentation, and proofread it using TrakEM2. Finally, Blender is a 3D modeling software, with 446 
a powerful 3D rendering engine, which can be customized with python scripts that can be 447 
embedded in the main GUI as add-ons, such as NeuroMorph and glycogen analysis. The flexibility 448 
of this software comes with the drawback that, in contrast to Fiji, for instance, it is not designed 449 
for the online visualization of large datasets; therefore, visualizing and navigating through large 450 
meshes (exceeding 1 GB) might be slow and not efficient. Because of this, it is always advisable 451 
to choose techniques that reduce mesh complexity but are careful not to disrupt the original 452 
morphology of the structure of interest. The remesh function comes in handy and is an 453 
embedded feature of the NeuroMorph batch import tool. An issue with this function is that, 454 
depending on the number of vertices of the original mesh, the octree depth value, which is 455 
related to the final resolution, should be modified accordingly. Small objects can be remeshed 456 
with a small octree depth (e.g., 4), but the same value might disrupt the morphology of larger 457 
objects, which needs bigger values (6 at best, to 8 or even 9 for a very big mesh, such as a full 458 
cell). It is advisable to make this process iterative and test the different octree depths if the size 459 
of the object is not clear. 460 
 461 
As mentioned previously, one aspect that should be taken into account is the computational 462 
power to be dedicated to reconstruction and analysis, related to the software that is being used. 463 
All the operations shown in the representative results of this manuscript were obtained using a 464 
MacPro, equipped with an AMD FirePro D500 Graphics card, 64 GB of RAM, and an Intel Xeon E5 465 
CPU with 8 cores. Fiji has a good software architecture for handling large datasets; therefore, it 466 
is recommended to use a laptop with a good hardware performance, such as a MacBook Pro with 467 
a 2.5 GHz Intel i7 CPU and 16 GB of RAM. ilastik software is more demanding in terms of hardware 468 
resources, in particular during the preprocessing step. Although downsampling the image stack 469 
is a good trick to limit the hardware requests from the software and allows the user to process a 470 
stack with a laptop (typically if it is below 500 pixels in x,y,z), we suggest the use of a high-end 471 
computer to run this software smoothly. We use a workstation equipped with an Intel Xeon Gold 472 
6150 CPU with 16 cores and 500 GB of RAM. 473 
 474 
When provided with an accurate 3D reconstruction, scientists can discard the original 475 
micrographs and work directly on the 3D models to extract useful morphometric data to compare 476 
cells of the same type, as well as different types of cells, and take advantage of VR for qualitative 477 
and quantitative assessments of the morphologies. In particular, the use of the latter has proven 478 
to be beneficial in the case of analyses of dense or complex morphologies that present visual 479 
occlusion (i.e., the blockage of view of an object of interest in the 3D space by a second one 480 
placed between the observer and the first object), making it difficult to represent and analyze 481 
them in 3D. In the example presented, an experienced user took about 4 nonconsecutive hours 482 
to observe the datasets and count the objects. The time spent on VR analysis might vary as 483 
aspects like VR sickness (which can, to some extent, be related to car sickness) can have a 484 



  

negative impact on the user experience; in this case, the user might prefer other analysis tools 485 
and limit their time dedicated to VR.  486 
 487 
Finally, all these steps can be applied to other microscopy and non-EM techniques that generate 488 
image stacks. EM generates images that are, in general, challenging to handle and segment, 489 
compared with, for instance, fluorescence microscopy, where something comparable to a binary 490 
mask (signal versus a black background), that in principle can be readily rendered in 3D for further 491 
processing, often needs to be dealt with. 492 
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We sincerely hope that all points have been addressed correctly and looking forward to the feedbacks from the editor. 
 
With my best regards, 
 
Corrado Calì, 

On behalf of all authors. 
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