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SUMMARY:  35 
Within this protocol we detail simplified methods for fabricating transparent neurovascular 36 
phantoms and characterizing flow therein. We highlight several important parameters and 37 
demonstrate their relationship to field accuracy. 38 
 39 
ABSTRACT:  40 
Particle Image Velocimetry (PIV) is used in a wide variety of fields, due to the opportunity it 41 
provides for precisely visualizing and quantifying flows across a large spatiotemporal range. 42 
However, its implementation typically requires use of expensive and specialized instrumentation, 43 
which limits its broader utility. Moreover, within the field of bioengineering, in vitro flow 44 
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visualization studies are also often further limited by the high cost of commercially-sourced tissue 45 
phantoms that recapitulate desired anatomical structures, particularly for those that span the 46 
meso-scale regime (i.e., sub-mm to mm length-scales). Herein, we present a simplified 47 
experimental protocol developed to address these limitations, the key elements of which include: 48 
1) a relatively low-cost method for fabricating meso-scale tissue phantoms using 3D printing and 49 
silicone casting; and 2) an open-source image analysis and pre/post-processing framework that 50 
reduces demand upon the instrumentation for measuring meso-scale flows (i.e., velocities up to 51 
tens of mm/s). Collectively, this lowers the barrier to entry for non-experts by leveraging 52 
resources already at the disposal of many bioengineering researchers. , thus circumventing the 53 
applicability of this protocol within the context of neurovascular flow characterization; however, 54 
it is expected to be relevant to a broader range of meso-scale applications in bioengineering and 55 
beyond. 56 
 57 
INTRODUCTION:  58 
Particle image velocimetry (PIV) is widely used in experimental fluid mechanics for flow 59 
visualization and quantitative investigations of fluid motion that vary in length-scale from 60 
atmospheric to microcirculatory flows1–3. While the specifics of its implementation can vary as 61 
widely as its applications, one aspect common to nearly all PIV studies is the use of video imaging 62 
of tracer particles seeded within the working fluid, followed by pair-wise analysis of consecutive 63 
image frames to extract desired flow characteristics. Typically, this is accomplished by first sub-64 
dividing each image frame into smaller regions termed interrogation windows. As a consequence 65 
of the random positions of the dispersed particles, each interrogation window contains a unique 66 
distribution of pixel intensities. If the window size and data acquisition rate are chosen 67 
appropriately, cross-correlation of the intensity signal in each window can be used to estimate 68 
the average displacement within that region. Finally, given that the magnification and frame rate 69 
are known experimental parameters, an instantaneous velocity vector field can be readily 70 
computed.  71 
 72 
A major advantage of PIV over single-point measurement techniques is its ability to map vector 73 
fields across a two- or three-dimensional domain. Hemodynamic applications, in particular, have 74 
benefited from this capability, since it allows a thorough investigation of local flows, which are 75 
known to play a significant role in vascular disease or remodeling (e.g., atherosclerosis, 76 
angiogenesis)4–6. This has also been true for the evaluation of neurovascular flows, and the 77 
interactions thereof with endovascular devices (e.g., flow diverters, stents, intra-saccular coils, 78 
etc.), since the relevant lengths-scales in such applications can often span one or more orders of 79 
magnitude (e.g., micrometer to mm-scale), and device geometry and placement can significantly 80 
impact the local fluid mechanics7.   81 
 82 
Most groups conducting PIV-based hemodynamics studies have relied on experimental setups 83 
that closely mimic some of the earliest investigations of stent influence on vascular flow7, 8. 84 
Typically, these include: a) pulsed lasers and high-speed cameras, to capture high velocity flows; 85 
b) synchronizers, to prevent aliasing between the pulse frequency of the laser and the camera 86 
acquisition frame rate; c) cylindrical optics, to form a light sheet, and thus, minimize background 87 
fluorescence from tracer particles above and below the interrogation plane; and d) in the case of 88 
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commercial turn-key systems, proprietary software packages, to perform the cross-correlation 89 
analyses. However, while some applications require the performance and/or versatility 90 
collectively afforded by these components, many others do not, thus making it sometimes 91 
difficult to justify the high cost of such systems. (which can reach up to > $100k). . Moreover, the 92 
high cost of commercially-sourced tissue phantoms that recapitulate desired vascular structures 93 
can also prove limiting for many in vitroin vitro studies, particularly for phantoms with features 94 
that bridge the meso-scale regime (> $500/phantom). It must be emphasized that the intent of 95 
this protocol is to outline a methodology to perform PIV with lab components that are already 96 
accessible to bioengineering laboratories. It is out of the scope of this document to provide a 97 
detailed guide on PIV and the reader is referred to comprehensive texts for variations on the 98 
method (CITE). Here, we lay out a fail-proof framework that can be readily applied even if one 99 
lacks experience with this measurement technique. Herein, we report the development of a 100 
simplifiede and low-cost protocol for implementing PIV for in vitro visualization of neurovascular 101 
flows, which typically lie both spatially and temporally within the meso-scale regime (i.e., length-102 
scales ranging from sub-mm to mm, and velocities up to tens of mm/s). The protocol seeks to 103 
leverage resources already at the disposal of many bioengineering researchers, thus lowering the 104 
barrier to entry for non-experts. 105 
 106 
It must be emphasized that the intent of this protocol is to outline a methodology to perform PIV 107 
in-house fabrication of transparent, polydimethylsiloxane (PDMS)silicone-based tissue phantoms 108 
from 3D-printed sacrificial acrylonitrile butadiene styrene (ABS) molds. By leveraging the 109 
increasing availability of 3D printers in recent years, particularly those in shared/multi-user 110 
facilities (e.g., institutional facilities or public makerspaces), this methodology cuts cost 111 
significantly (e.g., < $100/phantom in our case), while enabling rapid turnaround for fabrication 112 
of a wide variety of designs and geometries. In the current protocol, a fused deposition modeling 113 
system is used with acrylonitrile butadiene styrene (ABS) as the build material, and the printed 114 
part serves as a sacrificial mold for the subsequent phantom casting. Our experience has shown 115 
that ABS is well-suited for such use, since it is soluble in common solvents (e.g., acetone), and it 116 
has sufficient strength and rigidity to maintain mold integrity after removal of the support 117 
material (e.g., to prevent deformation or fracture of diminutive mold features). In the current 118 
protocol, mold integrity is further ensured through the use of solid printed models, although this 119 
comes at the expense of increased dissolution time. Use of hollow models may also possible in 120 
some cases, to enhance solvent access, and thus, reduce dissolution time. However, careful 121 
consideration should be given to the effect this may have on mold integrity. Finally, while the 122 
phantoms fabricated herein are based upon idealized representations of neurovascular 123 
structures generated using a common CAD software package, the protocol is expected to be 124 
amenable to the fabrication of more complex, patient-specific geometries as well (e.g., via use of 125 
model files generated by conversion of clinical imaging data into the .STL file format used by most 126 
3D printers). Further details regarding the phantom fabrication process are provided in Protocol 127 
Section s 1 and 2 of the Protocol. 128 
 129 
The second element of the protocol involves the use of an open-source plug-in for ImageJ to 130 
conduct the cross-correlation analyses9. This is coupled with the implementation of a simple 131 
statistical thresholding scheme (i.e. intensity capping)10 to improve image signal prior to cross-132 
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correlation, and as well as a post-correlation vector validation scheme, the normalized median 133 
(NMT), to eliminate spurious vectors through comparison of each to its nearest neighbors11. 134 
Collectively, this allows imaging to be accomplished using equipment commonly found in many 135 
bioengineering laboratories (e.g., fluorescence microscope with filtered, continuous white light), 136 
thus eliminating the need for acquisition of many of the costly components of typical PIV systems 137 
(e.g., pulsed laser, synchronizer, cylindrical optics, and proprietary software). Further details 138 
regarding the video collection, image processing, and data analysis are provided in Sections 5 and 139 
6 of the Protocol. 140 
 141 
Figure 1 illustrates the various components of the PIV setup used in this studyprotocol, which 142 
relies upon a fluorescence microscope equipped with a high-speed camera for imaging, as well 143 
as an external, continuous white-light source (i.e., metal halide lamp) for through-objective 144 
volumetric illumination. A , which also includes a variable-speed gear pump is used to to 145 
enableimpose recirculating flow of a transparent mock blood solution of a transparent mock 146 
blood solution through PDMS-basedthe neurovascular tissue phantoms. The solution  is 147 
composed of a 60:40 mixture of DI water and glycerol, which is a common substitute for blood 148 
in hemodynamics studies12–14,  due to: a) its similar density and viscosity, i.e. 1080 kg/m3 & 3.5 149 
cP, vs. 1050 kg/m3 & 3.0 – 5.0 cP for blood15, 16; b) its transparency in the visible range; c) its 150 
similar refractive index as PDMS (1.38 vs. 1.42 for PDMS)17–20 20, 21, which minimizes optical 151 
and d) the ease with which non-Newtonian behavior can be introduced, if needed, via the 152 
addition of xanthane21. Finally, fluorescent polystyrene beads are used as tracer particles (10.3 153 
μm diameter; 480 nm/501 nm excitation/emission). While neutrally-buoyant beads are desired, 154 
sourcing tracer particles with optimal fluid mechanical properties (e.g., density, size, 155 
composition) and emission wavelength can prove challenging. For example, the beads used 156 
herein are slightly less dense than the glycerol solution (1050 kg/m3 vs. 1080 kg/m3). However, 157 
the hydrodynamic effects thereof are negligible, given that the duration of a typical experiment 158 
is far shorter than the time scale associated with buoyancy effects (i.e., 5 min & 20 min, 159 
respectively). Further details regarding the mock blood solution formulation and , in vitro 160 
circulatory system setupvideo collection, image processing, and data analysis are provided in 161 
Sections 3 and 4 of the Protocol Sections 3 to 5.  162 
 163 
PROTOCOL:  164 
1. ABS-BASED SACRIFICIAL MOLD FABRICATION 165 

1.1. Design an inverse model of the desired tissue phantom using CAD software. 166 
1.1.2. Print the model using a 3D printer with ABS as the build material. 167 
 Design inverse model of desired tissue phantom using CAD software. The design used in 168 
2.1. Mixing 169 

2.1.1. In a disposable weigh boat, Mix the PDMS prepolymer base and curing agent in a 170 
mixture provides sufficient material for fabrication of phantoms with volumes up to 171 
50XXX mcm3 of 60g base to 6g curing agent for 5 to 10 min. 172 

 Place the mixture in a vacuum desiccator for 60 min to degas and minimize bubble 173 
 entrapment. Use cyclic pressurization/depressurization to facilitate bubble 174 

- Casting  175 
2.2.1. Mount the printed ABS mold on a glass slide using molding putty to seal the 176 
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interfaceMount printed ABS mold on a 75mm x 25mm glass slide such so that the top 177 
- Carefully pour the PDMS mixture into the mold while trying to minimize bubble 178 

entrapment. Lingering bubbles can be manually ruptured using a needlePour PDMS 179 
2.2. Curing  180 

temperatures this process can be accelerated22.  181 

2.3. Demolding 182 
2.3.1. Dissolve the ABS by submerging the phantom in acetone and sonicating for at least 183 

15 min using powers up to 70 W.  184 
  185 

- Place in ultrasonicaultrasonic bath to facilitate the dissolving of the ABS. 186 
-  187 

2.3.2. Thoroughly rinse the phantom with isopropyl alcohol, and then DI water to remove 188 
solvent residuesRinse phantom with isopropyl alcohol and DI water and check to 189 

  190 
-  191 
phantom is rinsed and dried sufficiently23. 192 

o  193 
2.4. Phantom fidelity verification  194 

2.4.1. Using an optical microscope with attached camera and image capture software, 195 
capture an image of a critical feature within the phantom under a magnification that 196 
maximizes the feature within the field of view. 197 

- Save the imagean image of the phantom under magnification. (For the example data 198 
2.4.3. Load both images into ImageJ by dragging them onto the “ImageJ Ttoolbar”. 199 
2.4.4. MakeClick on  the calibration reticle image to make it active, and then select the 200 

“Lline” tool. Using the mouse, d Draw a line along a feature of a known distance and 201 
select “Analyze” > “Set Scale…” from the ImageJ menu.  202 

2.4.5. In the “Sset Sscale” window, the field labeled “Distance in pixels” should be pre-203 
populated with the length of the drawn line in units of pixels. Enter the length of the 204 
feature on the calibration window in the field labeled “Known Ddistance”, and its units 205 
in the field labeled “Unit of Llength”. Check the box labeled “Global” to apply this 206 
calibration factor to all open images. 207 

2.4.6. Make the image of the phantom critical feature active and use the “Lline” tool to 208 
draw a line along a feature of interest. 209 

2.4.7. From the ImageJ menu, select “Analyze” > “Measure” (or press Ctrl + M) to measure 210 
the length of the line. 211 

 Compare the expected value against the value in the column marked “Llength” in the 212 
the “Results” window to confirm phantom fidelity. 213 

3. MOCK BLOOD SOLUTION FORMULATION 214 
3.1. Mix DI water and glycerol in a 60:40 ratio (by volume). A 100 mL volume is sufficient for 215 

the in vitro circulatory system described hereinMix 100 mL of 60:40 solution of DI water 216 
3.1.   217 
mock blood solution.    218 

3.2.3.3. n and Hhomogenize the mixture on a magnetic stir plateplate at 400 rpm for 10 min.  219 
- 10.3 µm diameter beads with 480 nm/501 nm excitation/emission wavelengths 220 
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4.1. Pump Setup 221 
4.1.1. Use a wire stripper tool to cut off the DC-end plug from the A/C to DC adapter 222 

source.  223 
4.1.2. Strip the coating off the power and ground wires and connect them to the input 224 

terminal of the pulse width modulation (PWM) voltage regulator.  225 
4.1.3. Connect the power and ground wires from the pump’s DC motor to the output 226 

terminal of the PWM voltage regulator. The PWM’s 7-segment  display outputs the 227 
duty cycle (0% - 100%) used to achieve a variable voltage to the DC motor.  228 

4.2. Pump Calibration 229 
4.2.1. In a 500mL beaker,P Pprepare 1200 mL of mock blood solution (see Sas outlined in 230 
4.2.2. Place tubing from the pump inlet to the beaker holding the mock blood solution. 231 
4.2.3. Place tubing from the pump outlet to an empty 500 mL beaker.r. from the volume.  232 
4.2.4. Select a desired range of duty cycle values to duty cycle set-point (0% - 100%).  and 233 

timer.  and collect  234 
4.2.5. Stop the timer once the pump has transferred allthe entire volume of  of the mock 235 

solution. Use this time to calculate the volumetric flow rate. 236 
-4.2.6. Repeat steps 4.2.1 – 4.2.5 for at least 5 different varying flow ratesduty cycle set-237 

a least-squares regression curve. A minimum of three replicate points per duty cycle 238 
set-point is recommended. This relationship can be used to correlate the desired flow 239 
rate to the required PWM duty cycle.  240 

4.5. VIDEO COLLECTION 241 
- Image calibration 242 

 Determine calibration ratio for the video imaging (see Section 2).Within the PCC 243 
- Import this image into ImageJ to estimate the calibration constant (e.g., pixels/mm). 244 
- Place the PDMS phantom on the stage of the upright fluorescence microscope. 245 
5.2.2. Connect the phantom to thea gear pump and introduce the mock blood solution. 246 

  247 
o   248 
with mock blood solution..  , which This may be particularly beneficial for models with 249 
vessels and/or blind features (e.g., small perforators and aneurysm sacs, respectively).  250 
o   251 

5.2.3. Set the pump motor controller for the desired flow rate based on the pump 252 
calibration curve. 253 

- Run the pump for 1 to - 5 minutes prior to the experiment to ensure steady-state 254 
conditions. 255 

- Turn on the Mg-Halideexternal lamp to Iilluminate the field of view of the camera 256 
according based upon the to the excitation wavelength of the fluorescent beads. 257 

- Adjust the imaging focal plane to the vessel mid-plane. This can be achieved by : 258 
: 259 
phantoms with circular vessel cross sections); and/or  260 
feature designed to facilitate identification of the vessel mid-plane. In the example 261 

4.1. Video recording 262 
- Select the video recording parameters to optimize signal-to-noise ratio (SNR).  263 

parameters include exposure time, frame rate, and gain.  264 
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frame rate of 2000 framesfps/s,, and a gain of 1.0. However, these parameters may 265 
on application (see; refer to  Ddiscussion section for morefurther details).   266 

o1.1.1. Gain can be used to amplify the signal, but this also increases sensor noise. 267 
- Phantom clean up 268 

- If bead-sticking is observed after an experiment, sonicate the phantom in an aqueous 269 
aqueous Alconox detergent solution using powers up to 70 W.  270 

5.6. IMAGE PROCESSING AND DATA ANALYSIS 271 
- Image pre-filteringprocessingprocessing 272 

o Drag the saved AVI file onto the IimageJ window to Iimport it. AVI file into ImageJ in 273 
“Cconvert to Ggrayscale”. 274 

- From the “ImageJ” mMenu, Sselect “Analyze” > “Generate Histogram” (or press cCtrl 275 
H) to  Intensity capping 276 
standard deviation for the unprocessed image. 277 
  278 

 NOTE: At high frame rates, it is not unusual for the distribution to be 279 
heavily toward zero (i.e., no signal). 280 

  281 
6.1.3. From the “ImageJ” ImageJ mMenu, Sselect “Image” > “Adjust”> “Brightness and 282 

press Shift + Ctrl + H) to Aapply a brightness/contrast filter.  283 
6.1.4. On the “Bbrightness and Ccontrast” menu, Ppress the “Set” button to define the 284 

limits. ChooseSet the minimum value to be  such that the intensity limits are set by 285 
set the maximum value to be the maximum intensity of the image (both based on 286 
statistics obtained in Section 5.16.1.2).  287 
  288 

o NOTE: obtained in step 5.1.2. This typically eliminates all but the top 10% 289 
of standard deviations may be varied depending on the desired distribution of 290 
pixel intensities.  291 
operation is provided in the Supplemental Material. 292 

  293 
- From the “ImageJ” ImageJ mMenu, Sselect “Process” > “Noise” > “Despeckle” .  294 

number of saturated pixels. 295 
  296 

NOTE: This operation is necessitated by the increased potential for pixel saturation 297 
that arises during optimization of brightness and contrast, which can produce 298 
spurious vectors during subsequent cross-correlation. 299 

  300 
- From the “ImageJ” ImageJ mMenu, Sselect “Process” > “Filters” > “ Gaussian Blur” 301 

radius of 1.5 to reduce artifacts arising from the . Select the radius to be 1.5. This value 302 
pixels in a 3x3 neighborhood by the prior despeckling operation. 303 

o Click on the “Ppolygon” tool, and then click within the image to outline the The 304 
interest (ROI).  305 

- From the “ImageJ” ImageJ mMenu, select “Edit” > “Clear Outside”  definitionto 306 
locations where no signal is expected (e.g., areas beyond vessel wall boundary), which 307 
can decrease overall SNR. 308 
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o The ImageJ ROI Definition function, followed by the Clear Outside function, can 309 
  310 
NOTE: This portion of the protocol e section below employs a third-party PIV plug-in for 311 
ImageJ for conducting PIV analyses, . Ensure the plug-in has been installed before 312 
implementing any of the operations below.which relies upon Gaussian peak-fitting to 313 
enable estimation of displacement with sub-pixel accuracy. 314 
-  315 

6.2.1. From the “ImageJ” ImageJ mMenu, Cross-correlationSselect “Plugins” > “Macros” 316 
saved macro “Supplemental Codde 2.ijjm” to perform a batched correlation oncross-317 
 318 

NOTE: The code performs an algorithmmacro isproceeds as follows: 319 
within consecutive images is first performed to determine the local displacement 320 
of advected tracer particles, i.e.  (i.e. the first image pair isconsists of the first and 321 
imagesimages #1 and #2, and the second image pair pair isconsists of the second 322 
two-step multi-pass evaluation was adoptedis then performed with initial and 323 
interrogation window sizes of 256 x 256 pixels and 128 x 128 pixels, respectively; 324 
and finally, 3) . After the correlation is performed for all image pairs, the macro 325 
potential for introductionappearance of spurious vectors. 326 
o  327 

6.3. Normalized median test (NMT) 328 
6.3.1. From the “ImageJ” ImageJ mMenu, select “Plugins” > “Macros” > “Run…” and 329 

saved macro “Supplemental Code 3.ijjm” to perform a batched vector validation 330 
normalized median test.  331 
 332 

 NOTE: The macro algorithm performsisproceeds as follows: 1) Perform 333 
field is first compared to its eight nearest neighbors andto compute the median 334 
2) . 335 
neighboring vector and the median vector magnitudecalculated median; .3) t 336 
vector under investigation and the median neighboring vector value is then 337 
normalized by the median of the residuals; 4) . 338 
value (typically 0.2 pixels), which can be varied based on a priori knowledge of 339 
noise during image acquisition; and finally, 5) . 340 
instantaneous vector fields before averaging them, since is performed to produce 341 
a composite field, as this has been shown to increase the vector field quality24. 342 

o  343 
REPRESENTATIVE RESULTS:   344 
Figure 2 illustrates the PDMS tissue phantom fabrication process. The phantoms designed herein 345 
are intended for the study of flow in idealized wide-necked, saccular, intracranial aneurysms, as 346 
well as proximal branching perforator arteries. Important additional design features include: 1) a 347 
common reservoir that all vessels drain into, to ensure unencumbered fluid egress from the 348 
phantom, otherwise droplet formation may occur at the smaller vessel outlets; 2) a bubble trap, 349 
to facilitate bubble removal; 3) an outer cavity wall, to ensure parallelism of the vessel with the 350 
horizontal plane, as well as precise definition of the final phantom slab height, length and width; 351 
and 4) use of a 21 gauge hypodermic needle shank (820 µm nominal outer diameter) for molding 352 
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of the perforator artery, due to our printer’s inability to define such features with sufficient 353 
fidelity. Faithful reproduction of all design features is observed throughout. 354 
 355 
Representative results for PIV-based flow characterization performed using the current protocol 356 
are presented in Figures 3 and 4. These studies were performed using phantom inlet flow rates 357 
of 100 mL/min, data acquisition rates of 2000 fps, and temporal averaging over spans of 0.05 s. 358 
Figure 3 shows representative image frames within the perforator artery, before and after 359 
intensity capping as well as corresponding surface plots of the 8-bit pixel intensity values. Both 360 
demonstrate that intensity capping significantly increases peak definition above the noise floor 361 
(i.e., increases SNR), which is critical to ensuring accuracy when performing subsequent cross-362 
correlation. Figure 4 shows the effects of intensity capping and NMT operations on the velocity 363 
vector field. Marked improvement in field uniformity is observed, thus further underscoring the 364 
importance of maximizing SNR to minimize data dropout.  365 
 366 
FIGURE AND TABLE LEGENDS:  367 
 368 
 369 
  370 
Figure 2: PDMS-based tissue phantom fabrication process: a) CAD model of neurovascular 371 
phantom mold; b) Printed ABS mold, after removal of support material; c) Casting and curing of 372 
PDMS within the ABS mold; d) Partial dissolution of ABS mold material; and e) Completed PDMS 373 
phantom, with inset showing final dimensions of key critical features, as well as the region of 374 
interest (ROI) in the perforator artery where the PIV measurements were made. .  375 
 376 
Figure 3: Effect of intensity capping operation on image SNR. Representative image frame and 377 
corresponding pixel intensity surface plots within the perforator artery, before (a, b) and after 378 
applying the intensity capping operation (c, d). 379 
 380 
Figure 4: Effects of intensity capping and NMT operations on velocity vector fields: 381 
Representative instantaneous velocity vector field within the perforator artery derived from: (a) 382 
unprocessed image data; (b) intensity capped data; and (c) intensity capped data + NMT post-383 
processing.  384 
 385 
Figure 5: Effect of interrogation window sizing on correlation quality. Optimal window sizing 386 
occurs when the value of the zero-normalized correlation coefficient is maximized, and the 387 
standard deviation is minimized. 388 
 389 
DISCUSSION:  390 
The protocol described herein outlines a simplifiede and relatively low-cost method for 391 
performing PIV studies to visualize neurovascular flows at physiologically-relevant dimensions 392 
and flow conditions in vitroin vitro. In doing so, it serves to complement protocols reported by 393 
others that have also focused on simplifying the quantification of ying vector fields, but within 394 
very different contexts that require consideration of far larger length-scales2523 or lower flow 395 
rates26, 27(e.g. atmospheric or microcirculatory flows), and thus, reliance upon simplification 396 
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schemes that are incompatible with the current application.  397 
 398 
o The most important considerations for successful implementation of PIV lie in the 399 
of flow field artifacts and maximization of image quality. Several steps in the tissue phantom 400 
fabrication process are critical to both of these criteria. For example, thorough degassing is crucial 401 
since air entrained within the PDMS during mixing can lead to bubble formation within the final 402 
phantom, which can adversely affect both feature fidelity and optical clarity. Additionally, 403 
minimization of surface roughness of the ABS mold is desired, since the PDMS casting process 404 
faithfully reproduces even the most minute imperfections (e.g., build lines, surface pores, 405 
scratches, etc.), thus resulting in surface roughness in the final phantom that can decrease optical 406 
clarity and increase potential for bead accumulation. While the protocol described herein has 407 
proven sufficient for the current applicationbeyond the scope of the current protocol, , there are 408 
means for reducing such roughness, should there be need (e.g., acetone vapor smoothing28, or 409 
optimization of layer thickness and part orientation with respect to build direction)29). 410 
 411 
 412 

 413 

𝑓𝑠𝑎𝑚𝑝𝑙𝑖𝑛𝑔 >
𝑣𝑚𝑎𝑥∙𝑐𝑐𝑎𝑙𝑖𝑏𝑟𝑎𝑡𝑖𝑜𝑛

ℎ𝑖𝑛𝑡𝑒𝑟𝑟𝑜𝑔𝑎𝑡𝑖𝑜𝑛 𝑤𝑖𝑛𝑑𝑜𝑤
 (1) 414 

 415 
where fsampling is the camera acquisition rate (Hz), vmax is the maximum expected velocity (mm/s), 416 
ccalibration is the calibration constant (pixels/mm), and hinterrogation window is the size of the 417 
interrogation window (pixels).  418 
correlation quality estimation techniques, such as the zero-normalized correlation coefficient11. 419 
In this technique, the averages of complementary signals from each frame-pair are first 420 
subtracted, and then normalized by the standard deviation of their intensities11. If a displacement 421 
of the original signal exists, such that all peaks and valleys match, the time-shifted value of this 422 
signal will be equal to one. Conversely, if there is no displacement that can align these signals, 423 
the value will be zero. This information is included in the ImageJ PIV output for each vector, and 424 
it can be plotted as its own field to see ifverify whether there are spatial effects contributing to 425 
correlation (e.g., uneven lighting). The correlation coefficient can also be averaged over a field as 426 
an overall estimate of its quality. Finally, this quantity may also be plotted against varying frame 427 
rates or interrogation window sizes to determine an optimum. Figure 5 illustrates the results 428 
from such an analysis using a Monte-Carlo synthesized particle field with displacements 429 
consistent with our experimentally-measured flows (a typical technique for characterizing 430 
correlation quality11). The results show that the interrogation window size and frame rate should 431 
be chosen such that a particle field is displaced by ≤ 20% of the interrogation window size per 432 
frame-pair to maximize the correlation coefficient, while minimizing its variability.  433 
 434 
 435 
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