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SUMMARY: 
Within this protocol we detail simplified methods for fabricating transparent neurovascular phantoms and characterizing flow therein. We highlight several important parameters and demonstrate their relationship to field accuracy.

ABSTRACT: 
Particle Image Velocimetry (PIV) is used in a wide variety of fields, due to the opportunity it provides for precisely visualizing and quantifying flows across a large spatiotemporal range. However, its implementation typically requires use of expensive and specialized instrumentation, which limits its broader utility. Moreover, within the field of bioengineering, in vitro flow visualization studies are also often further limited by the high cost of commercially-sourced tissue phantoms that recapitulate desired anatomical structures, particularly for those that span the meso-scale regime (i.e., sub-mm to mm length-scales). Herein, we present a simplified experimental protocol developed to address these limitations, the key elements of which include: 1) a relatively low-cost method for fabricating meso-scale tissue phantoms using 3D printing and silicone casting; and 2) an open-source image analysis and pre/post-processing framework that reduces demand upon the instrumentation for measuring meso-scale flows (i.e., velocities up to tens of mm/s). Collectively, this lowers the barrier to entry for non-experts by leveraging resources already at the disposal of many bioengineering researchers. , thus circumventing the need to implement many of the more costly components in standard PIV systems. We demonstrate the applicability of this protocol within the context of neurovascular flow characterization; however, it is expected to be relevant to a broader range of meso-scale applications in bioengineering and beyond.

INTRODUCTION: 
Particle image velocimetry (PIV) is widely used in experimental fluid mechanics for flow visualization and quantitative investigations of fluid motion that vary in length-scale from atmospheric to microcirculatory flows1–3. While the specifics of its implementation can vary as widely as its applications, one aspect common to nearly all PIV studies is the use of video imaging of tracer particles seeded within the working fluid, followed by pair-wise analysis of consecutive image frames to extract desired flow characteristics. Typically, this is accomplished by first sub-dividing each image frame into smaller regions termed interrogation windows. As a consequence of the random positions of the dispersed particles, each interrogation window contains a unique distribution of pixel intensities. If the window size and data acquisition rate are chosen appropriately, cross-correlation of the intensity signal in each window can be used to estimate the average displacement within that region. Finally, given that the magnification and frame rate are known experimental parameters, an instantaneous velocity vector field can be readily computed. 

A major advantage of PIV over single-point measurement techniques is its ability to map vector fields across a two- or three-dimensional domain. Hemodynamic applications, in particular, have benefited from this capability, since it allows a thorough investigation of local flows, which are known to play a significant role in vascular disease or remodeling (e.g., atherosclerosis, angiogenesis)4–6. This has also been true for the evaluation of neurovascular flows, and the interactions thereof with endovascular devices (e.g., flow diverters, stents, intra-saccular coils, etc.), since the relevant lengths-scales in such applications can often span one or more orders of magnitude (e.g., micrometer to mm-scale), and device geometry and placement can significantly impact the local fluid mechanics7.  

Most groups conducting PIV-based hemodynamics studies have relied on experimental setups that closely mimic some of the earliest investigations of stent influence on vascular flow7, 8. Typically, these include: a) pulsed lasers and high-speed cameras, to capture high velocity flows; b) synchronizers, to prevent aliasing between the pulse frequency of the laser and the camera acquisition frame rate; c) cylindrical optics, to form a light sheet, and thus, minimize background fluorescence from tracer particles above and below the interrogation plane; and d) in the case of commercial turn-key systems, proprietary software packages, to perform the cross-correlation analyses. However, while some applications require the performance and/or versatility collectively afforded by these components, many others do not, thus making it sometimes difficult to justify the high cost of such systems (> $100k). . Moreover, the high cost of commercially-sourced tissue phantoms that recapitulate desired vascular structures can also prove limiting for many in vitroin vitro studies, particularly for phantoms with features that bridge the meso-scale regime (> $500/phantom). Herein, we report the development of a simplifiede and low-cost protocol for implementing PIV for in vitro visualization of neurovascular flows, which typically lie both spatially and temporally within the meso-scale regime (i.e., length-scales ranging from sub-mm to mm, and velocities up to tens of mm/s). The protocol seeks to leverage resources already at the disposal of many bioengineering researchers, thus lowering the barrier to entry for non-experts.

9, 10

The first element of this protocol involves the use of an investment casting technique to enable in-house fabrication of transparent, polydimethylsiloxane (PDMS)silicone-based tissue phantoms from 3D-printed sacrificial acrylonitrile butadiene styrene (ABS) molds. By leveraging the increasing availability of 3D printers in recent years, particularly those in shared/multi-user facilities (e.g., institutional facilities or public makerspaces), this methodology cuts cost significantly (e.g., < $100/phantom in our case), while enabling rapid turnaround for fabrication of a wide variety of designs and geometries. In the current protocol, a fused deposition modeling system is used with acrylonitrile butadiene styrene (ABS) as the build material, and the printed part serves as a sacrificial mold for the subsequent phantom casting. Our experience has shown that ABS is well-suited for such use, since it is soluble in common solvents (e.g., acetone), and it has sufficient strength and rigidity to maintain mold integrity after removal of the support material (e.g., to prevent deformation or fracture of diminutive mold features). In the current protocol, mold integrity is further ensured through the use of solid printed models, although this comes at the expense of increased dissolution time. Use of hollow models may also possible in some cases, to enhance solvent access, and thus, reduce dissolution time. However, careful consideration should be given to the effect this may have on mold integrity. Finally, while the phantoms fabricated herein are based upon idealized representations of neurovascular structures generated using a common CAD software package, the protocol is expected to be amenable to the fabrication of more complex, patient-specific geometries as well (e.g., via use of model files generated by conversion of clinical imaging data into the .STL file format used by most 3D printers). Further details regarding the phantom fabrication process are provided in Protocol Section s 1 and 2 of the Protocol.

The second element of the protocol involves the use of an open-source plug-in for ImageJ to conduct the cross-correlation analyses9. This is coupled with the implementation of a simple statistical thresholding scheme (i.e. intensity capping)10 to improve image signal prior to cross-correlation, and as well as a post-correlation vector validation scheme, the normalized median test (NMT), to eliminate spurious vectors through comparison of each to its nearest neighbors11. Collectively, this allows imaging to be accomplished using equipment commonly found in many bioengineering laboratories (e.g., fluorescence microscope with filtered, continuous white light), thus eliminating the need for acquisition of many of the costly components of typical PIV systems (e.g., pulsed laser, synchronizer, cylindrical optics, and proprietary software). Further details regarding the video collection, image processing, and data analysis are provided in Sections 5 and 6 of the Protocol.

Figure 1 illustrates the various components of the PIV setup used in this studyprotocol, which relies upon a fluorescence microscope equipped with a high-speed camera for imaging, as well as an external, continuous white-light source (i.e., metal halide lamp) for through-objective volumetric illumination. A , which also includes a variable-speed gear pump is used to to enableimpose recirculating flow of a transparent mock blood solution of a transparent mock blood solution through PDMS-basedthe neurovascular tissue phantoms. The solution  is composed of a 60:40 mixture of DI water and glycerol, which is a common substitute for blood in hemodynamics studies12–14,  due to: a) its similar density and viscosity, i.e. 1080 kg/m3 & 3.5 cP, vs. 1050 kg/m3 & 3.0 – 5.0 cP for blood15, 16; b) its transparency in the visible range; c) its similar refractive index as PDMS (1.38 vs. 1.42 for PDMS)17–20 , which minimizes optical distortion; and d) the ease with which non-Newtonian behavior can be introduced, if needed, via the addition of xanthane21. Finally, fluorescent polystyrene beads are used as tracer particles (10.3 μm diameter; 480 nm/501 nm excitation/emission). While neutrally-buoyant beads are desired, sourcing tracer particles with optimal fluid mechanical properties (e.g., density, size, composition) and emission wavelength can prove challenging. For example, the beads used herein are slightly less dense than the glycerol solution (1050 kg/m3 vs. 1080 kg/m3). However, the hydrodynamic effects thereof are negligible, given that the duration of a typical experiment is far shorter than the time scale associated with buoyancy effects (i.e., 5 min & 20 min, respectively). Further details regarding the mock blood solution formulation and , in vitro circulatory system setupvideo collection, image processing, and data analysis are provided in Sections 3 and 4 of the Protocol Sections 3 to 5. 

PROTOCOL: 
1. ABS-BASED SACRIFICIAL MOLD FABRICATION
1.1. Design an inverse model of the desired tissue phantom using CAD software.
1.2. Print the model using a 3D printer with ABS as the build material.
1.3. Design inverse model of desired tissue phantom using CAD software. 
1.4. 
1.5. 
1.6. 
1.7. 	Comment by Masaru Rao: Describe clicking sequences in all software portions in a consistent manner throughout protocol. The scheme used in the Image Processing section seems most efficient.
1.8. 
1.9. 
1.10. 
1.11. 
1.12. 
1.13. 
1.14. 
1.15. 
1.16. 
1.17. 
1.18. 
1.19. 
1.20. 
1.21. 	Comment by Ryan Peck: Where on the printer?
1.22. 
1.23. 
1.24. 
1.25. 
1.26. 
1.27. 
1.28. 
1.29. 
1.30. 
1.31. 
1.32. Print model using 3D printer. 	Comment by Author: Need Edver to add detail about how to use Stratsys software to orient part, etc.
· A fused deposition modeling system is used herein, with ABS as the build material (0.635 mm resolution in build-plane, and 0.178 mm layer resolution).
· ABS is well-suited for use as sacrificial mold material, since it has sufficient strength and rigidity to maintain structural integrity after removal of the support material, and it is soluble in common solvents (e.g., acetone).
2.  PDMS-BASED VASCULAR PHANTOM FABRICATION
2.1. Mixing
2.1.1. Mix the PDMS prepolymer base and curing agent in a 10:1 ratio (by weight). Mix PDMS monomer base and curing agent in 10:1 ratioA 66 g mixture provides sufficient material for fabrication of phantoms with volumes up to 50 cm3 for 5 to 10 min.
2.1.2. Place the mixture in a vacuum desiccator for 60 min to degas and minimize bubble entrapment. Use cyclic pressurization/depressurization to facilitate bubble rupture.  
2.1.3. Cyclic pressurization/depressurization may be used to facilitate bubble rupture.
2.2. Casting 
2.3. 
2.3.1. Mount the printed ABS mold on a glass slide using molding putty to seal the interfaceMount printed ABS mold on glass slide using molding putty to seal interface.	Comment by Author: Dimensions?
2.3.2. Carefully pour the PDMS mixture into the mold while trying to minimize bubble entrapment. Lingering bubbles can be manually ruptured using a needle
2.3.3. .
2.3.4. Curing	
2.3.5. Cure the cast phantom at room temperature (25C) for at least 24 h. At higher temperatures this process can be accelerated22. 
2.3.6. Demolding
Submerge phantom in acetone bath for 15 min to dissolve ABS.
2.3.7. 
2.4. Demolding
2.4.1. Dissolve the ABS by submerging the phantom in acetone and sonicating for at least 15 min using powers up to 70 W. 



	Comment by Author: What do you mean by refresh?
Dissolution may be facilitated by ultrasonic agitation and/or periodic refreshing of acetone bath.
CAUTION: Acetone has high vapor pressure at room temperature and low flash point. Consequently, always work under a fume hood and away from potential ignition sources. Wear proper personal protective equipment (e.g., goggles or face shield, lab coat, acetone-resistant gloves, etc.).


2.4.2. Thoroughly rinse the phantom with isopropyl alcohol, and then DI water to remove solvent residuesRinse phantom with isopropyl alcohol and DI water.


NOTE: PDMS swells upon exposure to acetone; however, swelling subsides once the phantom is rinsed and dried sufficiently23.

3. Phantom fidelity verification 
3.1. Confirm phantom fidelity using optical microscopy 
3.1.1. Using an optical microscope with attached camera and image capture software, capture an image of a critical feature within the phantom under a magnification that maximizes the feature within the field of view.


3.1.2. Capture an image of an appropriate calibration reticle at the same magnification.
3.1.3. Load both images into ImageJ by dragging them onto the “Toolbar”.
3.1.4. Click on the calibration reticle image to make it active, and then select the “Line” tool. Using the mouse, draw a line along a feature of a known distance and select “Analyze” > “Set Scale…” from the ImageJ menu. 
3.1.5. In the “Set Scale” window, the field labeled “Distance in pixels” should be pre-populated with the length of the drawn line in units of pixels. Enter the length of the feature in the field labeled “Known Distance”, and its units in the field labeled “Unit of Length”. Check the box labeled “Global” to apply this calibration factor to all open images.
3.1.6. Make the image of the phantom critical feature active and use the “Line” tool to draw a line along a feature of interest.
3.1.7. From the ImageJ menu, select “Analyze” > “Measure” (or press Ctrl + M) to measure the length of the line.
3.1.8. Compare the expected value against the value in the column marked “Length” in the “Results” window to confirm phantom fidelity.
3.1.9. or other techniques.	Comment by Author: What do I do if I have residue? Do I start over?
4. MOCK BLOOD SOLUTION FORMULATION
4.1. Mix DI water and glycerol in a 60:40 ratio (by volume). A 100 mL volume is sufficient for the in vitro circulatory system described hereinMix 60:40 solution of DI water and glycerol.
	Comment by Author: According to editor's notes: shouldn't this be added as a note?
This is the standard blood substitute in hemodynamics studies15–17,  due to its:
density and viscosity (1080 kg/m3 and 3.5 cP, respectively, compared to 1050 kg/m3 and 3.0 – 5.0 cP for blood)18, 19; 
transparency in the visible range; and
similar refractive index as PDMS (1.41 compared to 1.42 for PDMS)20, 21, which minimizes optical distortion.
Non-Newtonian behavior can be achieved with addition of xanthane, if needed22.
4.2. Add 1 mL of 2.5% w/v fluorescent polystyrene bead solutions (i.e.,, tracer particles) to the mock blood solution.  
4.3.  and Hhomogenize the mixture on a magnetic stir plateplate at 400 rpm for 10 min. 
10.3 µm diameter beads with 480 nm/501 nm excitation/emission wavelengths are used in this study. 
An optimal bead volume fraction of 1% was determined empirically for the current application. Lower volume fractions may be possible with larger interrogation windows.
While neutrally-buoyant beads are desired, sourcing tracer particles with optimal fluid mechanical properties (e.g., density, size, composition) and emission wavelength can prove challenging. In this study, beads slightly less dense than the glycerol solution were used (1050 kg/m3 compared to 1080 kg/m3). However, the hydrodynamic effects thereof are negligible, given that the duration of a typical experiment is far shorter than the time scale associated with buoyancy effects (i.e., 5 min and 20 min, respectively).
5. IN VITRO CIRCULATORY SYSTEM SETUP
5.1. Pump Setup
5.1.1. Use a wire stripper tool to cut off the DC-end plug from the AC to DC adapter power source. 
5.1.2. Strip the coating off the power and ground wires and connect them to the input terminal of the pulse width modulation (PWM) voltage regulator. 
5.1.3. Connect the power and ground wires from the pump’s DC motor to the output terminal of the PWM voltage regulator. The PWM’s 7-segment display outputs the duty cycle (0% - 100%) used to achieve a variable voltage to the DC motor. 
5.2. Pump Calibration
5.2.1. Prepare 200 mL of mock blood solution (see Section 3). 	Comment by Author: This should be added as a note. I would delete it…
5.2.2. Place tubing from the pump inlet to the beaker holding the mock blood solution.
5.2.3. Place tubing from the pump outlet to an empty beaker.
5.2.4. Select a desired duty cycle set-point (0% - 100%). Press the “On” button and start a timer. 
5.2.5. Stop the timer once the pump has transferred the entire volume of mock blood solution. Use this time to calculate the volumetric flow rate.
5.2.6. Repeat steps 4.2.1 – 4.2.5 for at least 5 different duty cycle set-points to establish a least-squares regression curve. A minimum of three replicate points per duty cycle set-point is recommended. This relationship can be used to correlate the desired flow rate to the required PWM duty cycle. 
6. VIDEO COLLECTION
6.1. Image calibration
6.2. 
6.2.1. Determine calibration ratio for the video imaging (see Section 2).Capture a still image of the resolution target or calibration reticle.
6.2.2. 
· Import this image into ImageJ to estimate the calibration constant (e.g., pixels/mm).
6.3. Apparatus set up
6.4. 
6.4.1. Place the PDMS phantom on the stage of the upright fluorescence microscope.
6.4.2. 
6.4.3. Connect the phantom to thea gear pump and introduce the mock blood solution.

 

As an optional step, (Optional) the phantom may be pre-filledPre-fill the model with ethanol to facilitate full wetting, then flush and fill with mock blood solution. , which This may be particularly beneficial for models with smaller vessels and/or blind features (e.g., small perforators and aneurysm sacs, respectively). 
 

6.4.4. Set the pump motor controller for the desired flow rate based on the pump calibration curve.
6.4.5. Run the pump for 1 to - 5 minutes prior to the experiment to ensure steady-state conditions.
6.4.6. 
6.4.7. Turn on the external lamp to Iilluminate the field of view of the camera from the top with a through-objective illumination source. Select the an appropriate filter according based upon the to the excitation wavelength of the fluorescent beads.
6.4.8. 
6.4.9. Adjust the imaging focal plane to the vessel mid-plane. This can be achieved by :
6.4.10. using a focal length that maximizes the imaged vessel cross-section (e.g., when using phantoms with circular vessel cross sections); and/or 
6.4.11. indexing off of a phantom feature designed to facilitate identification of the vessel mid-plane..
6.5. Video recording
6.6. 
6.6.1. Select the video recording parameters to optimize signal-to-noise ratio (SNR). 
6.6.2. Key parameters include exposure time, frame rate, and gain. 
6.6.3. Optimal SNR is typically achieved at the highest achievable frame rate that still allows sufficient bead exposure (maximum frame rate being limited by minimum exposure time).In this protocol we use a frame rate of 2000 fps, and a gain of 1.0. However, these parameters may vary based on application (see Discussion section for further details). 
6.6.4. 
6.6.5. Gain can be used to amplify the signal, but this also increases sensor noise.
If the maximum velocity can be estimated from other flow parameters (e.g., inlet volumetric flow rate), then a lower bound on the required frame rate can be estimated using the following relation21:

	(1)

where fsampling is the camera acquisition rate (Hz), vmax is the maximum expected velocity (mm/s), ccalibration is the calibration constant (pixels/mm), and hinterrogation window is the size of the interrogation window (pixels).
If the sampling frame rate matches fsampling, maximum local velocities are not captured via cross-correlation of image pairs, since the distance traveled by tracer particles in between frames exactly matches the length scale of the interrogation windows. Therefore, the camera should be set to acquire images at a higher frame rate.
For the current application, it was found that cross-correlation is optimized when tracer particles travel ≤ 20% of the interrogation window width per frame-pair (see Discussion section for further details). 
6.6.6. Collect video and save in AVI format.
6.7. Phantom clean up
6.8. 
6.8.1. If bead-sticking is observed after an experiment, sonicate the phantom in an aqueous detergent solution using powers up to 70 W. 
6.8.2. 
6.8.3. Use of a pipe cleaner with matching diameter can also facilitate cleaning, although care must be taken to ensure the phantom is not damaged.
7. IMAGE PROCESSING AND DATA ANALYSIS
7.1. Image pre-processingprocessing
7.2. 
7.2.1. Drag the saved AVI file onto the ImageJ window to Iimport it. AVI file into ImageJ in grayscale format.
7.2.2. Select the box marked “Convert to Grayscale”.
7.2.3. From the “ImageJ” menu, select “Analyze” > “Generate Histogram” (or press Ctrl + H) to Intensity capping
To increase the quality of the signal correlation, the difference between the peaks and valleys (i.e. contrast) of the input signals should be maximized11 .
7.2.4. Ggenerate a histogram of image pixel intensities. At high frame rates, the distribution is usually skewed heavily toward zero (i.e., no signal).Take note of the mean and standard deviation for the unprocessed image.
7.2.5. 

NOTE: At high frame rates, it is not unusual for the distribution to be skewed heavily toward zero (i.e., no signal).

7.2.6. From the “ImageJ” menu, select “Image” > “Adjust”> “Brightness and Contrast” (or press Shift + Ctrl + H) to Aapply a brightness/contrast filter. 
7.2.7. On the “Brightness and Contrast” menu, press the “Set” button to define the image limits. Set the minimum value to be  such that the intensity limits are set by the mean value plus one standard deviation , and the maximum value to be the maximum intensity of the image (both based on statistics obtained in Section 6.1.2). 

NOTE: . This typically eliminates all but the top 10% of pixel intensities. 
The number of standard deviations may be varied depending on the desired distribution of pixel intensities. 
A custom macro script for performing the intensity capping operation is provided in the Supplemental Material.


7.2.8. From the “ImageJ” menu, select “Process” > “Noise” > “Despeckle” 
7.2.9. Optimization of brightness and contrast often increases the number of saturated pixels, which can appear as local maxima, and thus result in spurious vectors during subsequent cross-correlation. 
7.2.10. The Despeckle function in ImageJ can be used to reduce the number of saturated pixels.
7.2.11. 

NOTE: This operation is necessitated by the increased potential for pixel saturation that arises during optimization of brightness and contrast, which can produce spurious vectors during subsequent cross-correlation.

7.2.12. From the “ImageJ” menu, select “Process” > “Filters” > “ Gaussian Blur” with a radius of 1.5 to reduce artifacts arising from the 
7.2.13. Despeckling can occassionally removal ofe illuminated pixels in a 3x3 neighborhood by the prior despeckling operation.
7.2.14. 
7.2.15. Click on the “Polygon” tool, and then click within the image to outline the The Gaussian Blur function in ImageJ can be used to correct this effect.
7.2.16. rRegion of interest (ROI). 
7.2.17. From the “ImageJ” menu, select “Edit” > “Clear Outside”  definitionto remove 
7.2.18. Ssensor noise in locations where no signal is expected (e.g., areas beyond vessel wall boundary), which can decrease overall SNR.
· The ImageJ ROI Definition function, followed by the Clear Outside function, can be used to black out regions outside the ROI, thereby increasing SNR.
7.3. Data analysisPIV Calculation

NOTE: This portion of the protocol e section below employs a third-party PIV plug-in for ImageJ for conducting PIV analyses, . Ensure the plug-in has been installed before implementing any of the operations below.which relies upon Gaussian peak-fitting to enable estimation of displacement with sub-pixel accuracy.


7.3.1. From the “ImageJ” menu, Cross-correlationselect “Plugins” > “Macros” > “Run…” and navigate to the saved macro “Supplemental Codde 2.ijjm” to cross-correlate successive image pairs. 

NOTE: The macro proceeds as follows:
1) 


Cross-correlation of the intensity field within consecutive images is first performed to determine the local displacement of advected tracer particles, i.e. the first image pair consists of the first and second images, the second image pair consists of the second and third images, etc..; 2) 
a
The ImageJ PIV script allows multi-pass evaluation of the PIV fields. 

Here, a two-step multi-pass evaluation was adoptedis then performed with initial and final interrogation window sizes of 256 x 256 pixels and 128 x 128 pixels, respectively; and finally, 3) .the macro performs a temporal average to further reduce the appearance of spurious vectors.

NOTE: The peak in the correlation signal is typically not a discrete maximum at a single location, and thus peak fitting is needed to estimate the displacement with sub-pixel accuracy. The ImageJ PIV plug-in employs Gaussian peak-fitting for this purpose. 
7.4. Normalized median test (NMT)
7.4.1. From the “ImageJ” menu, select “Plugins” > “Macros” > “Run…” and navigate to the saved macro “Supplemental Code 3.ijjm” to validate the velocity fields via the normalized median test. 

NOTE: The macro proceeds as follows: 1) 


each vector in an instantaneous vector field is first compared to its eight nearest neighbors to compute the median value; 2) 
the array of residual errors is then calculated as the difference between each neighboring vector and the calculated median; 3) t
he difference between the vector under investigation and the median neighboring vector value is then normalized by the median of the residuals; 4) 
this is then compared to a threshold value (typically 0.2 pixels), which can be varied based on a priori knowledge of noise during image acquisition; and finally, 5) 

a temporal average of all 
validated instantaneous vector fields is performed to produce a composite field, as this has been shown to increase the vector field quality24.
7.4.2. 
· A custom macro script for performing the cross-correlation operation is provided in the Supplemental Material.
Averaging
· Temporal averaging provides a means for mitigating the potential for introduction of spurious vectors, due to mismatching of local maxima in the cross-correlation for a given frame-pair. 
· Obtain an average of each velocity component at each grid point. 


Normalized median test (NMT)
· Perform NMT for vector validation.
· Each vector is compared to its eight nearest neighbors and the median value is determined. 
· The array of residual errors is then calculated as the difference between each neighboring vector and the median vector magnitude.
· The difference between the vector under investigation and the median neighboring vector value is normalized by the median of the residuals.
· This is compared to a threshold value (typically 0.2 pixels), which can be varied based on a priori knowledge of noise during image acquisition.
· A custom macro script for performing the NMT operation is provided in the Supplemental Material.
· This script performs the normalized median test on each instantaneous vector field before averaging them, since this has been shown to increase the vector field quality22.

REPRESENTATIVE RESULTS:  
Figure 2 illustrates the PDMS tissue phantom fabrication process. The phantoms designed herein are intended for the study of flow in idealized wide-necked, saccular, intracranial aneurysms, as well as proximal branching perforator arteries. Important additional design features include: 1) a common reservoir that all vessels drain into, to ensure unencumbered fluid egress from the phantom, otherwise droplet formation may occur at the smaller vessel outlets; 2) a bubble trap, to facilitate bubble removal; 3) an outer cavity wall, to ensure parallelism of the vessel with the horizontal plane, as well as precise definition of the final phantom slab height, length and width; and 4) use of a 21 gauge hypodermic needle shank (820 µm nominal outer diameter) for molding of the perforator artery, due to our printer’s inability to define such features with sufficient fidelity. Faithful reproduction of all design features is observed throughout.

Representative results for PIV-based flow characterization performed using the current protocol are presented in Figures 3 and 4. These studies were performed using phantom inlet flow rates of 100 mL/min, data acquisition rates of 2000 fps, and temporal averaging over spans of 0.05 s. Figure 3 shows representative image frames within the perforator artery, before and after intensity capping as well as corresponding surface plots of the 8-bit pixel intensity values. Both demonstrate that intensity capping significantly increases peak definition above the noise floor (i.e., increases SNR), which is critical to ensuring accuracy when performing subsequent cross-correlation. Figure 4 shows the effects of intensity capping and NMT operations on the velocity vector field. Marked improvement in field uniformity is observed, thus further underscoring the importance of maximizing SNR to minimize data dropout. 

FIGURE AND TABLE LEGENDS: 


Figure 1: Particle image velocimetry setup. Reliance upon an open-source image analysis and pre/post-processing framework reduces demand upon the instrumentation for measuring meso-scale flows, thus eliminating the need for many of the costly components of typical PIV systems (e.g., pulsed laser, synchronizer, cylindrical optics, &/or proprietary software).
 
Figure 2: PDMS-based tissue phantom fabrication process: a) CAD model of neurovascular phantom mold; b) Printed ABS mold, after removal of support material; c) Casting and curing of PDMS within the ABS mold; d) Partial dissolution of ABS mold material; and e) Completed PDMS phantom, with inset showing final dimensions of key critical features, as well as the region of interest (ROI) in the perforator artery where the PIV measurements were made. . 

Figure 3: Effect of intensity capping operation on image SNR. Representative image frame and corresponding pixel intensity surface plots within the perforator artery, before (a, b) and after applying the intensity capping operation (c, d).

Figure 4: Effects of intensity capping and NMT operations on velocity vector fields: Representative instantaneous velocity vector field within the perforator artery derived from: (a) unprocessed image data; (b) intensity capped data; and (c) intensity capped data + NMT post-processing. 

Figure 5: Effect of interrogation window sizing on correlation quality. Optimal window sizing occurs when the value of the zero-normalized correlation coefficient is maximized, and the standard deviation is minimized.

DISCUSSION: 
The protocol described herein outlines a simplifiede and relatively low-cost method for performing PIV studies to visualize neurovascular flows at physiologically-relevant dimensions and flow conditions in vitroin vitro. In doing so, it serves to complement protocols reported by others that have also focused on simplifying the quantification of ying vector fields, but within very different contexts that require consideration of far larger length-scales2523 or lower flow rates26, 27(e.g. atmospheric or microcirculatory flows), and thus, reliance upon simplification schemes that are incompatible with the current application. 

The most important considerations for successful implementation of PIV lie in the minimization of flow field artifacts and maximization of image quality. Several steps in the tissue phantom fabrication process are critical to both of these criteria. For example, thorough degassing is crucial since air entrained within the PDMS during mixing can lead to bubble formation within the final phantom, which can adversely affect both feature fidelity and optical clarity. Additionally, minimization of surface roughness of the ABS mold is desired, since the PDMS casting process faithfully reproduces even the most minute imperfections (e.g., build lines, surface pores, scratches, etc.), thus resulting in surface roughness in the final phantom that can decrease optical clarity and increase potential for bead accumulation. While the protocol described herein has proven sufficient for the current applicationbeyond the scope of the current protocol, , there are numerous reports in the literature of means for reducing such roughness, should there be need (e.g., acetone vapor smoothing28, or optimization of layer thickness and part orientation with respect to build direction)29).



Parameter selection for video capture is also critical to ensure a high-fidelity vector field. Optimal SNR is typically achieved at the highest achievable frame rate that still allows sufficient bead exposure (maximum frame rate being limited by minimum exposure time). Gain can be used to amplify the signal, but this also increases sensor noise. 
If the maximum velocity can be estimated from other flow parameters (e.g., inlet volumetric flow rate), then a lower bound on the required frame rate can be estimated using the following relation30:

	(1)

where fsampling is the camera acquisition rate (Hz), vmax is the maximum expected velocity (mm/s), ccalibration is the calibration constant (pixels/mm), and hinterrogation window is the size of the interrogation window (pixels)
. 

However, 
For example, while Equation 1 prescribes a lower limit for the frame rate, better more optimal values can be determined using so-called correlation quality estimation techniques, such as the zero-normalized correlation coefficient11. In this technique, the averages of complementary signals from each frame-pair are first subtracted, and then normalized by the standard deviation of their intensities11. If a displacement of the original signal exists, such that all peaks and valleys match, the time-shifted value of this signal will be equal to one. Conversely, if there is no displacement that can align these signals, the value will be zero. This information is included in the ImageJ PIV output for each vector, and it can be plotted as its own field to see ifverify whether there are spatial effects contributing to poor correlation (e.g., uneven lighting). The correlation coefficient can also be averaged over a field as an overall estimate of its quality. Finally, this quantity may also be plotted against varying frame rates or interrogation window sizes to determine an optimum. Figure 5 illustrates the results from such an analysis using a Monte-Carlo synthesized particle field with displacements consistent with our experimentally-measured flows (a typical technique for characterizing correlation quality11). The results show that the interrogation window size and frame rate should be chosen such that a particle field is displaced by ≤ 20% of the interrogation window size per frame-pair to maximize the correlation coefficient, while minimizing its variability. 



Although the protocol described herein has proven sufficient for meeting the needs of the current application, Finally, it is important to acknowledge its limitations.  of the current protocol. For example, , while the use of a fluorescence microscope with continuous, volumetric illumination allows for simplification of the imaging setup (relative to pulsed lasers and light-sheet illumination), this comes at the cost of additional background fluorescence, thus requiring the implementation of various image processing operations prior to cross-correlation (i.e., intensity capping , despeckle, Gaussian Blur, and ROI operations described in Protocol Section 5). Similarly, while the NMT provides a means for improving the velocity vector field after cross-correlation, it is important to emphasize that this is just one of many vector validation techniques that could be used22, 30, each with their own unique advantages and disadvantages that may make their use more suitable for applications beyond those described here. while contrast enhancement via intensity capping offers ease of implementation, transformations of the entire distribution of pixel intensities may improve SNR further31. Similarly, although correlation-based tracking is well-established and provides sufficient resolution for reliably estimating first-order flow characteristics relevant to hemodynamics (e.g., intra-aneurysmal velocity), other techniques may offer higher spatial resolution (e.g., hybrid PIV/PTV, least squares matching)32, 33, and thus greater accuracy when considering characteristics that are more sensitive to velocity field resolution (e.g., wall shear stress, in-plane vorticity). Likewise, while the NMT provides a means for improving the velocity vector field after cross-correlation, it is important to emphasize that this is just one of many vector validation techniques that could be used24, 34, each with their own unique advantages and disadvantages that may make their use more suitable for applications beyond those described here. 

3031, 32

23, 33

Lastly, while our experimental setup seeks to mimic physiologically-relevant flow rates and length scales for the neurovasculature, it does not currently provide opportunity forallow the analysis of imposing pulsatile flows. This has not been a limitation for our current application, since However, since the range of Womersely numbers in much of the neurovasculature tends to be  tend to be ≤ 1 ( (i.e., there is minimal additive effect of multiple cardiac cycles)35, which this suggestssuggests that the steady-state conditions used herein are sufficient to resemble recapitulate oscillatory behavior during specificdiscrete time points along the cardiac waveform in which the flow rate is comparable. MoreoverHowever, for applications with where the larger Womersely number is largers (e.g., vasculature closer to the heart), we envision potential for introducing pulsatility through the use of an we anticipate potential for easily integrating pulsatility within the existing setup. For example, others have shown that an Arduino, which could be used to  may be used to send the motor pump a time-varying PWM , pulsewidth modulated (PWM) voltage waveform that enables mimicking of the a pulsatile cardiac flow profile seen in-vivo36–38. 

Conclusions:
Within this protocol, we have demonstrated simplified methods for fabricating meso-scale neurovascular phantoms and characterizing the flow fields therein via PIV. For researchers interested in vascular flow, variants of this protocol may be particularly useful for early exploratory studies, where the cost of standard PIV instrumentation would be otherwise prohibitive. 
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