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SUMMARY:  33 
Within this protocol we detail simplified methods for fabricating transparent neurovascular 34 
phantoms and characterizing flow therein. We highlight several important parameters and 35 
demonstrate their relationship to field accuracy. 36 
 37 
ABSTRACT:  38 
Particle Image Velocimetry (PIV) is used in a wide variety of fields, due to the opportunity it 39 
provides for precisely visualizing and quantifying flows across a large spatiotemporal range. 40 
However, its implementation typically requires use of expensive and specialized instrumentation, 41 
which limits its broader utility. Moreover, within the field of bioengineering, in vitro flow 42 
visualization studies are also often further limited by the high cost of commercially-sourced tissue 43 
phantoms that recapitulate desired anatomical structures, particularly for those that span the 44 
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meso-scale regime (i.e., sub-mm to mm length-scales). Herein, we present a simplified 45 
experimental protocol developed to address these limitations, the key elements of which include: 46 
1) a relatively low-cost method for fabricating meso-scale tissue phantoms using 3D printing and 47 
silicone casting; and 2) an open-source image analysis and processing framework that reduces 48 
demand upon the instrumentation for measuring meso-scale flows (i.e., velocities up to tens of 49 
mm/s). Collectively, this lowers the barrier to entry for non-experts by leveraging resources 50 
already at the disposal of many bioengineering researchers. We demonstrate the applicability of 51 
this protocol within the context of neurovascular flow characterization; however, it is expected 52 
to be relevant to a broader range of meso-scale applications in bioengineering and beyond. 53 
 54 
INTRODUCTION:  55 
Particle image velocimetry (PIV) is widely used in experimental fluid mechanics for flow 56 
visualization and quantitative investigations of fluid motion that vary in length-scale from 57 
atmospheric to microcirculatory flows1–3. While the specifics of its implementation can vary as 58 
widely as its applications, one aspect common to nearly all PIV studies is the use of video imaging 59 
of tracer particles seeded within the working fluid, followed by pair-wise analysis of consecutive 60 
image frames to extract desired flow characteristics. Typically, this is accomplished by first sub-61 
dividing each image frame into smaller regions termed interrogation windows. As a consequence 62 
of the random positions of the dispersed particles, each interrogation window contains a unique 63 
distribution of pixel intensities. If the window size and data acquisition rate are chosen 64 
appropriately, cross-correlation of the intensity signal in each window can be used to estimate 65 
the average displacement within that region. Finally, given that the magnification and frame rate 66 
are known experimental parameters, an instantaneous velocity vector field can be readily 67 
computed.  68 
 69 
A major advantage of PIV over single-point measurement techniques is its ability to map vector 70 
fields across a two- or three-dimensional domain. Hemodynamic applications, in particular, have 71 
benefited from this capability, since it allows a thorough investigation of local flows, which are 72 
known to play a significant role in vascular disease or remodeling (e.g., atherosclerosis, 73 
angiogenesis)4–6. This has also been true for the evaluation of neurovascular flows, and the 74 
interactions thereof with endovascular devices (e.g., flow diverters, stents, intra-saccular coils, 75 
etc.), since the relevant lengths-scales in such applications can often span one or more orders of 76 
magnitude (e.g., micrometer to mm-scale), and device geometry and placement can significantly 77 
impact the local fluid mechanics7.   78 
 79 
Most groups conducting PIV-based hemodynamics studies have relied on experimental setups 80 
that closely mimic some of the earliest investigations of stent influence on vascular flow7, 8. 81 
Typically, these include: a) pulsed lasers and high-speed cameras, to capture high velocity flows; 82 
b) synchronizers, to prevent aliasing between the pulse frequency of the laser and the camera 83 
acquisition frame rate; c) cylindrical optics, to form a light sheet, and thus, minimize background 84 
fluorescence from tracer particles above and below the interrogation plane; and d) in the case of 85 
commercial turn-key systems, proprietary software packages, to perform the cross-correlation 86 
analyses. However, while some applications require the performance and/or versatility 87 
collectively afforded by these components, many others do not. Moreover, the high cost of 88 
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commercially-sourced tissue phantoms that recapitulate desired vascular structures can also 89 
prove limiting for many in vitro studies, particularly for phantoms with features that bridge the 90 
meso-scale regime (> $500/phantom). Herein, we report the development of a simplified 91 
protocol for implementing PIV for in vitro visualization of neurovascular flows, which typically lie 92 
both spatially and temporally within the meso-scale regime (i.e., length-scales ranging from sub-93 
mm to mm, and velocities up to tens of mm/s). The protocol seeks to leverage resources already 94 
at the disposal of many bioengineering researchers, thus lowering the barrier to entry for non-95 
experts. 96 
 97 
The first element of this protocol involves the use of an investment casting technique to enable 98 
in-house fabrication of transparent, polydimethylsiloxane (PDMS)-based tissue phantoms from 99 
3D-printed sacrificial molds. By leveraging the increasing availability of 3D printers in recent 100 
years, particularly those in shared/multi-user facilities (e.g., institutional facilities or public 101 
makerspaces), this methodology cuts cost significantly (e.g., < $100/phantom in our case), while 102 
enabling rapid turnaround for fabrication of a wide variety of designs and geometries. In the 103 
current protocol, a fused deposition modeling system is used with acrylonitrile butadiene styrene 104 
(ABS) as the build material, and the printed part serves as a sacrificial mold for the subsequent 105 
phantom casting. Our experience has shown that ABS is well-suited for such use, since it is soluble 106 
in common solvents (e.g., acetone), and it has sufficient strength and rigidity to maintain mold 107 
integrity after removal of the support material (e.g., to prevent deformation or fracture of 108 
diminutive mold features). In the current protocol, mold integrity is further ensured through the 109 
use of solid printed models, although this comes at the expense of increased dissolution time. 110 
Use of hollow models may also possible in some cases, to enhance solvent access, and thus, 111 
reduce dissolution time. However, careful consideration should be given to the effect this may 112 
have on mold integrity. Finally, while the phantoms fabricated herein are based upon idealized 113 
representations of neurovascular structures generated using a common CAD software package, 114 
the protocol is expected to be amenable to the fabrication of more complex, patient-specific 115 
geometries as well (e.g., via use of model files generated by conversion of clinical imaging data 116 
into the .STL file format used by most 3D printers). Further details regarding the phantom 117 
fabrication process are provided in Section 2 of the Protocol. 118 
 119 
The second element of the protocol involves the use of an open-source plug-in for ImageJ to 120 
conduct the cross-correlation analyses9. This is coupled with the implementation of a simple 121 
statistical thresholding scheme (i.e. intensity capping)10 to improve image signal prior to cross-122 
correlation, as well as a post-correlation vector validation scheme, the normalized median test 123 
(NMT), to eliminate spurious vectors through comparison of each to its nearest neighbors11. 124 
Collectively, this allows imaging to be accomplished using equipment commonly found in many 125 
bioengineering laboratories, thus eliminating the need for acquisition of many of the costly 126 
components of typical PIV systems (e.g., pulsed laser, synchronizer, cylindrical optics, and 127 
proprietary software). Further details regarding the video collection, image processing, and data 128 
analysis are provided in Sections 5 and 6 of the Protocol. 129 
 130 
Figure 1 illustrates the PIV setup used in this protocol, which relies upon a fluorescence 131 
microscope equipped with a high-speed camera for imaging, as well as an external, continuous 132 
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white-light source (i.e., metal halide lamp) for through-objective volumetric illumination. A 133 
variable-speed gear pump is used to impose recirculating flow of a transparent mock blood 134 
solution through the neurovascular tissue phantoms. The solution is composed of a 60:40 135 
mixture of DI water and glycerol, which is a common substitute for blood in hemodynamics 136 
studies12–14,  due to: a) its similar density and viscosity, i.e. 1080 kg/m3 & 3.5 cP, vs. 1050 kg/m3 137 
& 3.0 – 5.0 cP for blood15, 16; b) its transparency in the visible range; c) its similar refractive index 138 
as PDMS (1.38 vs. 1.42 for PDMS)17–20 , which minimizes optical distortion; and d) the ease with 139 
which non-Newtonian behavior can be introduced, if needed, via the addition of xanthane21. 140 
Finally, fluorescent polystyrene beads are used as tracer particles (10.3 μm diameter; 480 141 
nm/501 nm excitation/emission). While neutrally-buoyant beads are desired, sourcing tracer 142 
particles with optimal fluid mechanical properties (e.g., density, size, composition) and emission 143 
wavelength can prove challenging. For example, the beads used herein are slightly less dense 144 
than the glycerol solution (1050 kg/m3 vs. 1080 kg/m3). However, the hydrodynamic effects 145 
thereof are negligible, given that the duration of a typical experiment is far shorter than the time 146 
scale associated with buoyancy effects (i.e., 5 min & 20 min, respectively). Further details 147 
regarding the mock blood solution formulation and in vitro circulatory system setup are provided 148 
in Sections 3 and 4 of the Protocol.  149 
 150 
PROTOCOL:  151 
1. ABS-BASED SACRIFICIAL MOLD FABRICATION 152 

1.1. Design an inverse model of the desired tissue phantom using CAD software. 153 
1.2. Print the model using a 3D printer with ABS as the build material. 154 

2. PDMS-BASED VASCULAR PHANTOM FABRICATION 155 
2.1. Mixing 156 

2.1.1. Mix the PDMS prepolymer base and curing agent in a 10:1 ratio (by weight). A 66 g 157 
mixture provides sufficient material for fabrication of phantoms with volumes up to 158 
50 cm3. 159 

2.1.2. Place the mixture in a vacuum desiccator for 60 min to degas and minimize bubble 160 
entrapment. Use cyclic pressurization/depressurization to facilitate bubble rupture.  161 

2.2. Casting  162 
2.2.1. Mount the printed ABS mold on a glass slide using molding putty to seal the 163 

interface. 164 
2.2.2. Carefully pour the PDMS mixture into the mold while trying to minimize bubble 165 

entrapment. Lingering bubbles can be manually ruptured using a needle. 166 

2.2.3. Cure the cast phantom at room temperature (25C) for at least 24 h. At higher 167 
temperatures this process can be accelerated22.  168 

2.3. Demolding 169 
2.3.1. Dissolve the ABS by submerging the phantom in acetone and sonicating for at least 170 

15 min using powers up to 70 W.  171 
 172 

CAUTION: Acetone has high vapor pressure at room temperature and low flash point. 173 
Consequently, always work under a fume hood and away from potential ignition 174 
sources. Wear proper personal protective equipment (e.g., goggles or face shield, lab 175 
coat, acetone-resistant gloves, etc.). 176 
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 177 
2.3.2. Thoroughly rinse the phantom with isopropyl alcohol, and then DI water to remove 178 

solvent residues. 179 
 180 

NOTE: PDMS swells upon exposure to acetone; however, swelling subsides once the 181 
phantom is rinsed and dried sufficiently23. 182 

 183 
2.4. Confirm phantom fidelity using optical microscopy 184 

2.4.1. Using an optical microscope with attached camera and image capture software, 185 
capture an image of a critical feature within the phantom under a magnification that 186 
maximizes the feature within the field of view. 187 

2.4.2. Capture an image of an appropriate calibration reticle at the same magnification. 188 
2.4.3. Load both images into ImageJ by dragging them onto the “Toolbar”. 189 
2.4.4. Click on the calibration reticle image to make it active, and then select the “Line” 190 

tool. Using the mouse, draw a line along a feature of a known distance and select 191 
“Analyze” > “Set Scale…” from the ImageJ menu.  192 

2.4.5. In the “Set Scale” window, the field labeled “Distance in pixels” should be pre-193 
populated with the length of the drawn line in units of pixels. Enter the length of the 194 
feature in the field labeled “Known Distance”, and its units in the field labeled “Unit 195 
of Length”. Check the box labeled “Global” to apply this calibration factor to all open 196 
images. 197 

2.4.6. Make the image of the phantom critical feature active and use the “Line” tool to 198 
draw a line along a feature of interest. 199 

2.4.7. From the ImageJ menu, select “Analyze” > “Measure” (or press Ctrl + M) to measure 200 
the length of the line. 201 

2.4.8. Compare the expected value against the value in the column marked “Length” in 202 
the “Results” window to confirm phantom fidelity. 203 

3. MOCK BLOOD SOLUTION FORMULATION 204 
3.1. Mix DI water and glycerol in a 60:40 ratio (by volume). A 100 mL volume is sufficient for 205 

the in vitro circulatory system described herein. 206 
3.2. Add 1 mL of 2.5% w/v fluorescent polystyrene bead solution (i.e., tracer particles) to the 207 

mock blood solution.   208 
3.3.  Homogenize the mixture on a magnetic stir plate at 400 rpm for 10 min.  209 

4. IN VITRO CIRCULATORY SYSTEM SETUP 210 
4.1. Pump Setup 211 

4.1.1. Use a wire stripper tool to cut off the DC-end plug from the AC to DC adapter power 212 
source.  213 

4.1.2. Strip the coating off the power and ground wires and connect them to the input 214 
terminal of the pulse width modulation (PWM) voltage regulator.  215 

4.1.3. Connect the power and ground wires from the pump’s DC motor to the output 216 
terminal of the PWM voltage regulator. The PWM’s 7-segment display outputs the 217 
duty cycle (0% - 100%) used to achieve a variable voltage to the DC motor.  218 

4.2. Pump Calibration 219 
4.2.1. Prepare 200 mL of mock blood solution (see Section 3).  220 
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4.2.2. Place tubing from the pump inlet to the beaker holding the mock blood solution. 221 
4.2.3. Place tubing from the pump outlet to an empty beaker. 222 
4.2.4. Select a desired duty cycle set-point (0% - 100%). Press the “On” button and start a 223 

timer.  224 
4.2.5. Stop the timer once the pump has transferred the entire volume of mock blood 225 

solution. Use this time to calculate the volumetric flow rate. 226 
4.2.6. Repeat steps 4.2.1 – 4.2.5 for at least 5 different duty cycle set-points to establish 227 

a least-squares regression curve. A minimum of three replicate points per duty cycle 228 
set-point is recommended. This relationship can be used to correlate the desired flow 229 
rate to the required PWM duty cycle.  230 

5. VIDEO COLLECTION 231 
5.1. Image calibration 232 

5.1.1. Determine calibration ratio for the video imaging (see Section 2). 233 
5.2. Apparatus set up 234 

5.2.1. Place the PDMS phantom on the stage of the fluorescence microscope. 235 
5.2.2. Connect the phantom to the gear pump and introduce the mock blood solution. 236 

 237 
 (Optional) Pre-fill the model with ethanol to facilitate full wetting, then flush and fill 238 
with mock blood solution. This may be particularly beneficial for models with smaller 239 
vessels and/or blind features.  240 
  241 

5.2.3. Set the pump motor controller for the desired flow rate based on the pump 242 
calibration curve. 243 

5.2.4. Run the pump for 1 - 5 min prior to the experiment to ensure steady-state 244 
conditions. 245 

5.2.5. Turn on the external lamp to illuminate the field of view. Select an appropriate filter 246 
based upon the excitation wavelength of the fluorescent beads. 247 

5.2.6. Adjust the imaging focal plane to the vessel mid-plane. This can be achieved by 248 
using a focal length that maximizes the imaged vessel cross-section (e.g., when using 249 
phantoms with circular vessel cross sections); and/or indexing off of a phantom 250 
feature designed to facilitate identification of the vessel mid-plane. 251 

5.3. Video recording 252 
5.3.1. Select the video recording parameters to optimize signal-to-noise ratio (SNR). Key 253 

parameters include exposure time, frame rate, and gain. In this protocol we use a 254 
frame rate of 2000 fps, and a gain of 1.0. However, these parameters may vary based 255 
on application (see Discussion section for further details).  256 

5.3.2. Collect video and save in AVI format. 257 
5.4. Phantom clean up 258 

5.4.1. If bead-sticking is observed after an experiment, sonicate the phantom in an 259 
aqueous detergent solution using powers up to 70 W.  260 

6. IMAGE PROCESSING AND DATA ANALYSIS 261 
6.1. Image pre-processing 262 

6.1.1. Drag the saved AVI file onto the ImageJ window to import it. Select the box marked 263 
“Convert to Grayscale”. 264 
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6.1.2. From the “ImageJ” menu, select “Analyze” > “Generate Histogram” (or press Ctrl + 265 
H) to generate a histogram of image pixel intensities. Take note of the mean and 266 
standard deviation for the unprocessed image. 267 
 268 

NOTE: At high frame rates, it is not unusual for the distribution to be skewed 269 
heavily toward zero (i.e., no signal). 270 

 271 
6.1.3. From the “ImageJ” menu, select “Image” > “Adjust”> “Brightness and Contrast” (or 272 

press Shift + Ctrl + H) to apply a brightness/contrast filter.  273 
6.1.4. On the “Brightness and Contrast” menu, press the “Set” button to define the image 274 

limits. Set the minimum value to be the mean value plus one standard deviation, and 275 
the maximum value to be the maximum intensity of the image (both based on 276 
statistics obtained in Section 6.1.2).  277 
 278 

NOTE: This typically eliminates all but the top 10% of pixel intensities. The number 279 
of standard deviations may be varied depending on the desired distribution of 280 
pixel intensities. A custom macro script for performing the intensity capping 281 
operation is provided in the Supplemental Material. 282 

 283 
6.1.5. From the “ImageJ” menu, select “Process” > “Noise” > “Despeckle” to reduce the 284 

number of saturated pixels. 285 
 286 

NOTE: This operation is necessitated by the increased potential for pixel saturation 287 
that arises during optimization of brightness and contrast, which can produce 288 
spurious vectors during subsequent cross-correlation. 289 

 290 
6.1.6. From the “ImageJ” menu, select “Process” > “Filters” > “Gaussian Blur” with a 291 

radius of 1.5 to reduce artifacts arising from the occasional removal of illuminated 292 
pixels in a 3x3 neighborhood by the prior despeckling operation. 293 

6.1.7. Click on the “Polygon” tool, and then click within the image to outline the region of 294 
interest (ROI).  295 

6.1.8. From the “ImageJ” menu, select “Edit” > “Clear Outside” to remove sensor noise in 296 
locations where no signal is expected (e.g., areas beyond vessel wall boundary), which 297 
can decrease overall SNR. 298 

6.2. PIV Calculation 299 
 300 
NOTE: This portion of the protocol employs a third-party PIV plug-in for ImageJ, which 301 
relies upon Gaussian peak-fitting to enable estimation of displacement with sub-pixel 302 
accuracy. 303 
 304 

6.2.1. From the “ImageJ” menu, select “Plugins” > “Macros” > “Run…” and navigate to the 305 
saved macro “Supplemental Code 2.ijjm” to cross-correlate successive image pairs.  306 
 307 

NOTE: The macro proceeds as follows:1) Cross-correlation of the intensity field 308 
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within consecutive images is first performed to determine the local displacement 309 
of advected tracer particles, i.e. the first image pair consists of the first and second 310 
images, the second image pair consists of the second and third images, etc.; 2) a 311 
two-step multi-pass evaluation is then performed with initial and final 312 
interrogation window sizes of 256 x 256 pixels and 128 x 128 pixels, respectively; 313 
and finally, 3) the macro performs a temporal average to further reduce the 314 
appearance of spurious vectors. 315 
 316 

6.3. Normalized median test (NMT) 317 
6.3.1. From the “ImageJ” menu, select “Plugins” > “Macros” > “Run…” and navigate to the 318 

saved macro “Supplemental Code 3.ijjm” to validate the velocity fields via the 319 
normalized median test.  320 
 321 

NOTE: The macro proceeds as follows: 1) each vector in an instantaneous vector 322 
field is first compared to its eight nearest neighbors to compute the median value; 323 
2) the array of residual errors is then calculated as the difference between each 324 
neighboring vector and the calculated median; 3) the difference between the 325 
vector under investigation and the median neighboring vector value is then 326 
normalized by the median of the residuals; 4) this is then compared to a threshold 327 
value (typically 0.2 pixels), which can be varied based on a priori knowledge of 328 
noise during image acquisition; and finally, 5) a temporal average of all validated 329 
instantaneous vector fields is performed to produce a composite field, as this has 330 
been shown to increase the vector field quality24. 331 

 332 
REPRESENTATIVE RESULTS:   333 
Figure 2 illustrates the PDMS tissue phantom fabrication process. The phantoms designed herein 334 
are intended for the study of flow in idealized wide-necked, saccular, intracranial aneurysms, as 335 
well as proximal branching perforator arteries. Important additional design features include: 1) a 336 
common reservoir that all vessels drain into, to ensure unencumbered fluid egress from the 337 
phantom, otherwise droplet formation may occur at the smaller vessel outlets; 2) a bubble trap, 338 
to facilitate bubble removal; 3) an outer cavity wall, to ensure parallelism of the vessel with the 339 
horizontal plane, as well as precise definition of the final phantom slab height, length and width; 340 
and 4) use of a 21 gauge hypodermic needle shank (820 µm nominal outer diameter) for molding 341 
of the perforator artery, due to our printer’s inability to define such features with sufficient 342 
fidelity. Faithful reproduction of all design features is observed throughout. 343 
 344 
Representative results for PIV-based flow characterization performed using the current protocol 345 
are presented in Figures 3 and 4. These studies were performed using phantom inlet flow rates 346 
of 100 mL/min, data acquisition rates of 2000 fps, and temporal averaging over spans of 0.05 s. 347 
Figure 3 shows representative image frames within the perforator artery, before and after 348 
intensity capping as well as corresponding surface plots of the 8-bit pixel intensity values. Both 349 
demonstrate that intensity capping significantly increases peak definition above the noise floor 350 
(i.e., increases SNR), which is critical to ensuring accuracy when performing subsequent cross-351 
correlation. Figure 4 shows the effects of intensity capping and NMT operations on the velocity 352 
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vector field. Marked improvement in field uniformity is observed, thus further underscoring the 353 
importance of maximizing SNR to minimize data dropout.  354 
 355 
FIGURE AND TABLE LEGENDS:  356 
 357 
Figure 1: Particle image velocimetry setup. Reliance upon an open-source image analysis and 358 
pre/post-processing framework reduces demand upon the instrumentation for measuring meso-359 
scale flows, thus eliminating the need for many of the costly components of typical PIV systems 360 
(e.g., pulsed laser, synchronizer, cylindrical optics, &/or proprietary software). 361 
  362 
Figure 2: PDMS-based tissue phantom fabrication process: a) CAD model of neurovascular 363 
phantom mold; b) Printed ABS mold, after removal of support material; c) Casting and curing of 364 
PDMS within the ABS mold; d) Partial dissolution of ABS mold material; and e) Completed PDMS 365 
phantom, with inset showing final dimensions of critical features, as well as the region of interest 366 
(ROI) in the perforator artery where the PIV measurements were made.   367 
 368 
Figure 3: Effect of intensity capping operation on image SNR. Representative image frame and 369 
corresponding pixel intensity surface plots within the perforator artery, before (a, b) and after 370 
applying the intensity capping operation (c, d). 371 
 372 
Figure 4: Effects of intensity capping and NMT operations on velocity vector fields: 373 
Representative instantaneous velocity vector field within the perforator artery derived from: a) 374 
unprocessed image data; b) intensity capped data; and c) intensity capped data + NMT post-375 
processing.  376 
 377 
Figure 5: Effect of interrogation window sizing on correlation quality. Optimal window sizing 378 
occurs when the value of the zero-normalized correlation coefficient is maximized, and the 379 
standard deviation is minimized. 380 
 381 
DISCUSSION:  382 
The protocol described herein outlines a simplified method for performing PIV studies to visualize 383 
neurovascular flows at physiologically-relevant dimensions and flow conditions in vitro. In doing 384 
so, it serves to complement protocols reported by others that have also focused on simplifying 385 
the quantification of vector fields, but within very different contexts that require consideration 386 
of far larger length-scales25 or lower flow rates26, 27(e.g. atmospheric or microcirculatory flows), 387 
and thus, reliance upon schemes that are incompatible with the current application.  388 
 389 
The most important considerations for successful implementation of PIV lie in the minimization 390 
of flow field artifacts and maximization of image quality. Several steps in the tissue phantom 391 
fabrication process are critical to both of these criteria. For example, thorough degassing is crucial 392 
since air entrained within the PDMS during mixing can lead to bubble formation within the final 393 
phantom, which can adversely affect both feature fidelity and optical clarity. Additionally, 394 
minimization of surface roughness of the ABS mold is desired, since the PDMS casting process 395 
faithfully reproduces even the most minute imperfections (e.g., build lines, surface pores, 396 
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scratches, etc.), thus resulting in surface roughness in the final phantom that can decrease optical 397 
clarity and increase potential for bead accumulation. While the protocol described herein has 398 
proven sufficient for the current application, there are numerous reports in the literature of 399 
means for reducing such roughness, should there be need (e.g., acetone vapor smoothing28, or 400 
optimization of layer thickness and part orientation with respect to build direction)29. 401 
 402 
Parameter selection for video capture is also critical to ensure a high-fidelity vector field. Optimal 403 
SNR is typically achieved at the highest achievable frame rate that still allows sufficient bead 404 
exposure (maximum frame rate being limited by minimum exposure time). Gain can be used to 405 
amplify the signal, but this also increases sensor noise. If the maximum velocity can be estimated 406 
from other flow parameters (e.g., inlet volumetric flow rate), then a lower bound on the required 407 
frame rate can be estimated using the following relation30: 408 

 409 

𝑓𝑠𝑎𝑚𝑝𝑙𝑖𝑛𝑔 >
𝑣𝑚𝑎𝑥∙𝑐𝑐𝑎𝑙𝑖𝑏𝑟𝑎𝑡𝑖𝑜𝑛

ℎ𝑖𝑛𝑡𝑒𝑟𝑟𝑜𝑔𝑎𝑡𝑖𝑜𝑛 𝑤𝑖𝑛𝑑𝑜𝑤
 (1) 410 

 411 
where fsampling is the camera acquisition rate (Hz), vmax is the maximum expected velocity (mm/s), 412 
ccalibration is the calibration constant (pixels/mm), and hinterrogation window is the size of the 413 
interrogation window (pixels). However, more optimal values can be determined using so-called 414 
correlation quality estimation techniques, such as the zero-normalized correlation coefficient11. 415 
In this technique, the averages of complementary signals from each frame-pair are first 416 
subtracted, and then normalized by the standard deviation of their intensities11. If a displacement 417 
of the original signal exists, such that all peaks and valleys match, the time-shifted value of this 418 
signal will be equal to one. Conversely, if there is no displacement that can align these signals, 419 
the value will be zero. This information is included in the ImageJ PIV output for each vector, and 420 
it can be plotted as its own field to verify whether there are spatial effects contributing to poor 421 
correlation (e.g., uneven lighting). The correlation coefficient can also be averaged over a field as 422 
an overall estimate of its quality. Finally, this quantity may also be plotted against varying frame 423 
rates or interrogation window sizes to determine an optimum. Figure 5 illustrates the results 424 
from such an analysis using a Monte-Carlo synthesized particle field with displacements 425 
consistent with our experimentally-measured flows (a typical technique for characterizing 426 
correlation quality11). The results show that the interrogation window size and frame rate should 427 
be chosen such that a particle field is displaced by ≤ 20% of the interrogation window size per 428 
frame-pair to maximize the correlation coefficient, while minimizing its variability.  429 
 430 
Although the protocol described herein has proven sufficient for meeting the needs of the 431 
current application, it is important to acknowledge its limitations. For example, while contrast 432 
enhancement via intensity capping offers ease of implementation, transformations of the entire 433 
distribution of pixel intensities may improve SNR further31. Similarly, although correlation-based 434 
tracking is well-established and provides sufficient resolution for reliably estimating first-order 435 
flow characteristics relevant to hemodynamics (e.g., intra-aneurysmal velocity), other techniques 436 
may offer higher spatial resolution (e.g., hybrid PIV/PTV, least squares matching)32, 33, and thus 437 
greater accuracy when considering characteristics that are more sensitive to velocity field 438 
resolution (e.g., wall shear stress, in-plane vorticity). Likewise, while the NMT provides a means 439 
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for improving the velocity vector field after cross-correlation, it is important to emphasize that 440 
this is just one of many vector validation techniques that could be used24, 34, each with their own 441 
unique advantages and disadvantages that may make their use more suitable for applications 442 
beyond those described here. Lastly, while our experimental setup seeks to mimic 443 
physiologically-relevant flow rates and length scales for the neurovasculature, it does not 444 
currently allow the analysis of pulsatile flows. This has not been a limitation for our current 445 
application, since the range of Womersely numbers in much of the neurovasculature tends to be 446 
≤ 1 (i.e., there is minimal additive effect of multiple cardiac cycles)35, which suggests that steady-447 
state conditions are sufficient to recapitulate discrete time points along the cardiac waveform in 448 
which the flow rate is comparable. However, for applications where the Womersely number is 449 
larger (e.g., vasculature closer to the heart), we envision potential for introducing pulsatility 450 
through the use of an Arduino, which could be used to send the pump a time-varying PWM 451 
voltage waveform that enables mimicking of a cardiac flow profile36–38. 452 
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